Two address cards/records after syncing using special characters

RESOLVED WONTFIX

Status

defect
--
major
RESOLVED WONTFIX
16 years ago
5 years ago

People

(Reporter: nbaca, Unassigned)

Tracking

(Depends on 1 bug, {dataloss, intl})

Dependency tree / graph

Details

Reporter

Description

16 years ago
Trunk build 2003-05-13: WinMe

Overview: Edit a record on the palm device, sync and sometimes two cards appear
on  both sides (palm device and Mozilla AB). The first card includes the
original data and the second card includes the additional data. 

I have only seen this problem with records that use special characters so
far(i.e. Euro, Trademark, Yen symbols)

Steps to reproduce, although it doesn't happen consistently:
1. Create records on the palm device using special characters (First Name, Last
Name) 
a. Euro --> alt+0+128 = €
b. Tradmark --> alt+0+153 = ™
2. Perform a palm sync
3. Edit the record on the palm device by adding an email address
4. Perform a palm sync
5. Edit the record by adding phone number and address data
6. Close the application (not sure if this is necessary)
7. Perform a palm sync

Actual Results: 2 records/cards appear on both sides (palm device and Mozilla
AB). The first card includes the First Name, Last Name and Email address. The
second card includes the same data and also the additional data for the phone
number and address areas.

Expected Results: Onlye on record/card should appear which should include all
the data.

Note: I will attach a log file which might shed light on when this problem
exactly occurs.
Reporter

Comment 1

16 years ago
The log file unfortunately was empty. Will have to try and recreate one again.
Keywords: nsbeta1

Comment 2

16 years ago
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-
Product: MailNews → Core

Updated

14 years ago
Assignee: cavin → nobody
QA Contact: nbaca
Summary: Two cards/records appear after syncing (using special characters) → Two address cards/records after syncing using special characters
probably a dup, but taking a more conservative approach making bug 237624 a blocker

(rcloseirl did not respond to mail)
Assignee: nobody → bienvenu
Depends on: 237624
QA Contact: vseerror

Updated

14 years ago
Severity: normal → major
Keywords: dataloss, intl
*** Bug 310290 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
Assignee: bienvenu → nobody
QA Contact: vseerror → palmsync

Updated

10 years ago
Product: MailNews Core → MailNews Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.