palmsync.xpi - problem syncing Contacts with Danish letters, umlauts (ä, ü, ö, ß), diacritics, etc in names - regression starting with TB 1.5

RESOLVED WONTFIX

Status

defect
--
critical
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: bo2hansen, Unassigned)

Tracking

({dataloss, intl, regression})

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When syncing contacts with Palm Pilot (Treo 650 - Palm OS Garnet v. 5.4.7) I am
experiencing problems with contacts created (or changed) on the Palm containing
Danish letters (æøå,ÆØÅ) in their names. Eg. Testætest Testøtest (first last)
becomes Test?test Testtest in Mozilla Address Book (MAB).

If I am "correcting" the names on the pc and sync back I have two contacts: A
wrong one and a correct one. If I then delete the wrong one on the Palm and add
some details to the correct one and syncs, a new wrong one is created in MAB and
the correct one is left unchanged.

I've noticed this behavior after upgrading to Thunderbird 1.5b1 and using the
palmsync.xpi from
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/extensions/palmsync/1.5b1/ -
but the problem may have existed before, without me noticing it.

Reproducible: Always
character set issue

*** This bug has been marked as a duplicate of 237624 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Address Book → MailNews: Palm Sync
Product: Thunderbird → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Reporter

Comment 2

14 years ago
I find it strange that this should be a duplicate of 237624 since I haven't
experienced these problems before (before TB1.5b1 or before upgrading from a
m125 to a Treo 650).

Has anything changed in either the addressbook, the sync app or in the Palm's
contacts DB?

Any suggestions to what I should be dig a little deeper?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #2)
> I find it strange that this should be a duplicate of 237624 since I haven't
> experienced these problems before (before TB1.5b1 or before upgrading from a
> m125 to a Treo 650).
> 
> Has anything changed in either the addressbook, the sync app or in the Palm's
> contacts DB?


> Any suggestions to what I should be dig a little deeper?

similar to or dup of Bug 205587
(In reply to comment #2)
> I find it strange that this should be a duplicate of 237624 since I haven't
> experienced these problems before (before TB1.5b1 or before upgrading from a
> m125 to a Treo 650).

David, should he try the beta version of palmsync for TB 1.5?


> Has anything changed in either the addressbook, 
> the sync app or in the Palm's contacts DB?

David or Mscott should know.

 
> Any suggestions to what I should be dig a little deeper?

Go to: Control Panel > System > Advanced > Environmental Variables.
Then setup the variable MOZ_CONDUIT_LOG with a value of C:\mozconduitlog.txt.
c:\mozconduitlog.txt will log your hotsync progress.

post or attach the log to this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #2)
> I find it strange that this should be a duplicate of 237624 since I haven't
> experienced these problems before (before TB1.5b1 or before upgrading from a
> m125 to a Treo 650).

Bo, need your feedback.

I missed your comment about having changed to TB1.5b1. It's possible there is an issue with TB1.5.  

But first, did you use http://ftp.mozilla.org/pub/mozilla.org/thunderbird/extensions/palmsync/1.5b1/palmsync.xpi

Also note relevant comments in bug 183397 and 214407, eg. do you have the newest possible software available for treo from palm?
Assignee: mscott → bienvenu
QA Contact: address-book → vseerror

Updated

14 years ago
Whiteboard: dupme Bug 205587?
per Bo symptoms match bug 205587 (whuch depends on bug 237624)

*** This bug has been marked as a duplicate of 205587 ***
Severity: normal → major
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Keywords: dataloss, intl
Resolution: --- → DUPLICATE
Whiteboard: dupme Bug 205587?
Bo in comment #2:
> I find it strange that this should be a duplicate of 237624 since I haven't
> experienced these problems before (before TB1.5b1 or before upgrading from a
> m125 to a Treo 650).
> 
> Has anything changed in either the addressbook, the sync app or in the Palm's
> contacts DB?
> 
> Any suggestions to what I should be dig a little deeper?

Correcting my my error(s). Bo is correct. This is definitely a regression - it worked in Thunderbird 1.0 (core 1.7).  My best guess is caused by bug 209699.  see also bug 237624 comment 23.

The approximate regression range 2004-09-17 - 2005-09-08.  I have a slightly (but not much) narrower range that I'll post later.
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: DUPLICATE → ---
Version: Trunk → 1.8 Branch

Updated

12 years ago
Duplicate of this bug: 311371
list of possible causes for the regression which includes bug 209699 http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fmailnews%2Fextensions%2Fpalmsync&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-09-17+00%3A00%3A00&maxdate=2005-09-08+00%3A00%3A00&cvsroot=%2Fcvsroot
Summary: palmsync.xpi - problem syncing Contacts with Danish letters in their names → palmsync.xpi - problem syncing Contacts with Danish letters, umlauts (ä, ü, ö, ß), diacritics, etc in names - regression starting with TB 1.5
note comment 7. 

tutorial/simplified instructions at http://wsm.wetpaint.com/ for getting the palm emulator and palmsync extension up and running 

changing to sev=critical consistent with dataloss
Severity: major → critical
Product: Core → MailNews Core
just reread bug 237624 comment 0 ...

From  Jungshik Shin   2004-03-16 01:28:01 PDT   (-) [reply]

As far as I know, Palm doesn't use Unicode but it uses one of legacy
(locale-dependent) encodings. It seems like Palm-Sync code in Mozilla assumes
ISO-8859-1. There should be a way to change the default character encoding for
Palm Sync. 

I don't have a Palm, but the problem was reported at http://www.mozilla.or.kr by
a Korean Mozilla/TB user.

------- Comment #1 From Robert Accettura [:raccettura] 2004-03-16 17:43:41 PDT (-) [reply] -------

I've never seen a Palm Conduit with an option to select character encoding.  

I think we should perhaps be looking to autodetect this perhaps by following
whatever the address book uses?

------- Comment #2 From Jungshik Shin 2004-03-17 09:52:22 PDT (-) [reply] -------

(In reply to comment #1)
> I've never seen a Palm Conduit with an option to select character encoding.

 Please, execuse me if I say something stupid. I've never owned Palm and I'm not
sure how this synchronizing works. I'm assuming that there are two parties, Palm
and Mozilla/TB.  Because Palm OS has no notion of character encoding, Palm will
just 'emit' a stream of bytes (and I guess Palm Conduit will just pass through
the stream of bytes/octets as they're). This bug is about how to interpret the
stream of bytes sent from Palm (via Palm conduit?) on Mozilla's side. Because
Mozilla uses Unicode, we can't just store the stream of bytes as they're, but we
have to 'interpret' bytes and convert them to Unicode. Currently, we interpret
the stream of bytes/octets in ISO-8859-1, which doesn't work for
non-Western-European users. It may not even work for Western European users
because what's used on Palm OS (in English/Western-European version) could well
be Windows-1252 instead of ISO-8859-1.

The other way around (when sending the content of Mozilla/TB's address book to
Palm),  we have to convert Unicode strings to what's used on Palm's side (a
sequence of bytes whose interpretation will depend on the language/locale of
Palm OS in use, which must be user-dependent.)
QA Contact: vseerror → palm-sync

Updated

10 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard

Updated

10 years ago
Assignee: bienvenu → nobody
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.