Compact folders should be enabled by default

RESOLVED DUPLICATE of bug 437657

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 437657
15 years ago
7 years ago

People

(Reporter: Dirk Feytons, Unassigned)

Tracking

({privacy})

Trunk
privacy
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

In "Preferences" -> "Offline & Disk Space" the option "Compact folders when it
will save over nnn KB" should be enabled by default.

Very often someone reports in n.p.m.mail-news that although they delete emails
their mailbox files don't shrink. They ask if it's a bug and someone else
explains it's a feature and tells them about compacting folders. None of the
posters seem to have known about compacting folders; some have noticed it
sitting in de File-menu but didn't know what it meant.

Therefore I suspect a lot of users have huge mailbox files and know nothing
about compacting folders to trim those files down. It's my opinion that the
above mentioned option should be enabled by default so compacting occurs
automatically. In this context bug 115499 (remove warning dialog before
compacting folders) might be worth a look.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Confirming, but adding dependency on bug 152675, which can crop up if 
auto-compact is turned on.
Status: UNCONFIRMED → NEW
Depends on: 152675
Ever confirmed: true

Updated

15 years ago
Blocks: 229034
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 2

12 years ago
What will be the future of this bug? Is this functionality desired by mozilla.com?

Comment 3

12 years ago
On the geckozone forum (french help about mozilla products), there is a LOT of problems that would be evitated if the folder can autocompact themselves... 
It is unbelievable that the normal way of using Thunderbird made him become less and less performant...
I hope something will be done!

Comment 4

11 years ago
I've experienced this problem many times with users who expected "thunderbird" whould just work, without having to learn about compacting manually or browsing all the options. Most of the time, when someone is calling the "geeky friend" when they have an issue about thunderbird (even if I didn't install it myself)n it's because this option wasn't turned on. Please check it by default, and set it to around 6000 kb and it will just work better for thunderbird users.

If thunderbird can't delete properly unwanted emails "because of bug 152675", there is a strong issue with this email client, which is very good otherwise. Maybe the other bug is happening when there is too much data to compact ? I've never experienced it btw. Maybe it could really delete the unwanted emails when the trash bin is emptied, and it will always work this way (it's just about deleting some text into a data file...)
Keywords: privacy
Assignee: mail → nobody
QA Contact: esther → message-display

Comment 5

8 years ago
Still some users on geckozone forums have corrupted inbox because they don't use "compact folder" (and do not understand what it is...).

Comment 6

8 years ago
I think this bug is duplicate of this one: https://bugzilla.mozilla.org/show_bug.cgi?id=341206 (apply for Thunderbird instead of seamonkey). Can anyone confirm?

Comment 7

7 years ago
The default was changed to "true" as part of bug 437657 and is effective in SeaMonkey starting with the 2.1 release (coming up any time soon now).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437657
You need to log in before you can comment on or make changes to this bug.