Closed Bug 205826 Opened 18 years ago Closed 18 years ago

Setting the helper application to mozilla.exe causes mozilla to open recursively and crash the system

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 167320

People

(Reporter: mrjdoh, Assigned: law)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

I set application/x-perl to be "open using mozilla.exe". When I subsequently clicked on a .pl file on a webpage, it opened another mozilla window, which opened another, and another, ...

Reproducible: Always

Steps to Reproduce:
1. Preferences -> Helper Applications -> application/x-perl to be handled by mozilla.exe in programme files directory.
2. Find a webpage with anyfile.pl, which is not doing the .pl file as DHTML.
3. Click on it and watch your memory and CPU usage.

Actual Results:  
My machine died.

Expected Results:  
A warning to say that you can't specify mozilla.exe as the helper application? Or if a new mozilla window is started, don't let it recursively try to open it with another instance of mozilla?

*** This bug has been marked as a duplicate of 167320 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.