Closed Bug 167320 Opened 22 years ago Closed 9 months ago

eternal/endless/infinite loop when associating Firefox/SeaMonkey/Mozilla as a helper application for a given file type

Categories

(Firefox :: File Handling, defect)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: chimera, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted)

Attachments

(1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826

I think the download manager should either prevent the user from choosing
mozilla itself as "open with", or (better) figure out that the user wants the
file opened in the browser, not by the download manager at all.

Reproducible: Always

Steps to Reproduce:
1. download a binary file
2. choose mozilla.exe to handle file
3. uncheck the box 'always ask'
4. have fun...
QA Contact: sairuh → petersen
*** Bug 201565 has been marked as a duplicate of this bug. ***
*** Bug 214157 has been marked as a duplicate of this bug. ***
*** Bug 205826 has been marked as a duplicate of this bug. ***
*** Bug 208636 has been marked as a duplicate of this bug. ***
.
Assignee: blake → law
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Download Manager → File Handling
Ever confirmed: true
*** Bug 215554 has been marked as a duplicate of this bug. ***
*** Bug 222833 has been marked as a duplicate of this bug. ***
*** Bug 229852 has been marked as a duplicate of this bug. ***
Assignee: law → cbiesinger
QA Contact: chrispetersen → ian
Summary: Eternal loop when associating mozilla.exe with file type → Eternal loop when associating mozilla.exe with file type as helper application
*** Bug 213316 has been marked as a duplicate of this bug. ***
*** Bug 208231 has been marked as a duplicate of this bug. ***
*** Bug 235027 has been marked as a duplicate of this bug. ***
*** Bug 264356 has been marked as a duplicate of this bug. ***
Assignee: cbiesinger → file-handling
*** Bug 266598 has been marked as a duplicate of this bug. ***
*** Bug 276343 has been marked as a duplicate of this bug. ***
*** Bug 280462 has been marked as a duplicate of this bug. ***
*** Bug 295955 has been marked as a duplicate of this bug. ***
*** Bug 317670 has been marked as a duplicate of this bug. ***
*** Bug 316261 has been marked as a duplicate of this bug. ***
An enhancement would be to have an additional choice in the download window ("What should Firefox do with this file?"):

"Attempt to display file"

This would force the browser to render it internally, using whatever fallback mechanisms the browser has, ignoring MIME type.

In most cases, this will work just fine.  There's a lot of websites out there that serve content that can be seen just fine in a browser, but for whatever reason has the wrong MIME type encoded, or has the EMBED tag around it, or something like that.  This confuses the browser, and so the user can't easily open the content just by clicking on it.

If there's already a bug open for this enhancement, please link it here.
In response to comment #19: the enhancement is in Bug 196078 for text/* documents, and Bug 57342 for everything else. 
*** Bug 351223 has been marked as a duplicate of this bug. ***
Summary: Eternal loop when associating mozilla.exe with file type as helper application → eternal/endless/infinite loop when associating Firefox/SeaMonkey/Mozilla as a helper application for a given file type
Assignee: file-handling → nobody
QA Contact: ian → file-handling
Would it not be possible to detect that the file open request came from the OS (command line parameter) and not defer to helper applications in that case, ie. error message.

Trying to detect the source or destination seems foolhardy.

(I'm not sure if this is the right bug. Bug 218257 Bug 215554 are newer.)
Maybe, but the problem is of course that the code that does the helper app launching doesn't know that the URL came from the command line, so this would require quite a bit of code changes.
Oh guys, I'm so sorry this was a dupe. I really did look at the list given and used the keywords of ".do open file" and "infinite loop" to try to find it but there was a list SOOOO long and it was definitely not in the first 100 that came back. I don't mean to fill up the system with dupes, but it sure would be nice to have this fixed! Thank you for checking it out. :) Your work on this browser is VERY appreciated!! Firefox is the best!
This bug is like an easter egg! 10 years old, critical but most people probably don't hit it ;) I hit it trying to open PDFs, it wasn't opening in Aurora so I tried choosing Aurora. It worked for the first PDF I tried it on, then the 2nd one looped :D At least the browser was responsive and I could exit (yay session store!)
Product: Core → Firefox
Version: Trunk → unspecified
I'm curious why we still allow FF to select itself and loop in such a way, especially considering how easy it is to do and it can effectively brick the profile (and system if it has low resources).
See Also: → 218257
Hardware: x86 → All
See Also: → 1534864
See Also: → 1555637

This is still happening in 71.0b6 (64-bit) on Windows 10.

:david.beers, Is this still happening in Firefox 74?

Still happening in 75.0b5 on macOS Catalina

(In reply to Tawanda Kanhema from comment #57)

:david.beers, Is this still happening in Firefox 74?

Sorry for not responding! It does not seem like it's happening on 76.0b3 on Windows 10 1909 64-bit build 18363.752. I downloaded a test .zip file from https://www.thinkbroadband.com/download and chose Firefox to "Open with". The file downloads and Firefox tries to open it from the local storage which just makes it ask to download it again. Is that what's supposed to happen? Either way, I'm not getting an endless loop of anything.

QA Whiteboard: qa-not-actionable

This is still happening with Firefox Developer Edition 99.0b4 (64-bit).

Why is this not fixed yet?

This is a real bug, which results in tabs opening repeatedly until, presumably, the system runs out of memory. I didn't try to find the upper limit.

The problem is that desktop helpers are smarter than Firefox is. I'm seeing this on files which contain XML but have file extensions that don't directly indicate XML. The desktop helper uses something like /usr/bin/file to determine that the file contains XML, and knows it doesn't otherwise have a handler for it. Then the desktop tries to open the file with Firefox (because it has a nice xml viewer/parser), which opens a tab for it, but then doesn't recognize the extension, so Firefox sends it back to the system, which determines that the file is XML and hands it back to Firefox, which opens another new tab, etc., in a repeating loop.

To observe the problem, go here:
https://www.repeaterbook.com/repeaters/details.php?state_id=12&ID=3720
and click on "Coverage Plot" without Google Earth installed.

Yes. it's a google earth file. No, the solution isn't to install Google Earth. Without Google Earth the system will open it up as a zip file. Then try to open the doc.kml inside it.

Listen, I know this isn't the desired use for these files, but without appropriate handlers installed (in this case Google Earth), it should be completely reasonable to open a zipped file as a zip and an xml file as xml. Even so, the failure mode needs to be something other than opening tabs until memory is exhausted. One may, for example, see the doc.kml file, alongside the two png files (in the compressed file), and make an educated assumption (correctly) that it's an XML file and want to look at it, and assume that double-clicking on an xml file won't cause firefox to have to be killed.

As this has been proven to be a bug, that can easily be reproduced, I am wondering why it is still open 20 years on! I know that mostly "power users" or techies might hit this occasionally, but it would be good to know if it IS going to be worked on at some stage, as users accidentally hitting this, would NOT want to get the loop ad memory exhaustion.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Tony Davis from comment #77)

As this has been proven to be a bug, that can easily be reproduced, I am wondering why it is still open 20 years on! I know that mostly "power users" or techies might hit this occasionally, but it would be good to know if it IS going to be worked on at some stage, as users accidentally hitting this, would NOT want to get the loop ad memory exhaustion.

Actually, I've done a bunch of work much more recently (than 20 years ago...) to stop this happening, see e.g. bug 1678255, bug 1633790, bug 1496380, bug 1750253.

It would be useful to have more information about what exactly you do to hit this case still, on what operating system, with what filetype, and what download preference changes you make - from a clean Firefox profile.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(ard1947)

Given that Alan Ott in comment #76 had mentioned an STR to show the bug is still there, that is why I added my comment in here, as comment #76 is only 3 months old. I guess the best way of moving forward (as you have done a lot of work on this as you say, and apologies if you thought I was saying otherwise), would be to check back with Alan Ott, to see if he is still on FF98 (as the BUG 1750253 says ths loop has been fixed in that level), or if this STR is a special case with .KMZ file types that have not been catered for? I see that BUG 1750253 (now osoleted) mentions "spam tabs" (possibly your internal language for Tab Loops) and the fix might not scope in enough unusual file types?

Flags: needinfo?(ard1947)

(In reply to Tony Davis from comment #79)

Given that Alan Ott in comment #76 had mentioned an STR to show the bug is still there,

I can't reproduce with those steps. The kmz doesn't open as a zip file automatically for me, and after manually unzipping, drag-dropping the unzipped kml file to Firefox works just fine and shows the raw XML. I tried to reproduce on macOS - it's not even clear from the comment what OS Alan is seeing this on or how some of the "open this file" actions are done (drag drop, from the file explorer, from the download panel, some other way).

Honestly at this point I think the best way to pursue this issue is for people who are still seeing this to provide significantly more detail around how they are reproducing it. See also some of the questions I just asked in bug 1807260 comment 3 (which is really a dupe of this bug, but I figured the conversation would be easier to follow in a separate bug report with a smaller number of comments & audience).

See Also: → 1807260

In the process of migrating remaining bugs to the new severity system, the severity for this bug cannot be automatically determined. Please retriage this bug using the new severity system.

Severity: critical → --

bug 1807260 was fixed in 108 and I haven't heard new complaints along these lines since then (ie over the past ~6 months or so). I'm going to close this out. If you can still reproduce this on Firefox 114 (released tomorrow), please file a separate bug with specific details, and add a needinfo request for me, and I'll take a look. :-)

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.