If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

find in the "view source" window broken

VERIFIED DUPLICATE of bug 6544

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 6544
18 years ago
16 years ago

People

(Reporter: buster, Assigned: kinmoz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
1) open any url in mozilla.exe
2) view source
3) Search > Find on this page
4) type in a string to search for
5) click Find
6) assert with this stack:

nsDebug::Assertion(const char * 0x02fb3d18, const char * 0x02fb3d0c, const char
* 0x02fb3cd4, int 2514) line 284 + 13 bytes
nsTextServicesDocument::GetBodyNode(nsIDOMNode * * 0x0012d328) line 2514 + 32
bytes
nsTextServicesDocument::CreateBodyContentRange(nsIDOMRange * * 0x0012d348) line
2538 + 32 bytes
nsTextServicesDocument::CreateBodyContentIterator(nsIContentIterator * *
0x02f8b4d0) line 2670 + 32 bytes
nsTextServicesDocument::InitWithDocument(nsTextServicesDocument * const
0x02f8b4c0, nsIDOMDocument * 0x02d35494, nsIPresShell * 0x02ce0370) line 261 +
35 bytes
nsFindComponent::Context::MakeTSDocument(nsFindComponent::Context * const
0x02ed8a70, nsIWebShell * 0x02cd59c0, nsITextServicesDocument * * 0x0012d490)
line 153 + 41 bytes
nsFindComponent::Context::DoFind(nsFindComponent::Context * const 0x02ed8a70,
int * 0x0012d6fc) line 446 + 49 bytes
nsFindComponent::FindNext(nsFindComponent * const 0x029f9bc0, nsISupports *
0x02ed8a70, int * 0x0012d6fc) line 917
XPTC_InvokeByIndex(nsISupports * 0x029f9bc0, unsigned int 8, unsigned int 2,
nsXPTCVariant * 0x0012d6ec) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x02edcc70,
nsXPCWrappedNative * 0x02f3b8b0, const XPCNativeMemberDescriptor * 0x02f3b960,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 1, long *
0x011d2f84, long * 0x0012d89c) line 894 + 43 bytes
WrappedNative_CallMethod(JSContext * 0x02edcc70, JSObject * 0x02328f48, unsigned
int 1, long * 0x011d2f84, long * 0x0012d89c) line 191 + 34 bytes
js_Invoke(JSContext * 0x02edcc70, unsigned int 1, unsigned int 0) line 665 + 26
bytes
js_Interpret(JSContext * 0x02edcc70, long * 0x0012e10c) line 2226 + 15 bytes
js_Invoke(JSContext * 0x02edcc70, unsigned int 0, unsigned int 0) line 681 + 13
bytes
js_Interpret(JSContext * 0x02edcc70, long * 0x0012e938) line 2226 + 15 bytes
js_Invoke(JSContext * 0x02edcc70, unsigned int 0, unsigned int 0) line 681 + 13
bytes
js_Interpret(JSContext * 0x02edcc70, long * 0x0012f164) line 2226 + 15 bytes
js_Invoke(JSContext * 0x02edcc70, unsigned int 1, unsigned int 2) line 681 + 13
bytes
js_InternalCall(JSContext * 0x02edcc70, JSObject * 0x02328ee8, long 36871208,
unsigned int 1, long * 0x0012f2e0, long * 0x0012f288) line 758 + 15 bytes
JS_CallFunction(JSContext * 0x02edcc70, JSObject * 0x02328ee8, JSFunction *
0x02f8d2b0, unsigned int 1, long * 0x0012f2e0, long * 0x0012f288) line 2720 + 32
bytes
nsJSContext::CallFunction(nsJSContext * const 0x02edb040, void * 0x02328ee8,
void * 0x02f8d2b0, unsigned int 1, void * 0x0012f2e0, int * 0x0012f2dc) line 468
+ 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x02f8c2c4) line 133 + 51 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x02f0f890,
nsIDOMEvent * 0x02f8c2c4, unsigned int 4) line 623 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x02f04820, nsEvent *
0x0012f7b0, nsIDOMEvent * * 0x0012f778, unsigned int 7, nsEventStatus *
0x0012fa80) line 758 + 25 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02f0f9c0, nsIPresContext *
0x02f04820, nsEvent * 0x0012f7b0, nsIDOMEvent * * 0x0012f778, unsigned int 1,
nsEventStatus * 0x0012fa80) line 2580
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0x02f23d50, nsIPresContext * 0x02f04820, nsMouseEvent * 0x0012fb74,
nsEventStatus * 0x0012fa80) line 1383 + 42 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x02f23d50,
nsIPresContext * 0x02f04820, nsGUIEvent * 0x0012fb74, nsIFrame * 0x02f29330,
nsEventStatus * 0x0012fa80, nsIView * 0x02f04210) line 652 + 24 bytes
PresShell::HandleEvent(PresShell * const 0x02f05dd4, nsIView * 0x02f04210,
nsGUIEvent * 0x0012fb74, nsEventStatus * 0x0012fa80) line 2458 + 43 bytes
nsView::HandleEvent(nsView * const 0x02f04210, nsGUIEvent * 0x0012fb74, unsigned
int 28, nsEventStatus * 0x0012fa80, int & 0) line 841
nsViewManager::DispatchEvent(nsViewManager * const 0x02f04390, nsGUIEvent *
0x0012fb74, nsEventStatus * 0x0012fa80) line 1678
HandleEvent(nsGUIEvent * 0x0012fb74) line 69
nsWindow::DispatchEvent(nsWindow * const 0x02f040d4, nsGUIEvent * 0x0012fb74,
nsEventStatus & nsEventStatus_eIgnore) line 437 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fb74) line 458
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=???
y=???}) line 3464 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=???
y=???}) line 3682
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 7012485, long *
0x0012fde0) line 2757 + 24 bytes

continue past the assert, and the find is cancelled and you can run normally.


The problem is the document in a view source panel is an XML document, and thus
has no body.  Find (and the underlying text services) should work for any *ML,
not just HTML.  The dependancy on finding the one-and-only BODY should be
removed.

Updated

18 years ago
Target Milestone: M13

Comment 1

18 years ago
setting to M13
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

18 years ago
Accepting bug.
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 3

18 years ago
Moving all TextServices/SpellChecker/Find bugs to M14.
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 6544 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
verified in 1/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.