Opening rfc822 attachment does not show image subattachments inline. [and can lead to NS_ERROR_INVALID_POINTER exception]

VERIFIED FIXED

Status

MailNews Core
Attachments
--
major
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
A message with attached images (or embedded images in an HTML message) is 
forwarded as attachment (or attached from .EML file) in another message.  That 
message is received by Mozilla; the Mozilla user opens the attachment in its own 
window.

Actual Result: images are not shown, but replaced with the no-icon image or the 
'alt' text representation.

Expected Result: images shown inline.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516

Related: bug 203570, bug 204253.
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4) Gecko/20030612]

Bug still there.

You can use bug 209899 attachment 126146 [details] as a testcase:
The subattached image is displayed:
*"correctly" in the main message. (maybe because of bug 203570)
*"as a "broken" icon in the submessage. (this bug)
Addition to comment 1:

(I meant "Confirming on v1.4rc2 on W95.)


Second part to this bug:

1. Right click the "broken" icon
2. Choose "Save Image As..."

Get 1 JS error
[
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER) [nsIURIChecker.asyncCheckURI]"  nsresult:
"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://communicator/content/contentAreaUtils.js :: nsHeaderSniffer :: line
421"  data: no]
]

Changing:
*(S) 'Normal' -> 'Major'
Severity: normal → major
Summary: Opening rfc822 attachment does not show image subattachments inline → Opening rfc822 attachment does not show image subattachments inline. [and can lead to NS_ERROR_INVALID_POINTER exception]
[Netscape® Communicator 4.8 : en-20020722]

Not '4xp', since v4.8 displays:
*everything in the main message (like comment 1)
*the ".msg" attachement (and its image) in a browser (not in a mail window).
*NB: The image attachement is shown as a link, which can be clicked.


[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3.1) Gecko/20030425]

Probably not 'regression', since v1.3.1 displays:
*the ".eml" attachement as _source_ in a browser (not in a mail window).
*NB: That was another bug/enhancement fixed at some date.
Product: MailNews → Core
No longer blocks: 279650
Depends on: 279650
Depends on: 269826
Blocks: 279650
No longer depends on: 279650
Blocks: 269826
No longer depends on: 269826
(Reporter)

Comment 4

13 years ago
xref bug 174692
No longer blocks: 279650

Comment 5

13 years ago
fixed as part of work in 203570
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
VERIFIED with Seamonkey latest-trunk 2005102717(win32 ZIP build) on Win-2K.
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.