Forward a message which includes an attached web page and images are broken

RESOLVED DUPLICATE of bug 144276

Status

RESOLVED DUPLICATE of bug 144276
16 years ago
10 years ago

People

(Reporter: nbaca, Assigned: cavin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

16 years ago
Trunk build 2003-04-29: WinMe, Mac 10.1.5

Overview: Forward a message which includes an attached web page
(www.google.com), retrieve the message and the images do not appear.

Steps to reproduce:
1. In a new message window select File|Attach Web Page and type
http://www.google.com
2. Send the message to yourself
3. View the message and the google images are present
4. Forward the message back to yourself (preferences are set to Forward Inline)
5. View the message 

Actual Results: The google images are broken.

Seth looked at the image sources and the problem may be that the forwarded
messages are missing these two lines:

Content-Base: "http://www.google.com/"
Content-Location: "http://www.google.com/"

After placing these two lines in the messages source then the images appeared.

Expected Results: The images should be present
(Reporter)

Comment 1

16 years ago
Marking nsbeta1 so that this is fixed at some point.

This problem was also present in N7.02.
Keywords: nsbeta1

Comment 2

16 years ago
adt: nsbeta1+/adt2
Assignee: ducarroz → cavin
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
sounds mime related, keeping kaie / ducarroz in the loop.

Comment 4

16 years ago
adt: nsbeta1-
Keywords: nsbeta1+ → nsbeta1-

Comment 5

16 years ago
I confess I had never seen this feature before.

I just tried to reproduce this bug on Linux with the latest trunk build.
Actually, I was unable to attach a web page at all!

When I followed your steps, Mozilla didn't even send the message. It complained
with "There was a problem including the file www.google.com ...".

Do you see this message, too?

Comment 6

15 years ago
>------- Additional Comment #5 From Kai Engert 2003-05-26 00:33 -------
>
>I confess I had never seen this feature before.
>
>I just tried to reproduce this bug on Linux with the latest trunk build.
>Actually, I was unable to attach a web page at all!
>
>When I followed your steps, Mozilla didn't even send the message. It complained
>with "There was a problem including the file www.google.com ...".
>
>Do you see this message, too?

You can try www.mozilla.org  and then you will see the bug.

Comment 7

15 years ago
I've seen no problem sending mail with a webpage attached in 1.4 final or a 
current 1.5b, under Windows; however, Kai may have encountered bug 140743.

Note that (of course) to see the images in the message, you must clear the 
setting for
  Preferences | Privacy&Security | Images |
    Do not load remote images in Mail & Newsgroup messages

If the original message is forwarded as an attachment, the images are loaded 
correctly in the containing message; the problem occurs only with forwarding 
inline.
Related: bug 206278 description.

Comment 9

15 years ago
This appears to be a dupe of bug 144900 -- but Ducarroz says there, that bug is 
also a dupe of an earlier bug...

Comment 10

15 years ago
I've found the dupe, and copied over the important information from this bug's 
original report, re: content-base and content-location.

*** This bug has been marked as a duplicate of 144276 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.