Mozilla not supporting Devnagari(hindi)/gujarati text entering in its text boxes.

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Spundun, Assigned: smontagu)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6

I tried with french and it works but if I try to enter text in devnagari or
gujarati... that doesnt work.

I am using the setup of IndLinux http://sourceforge.net/projects/indlinux/ is
the url of the project. They provide keyboard maps for Devnagari and other
indian languages to work with unicode. I can successfully use my setup with
gnome software like gedit and gaim. I am using the gkb applett to switch the
keyboard layouts. 
When I switch to french keyboardlayout ... it works, I can type in french
(typing the question mark prints the funny dna like character). 
But when I switch to Devnagari and press both the shift keys (to switch between
english layout and devnagari... which works with gedit,gaim) and then type
anything.... the cursor doesnt move... I dont see anything happening.

I cannot type devnagari in say the yahoo mail forms... or compose my own mail in
mozilla.

Spundun

Reproducible: Always

Steps to Reproduce:
1.Install IndLinux as per the README guidance
2.configure and try gkb with Devnagari layout
3.try to type in anyof the mozilla boxes

Actual Results:  
nothing happens

Expected Results:  
devnagari unicode text should appear

Comment 1

15 years ago
If you use a --enable-ctl build for mozilla this problem will not occur.

For more details see http://geocities.com/alkuma/seehindi.html (refresh)

Comment 2

15 years ago
> For more details see http://geocities.com/alkuma/seehindi.html (refresh)

This page has moved.
http://devanaagarii.net

Comment 3

15 years ago
Sun's fonts now come in truetype as well and they work with Xft-build of Mozilla
with CTL-enabled.
Would you update your page? (see bug 203406)

(Reporter)

Comment 4

14 years ago
Sorry guys ... but since my laptop got stolen.. I have bought a new powerbook
and I am working on Mac osx so cant test this bug with newr versions of Mozilla
and Firefox... As far as I am concerned... you can close this bug.. but I dont
know if its fixed or not.

Meanwhile for MacOS X .. I have filed an new bug #249618

Spundun
*** Bug 266655 has been marked as a duplicate of this bug. ***
*** Bug 308893 has been marked as a duplicate of this bug. ***
QA Contact: amyy → i18n
(Reporter)

Comment 7

7 years ago
Closing this bug.

Firefox has gone through many generations since I opened this bug, and so have my macbookpros. But I just installed VMWare and used firefox through an ubuntu virtual machine and sure enough, gujarati keyboard layout works like a charm. SO this bug has been fixed, probably for many years.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.