[FIX]Back does not refill forms for application/xhtml+xml pages

RESOLVED FIXED in mozilla1.8alpha6

Status

()

defect
P1
critical
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: berend, Assigned: bzbarsky)

Tracking

(Blocks 1 bug, {dataloss})

Trunk
mozilla1.8alpha6
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

See for example bug #138499. Exactly the same thing.

For pages served as application/xhtml+xml the form data is not restored when you
go back, but you get the initial values.

Reproducible: Always

Steps to Reproduce:
Just load my form.xhtml and form.html. This already shows the behaviour.
Actual Results:  
If you remove the data in the text area, press Save and go back, your data is
there again.

Expected Results:  
Behave like the text/html mode. That one works fine.
Reporter

Comment 1

16 years ago
Reporter

Comment 4

16 years ago
I forgot to mention that this bug was already present in Mozilla 1.3.0. I
upgraded to 1.4 to see if it was still there, and it is.
Reporter

Updated

16 years ago
Summary: Back button does not work properly for pages serves as application/xhtml+xml → Back button does not work properly for pages served as application/xhtml+xml

Comment 5

16 years ago
confirmed with linux trunk 20030522

==> session history (or form controls?)
Assignee: dveditz → radha
Status: UNCONFIRMED → NEW
Component: Form Manager → History: Session
Ever confirmed: true
Keywords: dataloss
QA Contact: tpreston → petersen

Comment 6

16 years ago
Comment on attachment 123951 [details]
Form where you can edit data

simpler steps to reproduce:
1. modify the textarea
2. reload (not shift-reload)
Attachment #123951 - Attachment mime type: text/html → application/xhtml+xml
I could've sworn I've seen this bug in the system before, but I just can't find it.
Reporter

Comment 8

16 years ago
Mr Keiser, you mean #138499? Search for application/xhtml+xml.

Comment 9

16 years ago
I just lost data because of this bug while trying to post a comment at
http://simon.incutio.com/.
Severity: normal → critical
OS: Linux → All
Hardware: PC → All
Summary: Back button does not work properly for pages served as application/xhtml+xml → Back does not refill forms for application/xhtml+xml pages

Comment 10

15 years ago
If everyone that had lost data because of this bug had posted a comment and
added a vote, this bug would be number 1 in "BugZilla's Spamming Top 10".

Just added my vote ;)

Comment 11

15 years ago
My personnal weblog is in application/xhtml+xml and sometimes I lose data
because of this bug (I submit the form, an error occurs, and I want to go back).
For now I have to open Notepad and copy/paste my content into notepad before
submitting in order be sure I won't lose anything.

Updated

15 years ago
Blocks: 252729

Updated

15 years ago
Flags: blocking-aviary1.0?

Updated

15 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0-
*** Bug 267287 has been marked as a duplicate of this bug. ***
Posted patch PatchSplinter Review
Assignee: radha → bzbarsky
Status: NEW → ASSIGNED
Attachment #164304 - Flags: superreview?(peterv)
Attachment #164304 - Flags: review?(peterv)
Priority: -- → P1
Summary: Back does not refill forms for application/xhtml+xml pages → [FIX]Back does not refill forms for application/xhtml+xml pages
Target Milestone: --- → mozilla1.8alpha5
Comment on attachment 164304 [details] [diff] [review]
Patch

Sorry about the delay, I thought I'd already done this one.
Attachment #164304 - Flags: superreview?(peterv)
Attachment #164304 - Flags: superreview+
Attachment #164304 - Flags: review?(peterv)
Attachment #164304 - Flags: review+
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.8alpha5 → mozilla1.8alpha6

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: chrispetersen → docshell
You need to log in before you can comment on or make changes to this bug.