Closed Bug 20757 Opened 22 years ago Closed 22 years ago

parameterless window.open() doesn't, and prevents app quit

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: David.Chappell, Assigned: danm.moz)

References

Details

Attachments

(1 file)

It is my understanding that if the first argument to windows.open() is an empty
string or null, then a new window should be created but no document should be
loaded.  M11 attempts to load a document with an empty name.  (Which is likely
to be an index.html file, a directory listing, or an error page.)
Assignee: mccabe → vidur
Component: Javascript Engine → DOM Level 0
Reassiging to the DOM component.  window.open isn't in the core JavaScript
engine.
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.
Assignee: vidur → danm
Status: ASSIGNED → NEW
Reassigning to danm, since he's now defacto owner of window.open().
Status: NEW → ASSIGNED
Summary: window.open() with empty string or null 1st argument doesn't work correctly → parameterless window.open() doesn't, and prevents app quit
Target Milestone: M15
window.open() without parameters should open a new, blank window. Mozilla doesn't.
Added bonus: mozilla will refuse to shut down after attempting to open such a window.
Neato.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
I've applied the patch submitted above by bissiri; it explicitly skips the URL load if no URL
parameter was specified. Fixes the original complaint and also solves the secondary symptom
I mentioned just above (app refuses to quit). Thanks, masked man!
Status: RESOLVED → REOPENED
Status: REOPENED → ASSIGNED
Resolution: FIXED → ---
Oops. Patch was actually very evil. Backing out for now.
*** Bug 22487 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
After resubmitting a second patch from Matthew, we seem to get all the good behaviour
without the evil.  Not really sure what went wrong last time. Perhaps I messed up
a brace or something in my last attempt. Seems good this time. Sorry for the confusion.
You need to log in before you can comment on or make changes to this bug.