Closed Bug 208035 Opened 19 years ago Closed 18 years ago

Use backspace key for back function in Linux

Categories

(Firefox :: General, enhancement, P2)

x86
Linux
enhancement

Tracking

()

RESOLVED FIXED
Firefox1.0beta

People

(Reporter: maffew, Assigned: mconnor)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030430 Galeon/1.3.4 Debian/1.3.4.20030509-1
Build Identifier: 

The most common actions I take in my browser are:

* search with google
* go to location bar, type in an address or nickname
* paste in an address by middle-clicking on the window
* click on a link
* go back (especially when doing google searches)
* reload (especially for nicknamed or bookmarked pages)
* copy address and paste into another app

All of these should have keyboard shortcuts. And they do. 

But back and reload are very simple actions that should have single key shortcuts. 

Currently on Unix the shortcuts are awkward to find with the fingers: Alt-Left
and Ctrl-R. 

They should be the same as on Windows: Backspace and F5. If that's not possible,
other keys should be found so that only a single, easy-to-find-with-the-fingers,
key needs to be pressed for these extremely common actions.

Thanks for your work on free software.


Reproducible: Always

Steps to Reproduce:
Bug 184472 already exists for the lack of F5 reload functionality in Linux (add
yourself to the CC: list) so I'm turning this into a bug about the Back function
only.

-->Confirming
Status: UNCONFIRMED → NEW
Component: Menus → General
Ever confirmed: true
Summary: single key shortcut needed on Unix for common actions like back and reload → Use backspace key for back function in Linux
Confirming bug still present on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030804 Mozilla Firebird/0.6.1
QA Contact: asa
In 0.6 I was able to map VK_BACK to cmd_BrowserBack. But in .61 and .7 this no
longer works.

I note in bug 219203 there's some argument about what key should do a
browserback. I agree with the OP that it should be a SINGLE easy to reach key.
Double-key combos are much harder to use, a single key you can just poke at it.

At the very least, it should be mappable, but that now seems to be broken/disabled.
I have added some more discussion of this issue in bug 219203, including a
suggestion to use F12 instead of Backspace. I think the most important thing is
to have a convenient single key shortcut. Matching the behaviour that most
people are familiar with is also important though. There has to be a pretty good
reason *not* to use an existing custom, especially for such a commonly used
feature. The onus of proof I think is on the people who argue against Backspace.
Assignee: blake → bryner
I also believe just like in Windows, like the Mozilla suite, Firefox and IE, the
backspace key should go back.  If anything else, Firefox should act the same in
Windows as it does in any other OS.  Users should be able to expect that.
F5 has been fixed in the linux build, now the back-button.

I would rather have backspace as back instead of F12 or an other button, reason
for this is that it would be much easyer for people that used other browsers
before. I hope this will be fixed.
Flags: blocking1.0?
OK.
Flags: blocking1.0? → blocking1.0+
easy
Assignee: bryner → mconnor
not sure if we should do this on OS X as well, need some machead input
Priority: -- → P3
Target Milestone: --- → Firefox1.0beta
fixed branch and trunk
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Whiteboard: fixed-aviary1.0
*** Bug 251306 has been marked as a duplicate of this bug. ***
any reason we #ifndef it at all? can anybody refer to relevant HIGs?
Keywords: fixed-aviary1.0
Whiteboard: fixed-aviary1.0
Please note that SHIFT+BACKSPACE also should work to browse forward!
(In reply to comment #13)
> Please note that SHIFT+BACKSPACE also should work to browse forward!

That is exactly what happens here.
(In reply to comment #14)
> (In reply to comment #13)
> > Please note that SHIFT+BACKSPACE also should work to browse forward!
> 
> That is exactly what happens here.

OK. I have not tested it. I only wanted to make sure that you also make this
working.
Note that I have just filed bug 262905 on reverting this patch, since platform
convention on Linux, widely implemented, is to have backspace do page up in apps
that use space to page down.
You need to log in before you can comment on or make changes to this bug.