GTK:FT2 should use fontEncoding.properties file instead of hardcoding them

RESOLVED WONTFIX

Status

Core Graveyard
GFX: Gtk
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Jungshik Shin, Assigned: Jungshik Shin)

Tracking

({intl})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

15 years ago
While investigating the possibility of supporting wide custom font encodings in
GFX:FT2 (a la bug 176290, bug 177877) I realized that nsFreeType.cpp has the
hard-coded list of fonts and their font-encodings. This should be factored out
into fontEncoding.properties file as is done for Win,Mac and Xft. 

Applications of this include bug 204039, bug 203052, bug 204286, bug 176315.
(Assignee)

Comment 1

15 years ago
Created attachment 127416 [details] [diff] [review]
work in progress

It more or less works, but needs some factoring (and a couple of problems to
fix). I just want to put an interim version somewhere safer than my machine.


In this patch, I went beyond making FT2 code refer to fontEncoding.properties
file (instead of hard-coded arrays). I enabled FT2 code to deal with 'wide
custom' fonts as well as 'narrow' custom fonts. The latter is supported by the
existing code and is for MathML while the former is for CTL support.
(Assignee)

Updated

15 years ago
Depends on: 212400
(Assignee)

Comment 2

15 years ago
One line patch for bug 212400 fixed a seemingly hard-to-understand problem 
(with 'the' Korean custom font working while other custom fonts not working).  
 
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Blocks: 179946
(Assignee)

Comment 3

15 years ago
Created attachment 127710 [details] [diff] [review]
v2 patch (still needs some more refining)
Attachment #127416 - Attachment is obsolete: true
(Assignee)

Comment 4

15 years ago
Created attachment 129347 [details] [diff] [review]
patch v3

I shouldn't have aimed too high :-).  It took a lot more tweaking than I
expected.
With this patch, I fixed bug 179946 and bug 195038 (see also bug 94319) as well
as this bug. I kinda littered files with debug statements and I'll clean them
up later.
In the meantime, I'm uploading this for the peace of mind :-)
Attachment #127710 - Attachment is obsolete: true
(Assignee)

Comment 5

15 years ago
Created attachment 131648 [details] [diff] [review]
a new patch

basically the same as attachment 129347 [details] [diff] [review] with a bit more extensive comments
Attachment #129347 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.6alpha
(Assignee)

Updated

15 years ago
Attachment #131648 - Flags: superreview?(rbs)
Attachment #131648 - Flags: review?(bstell)
(Assignee)

Comment 6

15 years ago
Brian and Masaki,
Can either of your review the latest patch and move this forward? If both of you
can't at the moment, who would be qualified to review it(someone at Sun)? Thanks.
Blocks: 33127
(Assignee)

Comment 7

15 years ago
Pete, can you review the latest patch? 

Comment 8

15 years ago
*** Bug 226121 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

15 years ago
bryner, would you care to take a look? It's long ! I have to update the patch
against the trunk (not much change, though) and perhaps have to comment more. 

Comment 10

15 years ago
Comment on attachment 131648 [details] [diff] [review]
a new patch

Removing the sr request to simplify my queue. Care to re-ask once you get the
r.
Attachment #131648 - Flags: superreview?(rbs)
(Assignee)

Comment 11

15 years ago
Comment on attachment 131648 [details] [diff] [review]
a new patch

I'm making a new patch against the trunk.
Attachment #131648 - Flags: review?(bstell)
(Assignee)

Comment 12

15 years ago
Created attachment 141328 [details] [diff] [review]
a new patch updated to the trunk

I updated attachment 131648 [details] [diff] [review] to the trunk (+ my patch for nsAutoBuffer that will
go in as soon as the HEAD is opened up for 1.7beta development)

I haven't yet managed to test it because a new version of freetype library
doesn't have FT_Image_Cache* APIs (bug 234035).
Attachment #131648 - Attachment is obsolete: true
jshin, is still needed after 4 years?
QA Contact: ian → gtk
Target Milestone: mozilla1.6alpha → ---
Product: Core → Core Graveyard
I am inclined to think this has been rendered moot by subsequent changes, in that I cannot find the offending hardwired table in the code nor can I find any fontEncoding.properties files.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.