Closed Bug 20862 Opened 20 years ago Closed 20 years ago

Default bookmarks need cleanup (remove Netscape-isms)

Categories

(SeaMonkey :: Bookmarks & History, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: braden, Assigned: jmd)

References

Details

Attachments

(5 files)

If various companies have deals with Netscape/AOL to be listed in the default
bookmarks, Mozilla probably doesn't need to be giving them a free ride.
Blocks: 14532
OS: Linux → All
Hardware: PC → All
*** Bug 5090 has been marked as a duplicate of this bug. ***
Assignee: dmose → slamm
Component: UE/UI → Bookmarks
The default Mozilla bookmarks should NOT be redirected though home.netscape.com
- they should point directly to the website URL.   For example the URL for
Altavista should be changed from:

http://home.netscape.com/bookmark/4_06/altavista.html

to

http://www.altavista.com

This applies to all the default Mozilla bookmarks.
Status: NEW → ASSIGNED
Target Milestone: M13
Ok, I will clean it up.
Target Milestone: M13 → M14
Move this to M14.  Methinks we need some input from the marketing dweebs on
this.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
dmose already did the bookmark scrubbing. Marking FIXED.
Status: RESOLVED → REOPENED
nope. the exact example mentioned in this bug has not been changed.
I'm looking at an opt mozilla build from 2000011910
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
This is for mozilla only right?  
AFAIK, yes. although technically the commercial default bookmarks should be checked to make sure they match the current set of 
marketing/legal requirements. I could do this but i would need to have an 'official' list from somebody.
scratch my above comments. this is mozilla only. I broke out bug 26477 to cover my commercial bookmarks concerns.
I can take this, ok?
Assigning to myself (was slamm), will have fixed within 24 hours.
Assignee: slamm → icos
Status: REOPENED → NEW
OK, I have updated the bookmark file, but I need to know what to do in certain 
situations.

* There is a link to Netscape's SmartUpdate. I think thats dumb. Suggest: remove 
bookmark

* There are some shopping links (ie, Flowers, Computers, etc) that take you to 
the same generic shopping site. suggest: do nothing

* There is a 404 at http://webcenters.netscape.com/shopping/computers.html. 
suggest: remove bookmark

Also, there are a few name changes in the name of the destinations. I don't know 
how "strict" this has to be, but can I use common sense to delete and modify 
names for some of these bookmarks?

Status: NEW → ASSIGNED
You can change the mozilla bookmarks at will. If there are Netcenter bookmarks 
in there that are unappropriate for mozilla then you are welcome to replace or 
remove them.
Yes, but if we submit a vendor-neutral bookmarks file -- one with links to 
Mozilla.org, Web standards specs, Bugzilla/Bonsai/Tinderbox links, and so on, 
i.e. bookmarks likely to be useful to Mozilla users rather than Netscape users -- 
would someone check it in?
Fixed. slamm, please check in this attachment.
This attachment is the new bookmarks.html file, with mainly these changes:

* Previous URLs that went through Netscape.com now are direct (main issue of 
this bug)
* Added more search engines
* Removed SmartUpdate (for Nav 4.x) link
* Removed 404's and duplicates
* Added link to http://ftp.mozilla.org/pub/mozilla/nightly/latest/ in personal 
toolbar folder (Title: "Latest Builds")
* Added link to http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser in 
personal toolbar folder (Title: "New Bug")
* Added "Jump to Bug" bookmarklet to personal toolbar folder. Code by 
mpt@mailandnews.com (thanks!)


slamm, I'd be happy to help you with any other additions and modifications to 
the default bookmark file. Just let me know.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
icos@digitalchat.net did you check this in? Setting a bug resolution to FIXED means it's in the tree and the next build after your 
checkin will contain the fix such that I can 'verify' it. Is that the case here? If so when was the checkin?
I'm sorry if I wasn't clear earlier. I don't have CVS access, so I couldn't 
check in the new booksmark file, which is attached to this bug. I was waiting 
for slamm to do so.
yeah that's what I figured, I was just being huffy. I do have to reopen this though b/c it's not time for me to look at it yet and 
slamm needs to know that this is still an open issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reassigning to me.
Assignee: icos → slamm
Status: REOPENED → NEW
Marking for beta consideration.
Keywords: beta1
Summary: Default bookmarks need cleanup → Default bookmarks need cleanup (remove Netscape-isms)
Whiteboard: New bookmark file ready.
Putting on PDT- radar for beta1
Whiteboard: New bookmark file ready. → [PDT-]New bookmark file ready.
Is this in yet?

If not, I'll commit it tonight.
Move to M16 ...
Target Milestone: M14 → M16
I agree with mpt@mailandnews.com.  There is no reason to have most of the links
in the attached bookmarks file in mozilla.  This should be in netscape but not
mozilla.  We should have links to useful things like w3c specs, ui design, and
developer stuff. Not links to travel, shopping, and entertainment.  How are the
developers supposed to get any work done if they are being tempted by all these
useless sites shopping and entertainment sites. :)
I think shipping default bookmarks with the Mozilla build is useless and has potential to 
generate trouble. I think the bookmarks could be empty by default. If there has to be 
something in the bookmark file, mozilla.org and w3.org are suitable default bookmarks. 
Putting in anything else has the potential to prompt complaints like: "Why is that site in the 
default bookmarks? I want my site listed, too." or "Why is that site in the default 
bookmarks? I don't want that site listed."
Target Milestone: M16 → M18
We want default bookmarks, though I agree that doing just about _anything_ will
cause complaint.

The bookmarks are a great way to point new users at handy locations, like
perhaps the PSM plugin (yes, it's from Netscape, but 90% of our users want it,
and the vast majority of the code in question is in the tree) and some other
Mozilla-related stuff.

Someone want to take another swing at a bookmarks.html that doesn't suck, and
then reassign the bug to me?
I can do this ... ETA this weekend.
Status: NEW → ASSIGNED
Hmmm, didn't know you could accept an assignment of a bug to someone else ...
*Really* assigning to self this time.
Assignee: slamm → mpt
Status: ASSIGNED → NEW
Ok, I've attached a half-finished version of a default bookmarks file. I'm not 
going to finish it until bug 40025 is fixed. Things wrong with the bookmarks:
* lots of links missing
* it has a root `Bookmarks' folder, because it was created in 4.7 and not
  Mozilla, because my use of Mozilla is blocked by bug 40025
* it has all that cruft about when each bookmark was created and when it was last
  visited etc etc, which needs to be removed/sanitized.

Issues for discussion:
* Is there anything obvious which it looks like I'm not going to include but
  which I should?
* Should I assume that the user has JavaScript enabled, and insert my hoopy
  Bugzilla bookmarklet instead of an ordinary bookmark to bugzilla.mozilla.org?
* Should there be bookmarks for *anything* not strictly Mozilla-related -- such
  as the Open Directory Project, for example, or Slashdot? (cf. bug 30653)
* I'm planning to include links to everything in the Debug menu, with the aim of
  retiring the Debug menu itself. Does this sound like a good idea?
I am concered about taking to much out of menus and putting them in the 
bookmarks.  Many people run "mozilla -installer" that move ones Netscape 
bookmarks over.  Thus they may never see some of the other bookmarks that mgiht 
be important.  I don't know the links should be in the debug menu or where, but 
I would hate for the links to just completely disappear for people that import 
bookmarks.


"Should there be bookmarks for *anything* not strictly Mozilla-related"--

In my opinion, no. The Mozilla.org version should remain as neutral as possible.
Henri, i would almost agree
For default bookmarks I suggest links to Mozilla.org, W3C, Mozillazine, IETF, 
faq.org/rfc (or some other RFC site), a few other standards sites.   Not 
necessarly 3 or 4 links to sub sections of W3C, just W3C.  
Again remember that anyone that runs mozilla -installer will never see thse 
links.




*** Bug 31840 has been marked as a duplicate of this bug. ***
Blocks: 38577
> Should I assume that the user has JavaScript enabled, and insert my hoopy

I'd pass on that assumption.

> Should there be bookmarks for *anything* not strictly Mozilla-related -- such

no

> retiring the Debug menu itself. Does this sound like a good idea?

no. debug menu should be seperate.

I'd like to see this rearanged as
  W3C (World Wide Web Consortium)
    `-- HTML 
    `-- CSS
    `-- XML
  IETF
    `-- Relavant standards
  RFCs
    `-- HTTP 1.1
    `-- Maybe some mailnews protocols?

That is, grouped by organization, rather then by standard. This is a little bit
cleaner, and gets rid of the unofficial pages you had listed, like blooberry's
reference, etc. While they may be nice, they're not official, which leads to
requests to add CNETs html help page, then builder.com's javascript page, then
we're back in the same boat we're in now.

Under tools, keep PSM, add a link to alphanumericas crash recovery plugin maybe?

Split 'Mozilla Development' into two sections:

 Mozilla.org
   `-- mozilla.org (http://mozilla.org)
   `-- Status Update (http://mozilla.org/status/)
   `-- <maybe one or two more general-user pages>
 Mozilla Development
   `-- lxr
   `-- tinderbox
   `-- bonsai
   `-- bugzilla

Remove dmoz... its available in the search sidebar.

OK, i think that's it. Forgive the random order everything above is in, but its
really hard to lay stuff out in this little 5 line 'additional comments' box =).
Think I'll go RFE for zooming in on a form box.

I can lay this out in a bookmarks.html myself mpt, i'll wait for comments back
or to hear from you.
If we keep a cast-iron non-commercial policy, then logically we can't include 
MozillaZine either. If we did, then we'd have to include the O'Reilly Network 
Mozilla site, and who knows how many other Mozilla-related sites which start 
popping up in the next few months.

What it comes down to, is do you (a) want no default bookmarks at all, (b) want 
bookmarks which are completely non-commercial (that means no MozillaZine), or (c) 
trust the person maintaining the bookmarks file to only include those bookmarks 
which are considered most useful for Mozilla users, and say `get lost' to anyone 
else?

Reassigning to Jeremy, as I'm blocked by bug 36928 and don't want to hold this up 
if someone else is willing to do the work.
Assignee: mpt → mozilla
Whiteboard: [PDT-]New bookmark file ready. → [PDT-]
Ok, this was harder then I thought. Currently, mozilla has an absolute *MESS*
of ways to access links.

There are links in the help, debug, and qa menus, the mozilla pull-up in the
taskbar chrome, and then the user bookmarks file, which is accessible in four
ways itself (menu, personal toolbar, sidebar, bookmark manager).

I've thought about the layout a bit, trying to sort it all out, and now I
present what I feel is the best, most useful layout. I encourage feedback
(via direct email to avoid spam here) on anything and everything. I've
removed all netscape-isms (what this bug originally called for), and tried
hard to put links in the most appropriate places, while avoiding duplication.

Things that need to be done, outside of the default user bookmarks.html:

1) add all webtools to the taskbar chrome 'Mozilla' pullup. This will keep
   them all together, and make that pullup useful. Alternativly, we can put
   the webtools in the user bookmark file, and move the Mozilla.org folder
   to the chrome. comments welcome. note that the one embeded in the chrome
   will be more 'permanent', and as mozilla is targeted at more technical
   users, i feel the webtools may be the thing to put there. they at least
   serve a function, whereas the generic 'mozilla.org' links are more likely
   to not be wanted by powerusers, as they can navigate mozilla.org's
   frontpage for themselves.
2) add a sample ftp URL to the debug menu, as there are none in bookmarks now

Need comments on:

1) Tools/PSM is a good entry I think, but it creates problems. Do we include
   Alphanumerica's Crash Recovery? Where is the line drawn? See above comment.
2) Should there be Custom Keywords for any of the bookmarks by default?
   It would serve to demonstate the feature, but how will the user know
   what they are? The current bookmarks have keywords for the Mac
   Resources... stuff like 'rumors' for macosrumors. We probably don't
   want this.
3) I still put dupes in the Personal Toolbar folder. There isn't a way
   around this, that I see. We have so many places that links need to
   go, and only so many to go around. Rather then duplicating a whole
   catagory here, I took the ones I thought were most-accessed, and put
   them here for one-click access. If you think that another link is
   qualified for most-accessed one-click status, let me know.
4) I'm pretty sure I want to do away with the Community folder, for reasons
   touched apon in Matthews comment above. Feelings?
5) Should there be a link to the IETF? AFAIK, they deal with lower level
   protocols that aren't really relevant to gecko, but someone suggested it.
   Anything else to put in the standards folder? RDF, Unicode, OJI, SSL...Should
   the RFCs provide direct links to the standards Mozilla implements? This is
   more useful, but there are so freakin many of them... theres probably 3-4 for
   URIs and URLs alone...plus all the ones that mozilla deals with, that aren't
   really thought of as relevant to a web browser... DNS, TCP, LDAP, SMTP, POP,
   IMAP, the list goes on... you begin to see my problem...

Technical info I need:

1) Syntax for smartfind's 'find:' protocol. The default smartfinds are
   redirecting through netcenter. This bug calls for the removal of this.
2) In bookmark manager, there are three special folder designations, 'new
   bookmarks', 'new internet search', and 'personal toolbar'. I'm not quite
   sure what the middle one does. It certainly isn't where the search sidebar
   pulls its list from, as the name makes it sound.

Here is a rought draft of the new Mozilla default user bookmarks. Please make
sure you've read all of the above BEFORE you comment on anything below, and
keep those issues in mind.

----------------------------------------

+ Mozilla.org
    The Mozilla Organization <URL:http://mozilla.org/>
    Status Update <URL:http://mozilla.org/status/>
    Feedback <URL:http://www.mozilla.org/feedback.html>

+ Developer Information
    Getting Involved <URL:http://mozilla.org/get-involved.html>
    Developer Documentation <URL:http://mozilla.org/docs/>

    + Standards References
        World Wide Web Consortium <URL:http://www.w3c.org/>
        + RFCs
            Archive <need to find a mirror that can spare the bandwidth>
            HTTP 1.1 <dido>
            FTP <dido>
            URLs <dido>
            Gopher <dido>

+ Community
    MozillaZine <URL:http://mozillazine.org/>
    Alphanumerica's Mozilla Page <URL:http://www.alphanumerica.com/projects...>

+ Tools
    Netscape Personal Security Manager <URL:http://docs.iplanet.com/docs/ma...>
    Alphanumerica's Total Recall <URL:http://www.alphanumerica.com/projects...>

<-- seperator -->

+ Personal Toolbar Folder
    Mozilla.org <URL:http://www.mozilla.org/>
    Bugzilla <URL:http://bugzilla.mozilla.org/>
    Tinderbox <URL:http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonk...>
    Latest Builds <URL:http://ftp.mozilla.org/pub/mozilla/nightly/latest/>
Keywords: beta1
Whiteboard: [PDT-] → awaiting comments
Forgot to explain why that spam isn't an attachment...

I've posted it in plaintext for now, because doing it in mozilla bookmark format
involves technical issues, while I'm only working on the UI/political ones right
now. After some feedback, there will be a real, usable, rough draft.
>...
> add all webtools to the taskbar chrome 'Mozilla' pullup. This will keep
> them all together, and make that pullup useful.

Don't treat the symptoms, cure the disease ...

>                                                 Alternativly, we can put
> the webtools in the user bookmark file,
>...

... That makes much more sense. Many end users of Mozilla (even of the 
mozilla.org distribution), such as Web developers for example, may have little or 
no interest in mozilla.org developer tools. So hard-coding them into the chrome 
is bad manners, not to mention inviting linkrot. (Try firing up a copy of 
Netscape 1.1 and clicking on the hard-coded `Directory buttons' -- three of the 
six don't work. Where they're part of the chrome, rather than an easily-deletable 
part of the bookmarks, that's just wrong.)

If we have mozilla.org links in the bookmarks, the list of open windows in the 
Tasks menu, and we move the component icons in the status bar, then we can rid
non-commercial Mozilla of that sorry excuse for a `taskbar' and reclaim some 
screen real estate.

The personal toolbar should only contain about 2 bookmarks, because (a) that 
would make it visually obvious that bookmarks can be added to it, and that it's 
not just a hard-coded Links toolbar, (b) it's easier to add items to the toolbar 
than to remove them, and (c) of any given user's half-dozen or so most frequently 
visited bookmarks, most of them won't be from the default bookmarks anyway.
Responce to mpt's proposed changes:

> ADD_DATE, LAST_MODIFIED, ID fields removed

A bookmark backend person needs to be consulted on the correct format to submit
the bookmarks in. The parser may be handling entries without those fields alot
slower, or whatever. They might be better off all set to a certain date, maybe
the profile creater should do it. Set it to the current time. Makes more sense.
You're submission appears to be hand edited Mac text...probably not what we want
for the canonical version.


> Addition of dmoz to the Toolbar and Community folders

Dmoz.org is a Netscape owned property, and there is quite a bit of unrest
regarding it. It was not an oversight on my part not including it. For example:
http://www.traffick.com/story.asp?StoryID=59

I'd prefer all community sites be removed before any dmoz.org content is
included. I'm not saying I nessicarily share the opinions of the editorial
above, I'm just saying it will cause trouble.


> Relocation of Personal Toolbar Folder, seperator removal

I am against the relocation of this folder. It was so placed in my bookmarks for
certain reasons.

1) it is special. It is designated as a special folder, one which effectivly
cannot be deleted, only renamed. Sure it can be, but then you have no toolbar.

2) due to this specialness, it should be sorted seperatly. The seperator serves
to break apart sorting. For example, if you have 4 bookmarks with a seperator in
the middle, having the bookmark manager sort them by name will sort the top two
by name, then the seperator, then the bottom two. I feel the Personal Toolbar
Folder is better sorted with the bookmarks the user has added themselves.

3) this issue is the most trivial, so I will stop devoting so much space to it.


> Renaming of "Personal Toolbar Folder" Folder

In mpt's version, the "Personal Toolbar Folder" was renamed to "Toolbar Folder".
Netscape 4.x and Mozilla both officially designate this special folder as the
"Personal Toolbar Folder", hence my naming of it that. Under the view pulldown,
it is named "Personal Toolbar". In Bookmark manager, it again has the Personal
prefix. It is important to maintain this consistancy.


> Inclusion of IETF under standards

What standards are the IETF responsable for that are relevant to Mozilla? Again,
their non-inclusion was intentional on my part.


> Rewordins

Many renamings were done, most of which I {approve,am indifferant to}. I
personally would like to see the following two switched *back*, however:

mozilla.org link:
    jmd: The Mozilla Organization
    mpt: mozilla.org home
    rationale: Look at the top of the sidebar at http://mozilla.org...

bonsai.mozilla.org link:
    jmd: bonsai (CVS Tree Control)
    mpt: bonsai (CVS repository)
    rationale: It's really a great pun. Really.


The other changes I am indifferant on. Webtools moved under Developer
Information. Harder to get to for people that use them frequently, out of the
way for people who don't. So, shall we go another round?


On an unrelated note, in case anyone asks about the RFC link:
Not wanting to incur bandwidth use on an unwilling nonprofit RFC mirror, I have
contacted the webmaster for the linked-to mirror: 'faqs.org/rfcs/', and have
recieved a reply that they are fine with the link. There are *MANY* RFC mirrors
out there, but I think this one is well maintained with a very useful web
interface.
Status: NEW → ASSIGNED
Jeremy, I agree with all your arguments, with the following exceptions.

* I put the Personal Toolbar Folder at the top, with a separator after it, to
  emphasize that it is distinct from other folders, and to make it easier for
  users to find the thingamy which controls the contents of the Personal Toolbar.

  It's a usability thing. If the Personal Toolbar Folder is placed at the bottom,
  and a Mozilla user leaves the default bookmark items there, and then adds new
  bookmarks, the Personal Toolbar Folder will be lost somewhere in the middle of
  the bookmarks. Which would be bad.

* The renamings (and movement of the Webtools folder) were done to maximize
  usability. Most people think of <http://mozilla.org/> as the `mozilla.org'
  site, not as `The Mozilla Organization' site. And the default Mozilla
  bookmarks are really not the place for puns. (Sorry.)

Steve Lamm, please tell us what's the best way to neutralize the bookmarks 
metadata (ADD_DATE, LAST_MODIFIED, etc) for Mozilla -- or CC someone who can tell 
us.
cc'ing rjc as slamm is on sabbatical and rjc did the backend anyway.

rjc please see the last lines of the last comment before mine (Matthew Thomas 6/16) they refer back to the first lines of Jeremy 
M. Dolan's 06-16 comment.
Blocks: 43797
rjc, can you comment? I'd like to get this in ASAP.

I believe mpt and I have reached a consensus via email, I'll post a final draft
once the optimal format is known.
Whiteboard: awaiting comments
Target Milestone: M18 → M17
final draft incoming shortly since no responce was recieved in two and a half
months. this needs to be checked in badly.
Priority: P3 → P1
Target Milestone: M17 → M18
Yes, please get this in ASAP. Doesn't matter, if it isn't polished, just remove
those ads. Jeremy, if NS employees don't reposnd, just cry.
Well, this is way too political for me to do myself, some official mozilla.org
representative needs to make the final call here, but I'm ataching what I have,
and request SOMETHING be checked in before M18. The current default bookmarks
are a huge setback to getting it across that mozilla != netscape.

some of the smaller sites linked to in here (the faq under community comes to
mind) should be contacted before they are checked it. faqs.org/rfc i did
contact, that is fine (the official rfc archive has a smaller bandwidth
capacity, they requested not to be used).

feedback from NSCP/moz.org officials, please...
forwarded to the approval gang.
a=brendan, will check in what's there.

However, I have some objections. Filed bug 51193 about tuning.
I sat the LAST_MODIFIED and LAST_VISITED values to "0", like in the previous
(Netscape) default bookmarks file.

Checked in. FIXED.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
marking VERIFIED Fixed
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.