Closed Bug 208693 Opened 17 years ago Closed 9 years ago

Selected (highlighted) text is always white text on blue background, even if original text is white on a blue background.

Categories

(Core :: DOM: Selection, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 56314

People

(Reporter: kg, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030606 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030606 Mozilla Firebird/0.6

Whenever I select any text on any webpage, the selected (highlighted) text is
always white text on blue background, even if original text is white on a blue
background.  This is most noticible on a site such as the one I have listed
(http://www.gamingforce.com/forums/).  This makes it difficult many times to see
what text is actually selected.

If you were able to make it call an 'IF' statement before the text/bg color
changing process to check what color the text/bg of the original text is, then
you could apply a white-on-blue scheme to dark text on a light bg, and
blue-on-white scheme to light text on a dark bg.  This is much the same way
Internet Explorer handles selecting text.

Thank you for your time.

Reproducible: Always

Steps to Reproduce:
1. Mouse down on any text anywhere within the browser on any webpage.
2. Drag mouse to select text.
3. Release mouse button.

Actual Results:  
Selected (highlighted) text is always white text on blue background, even if
original text is white on a blue background.

Expected Results:  
Apply a white-on-blue scheme to dark text on a light bg, and blue-on-white
scheme to light text on a dark bg.

Samme occurance happens everytime with both Standard Mozilla Firebird theme and
the MozillaZine (MZ) theme.
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604

I have run into sites where the selected text is nearly the exact same color as
the unselected text.  Makes identifying the selection really difficult.
Confirming, although my selection background colour is gray...
Status: UNCONFIRMED → NEW
Ever confirmed: true
->Selection
Assignee: general → mjudge
Component: Browser-General → Selection
QA Contact: general → pmac
Or how about inverting the text/background colour? That would probably be better
if the background isn't the exact colour needed to trigger the change. Wouldn't
be as consistent with other applications though I suppose. Perhaps a config
option could be add if you think that's necessary.
This is very similar to bug 50814.  I'll leave it up to the reporter to decide
whether it's a dup or not.
this is even worse when the blue background is exactly the blue in the
highlighting
(http://premier.ticketek.com.au/Ticketek/front/inserts/insertTermsOfUse.asp). in
which case it is impossible to see what is selected
*** Bug 276678 has been marked as a duplicate of this bug. ***
This bug is resolved by fixing the bug 56314
i think this is fixed in 2.0?
Assignee: mjudge → nobody
QA Contact: pmac → selection
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 56314
You need to log in before you can comment on or make changes to this bug.