Save As, or Save Link Target As ... doesn't save the page

RESOLVED DUPLICATE of bug 203689

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 203689
15 years ago
14 years ago

People

(Reporter: Laimonas Simutis, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

After selecting frm menu Save As option or Save Link Target As ... from mouse
menu, the dialog comes that allows to choose a file name for the page that is to
be saved. However, then the filename is chosen and the Save button is clicked,
page is not saved. I thought that this might be not a bug and tried the same
thing for the same pages with IE, and save worked.

Reproducible: Always

Steps to Reproduce:
1. Go to any site
2. Click on Save As
3. Choose a path and try to save

Actual Results:  
The Save As dialog left, but when I checked the directory if it has the page I
wanted to save, it wasnt' there.

Expected Results:  
Saved the page in the specified directory under specified name.
WFM build 2003060308 XP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 2

15 years ago
see bug 208608 comment #1 for confirmation information. I won't necessarily say
it's confirmed, but how can you mark it as WFM if nobody else has tested it?
Status: RESOLVED → UNCONFIRMED
Depends on: 208608
Resolution: WORKSFORME → ---
because I tried with build 2003060308 and I just did it again with build
2003060908 and saving web pages is something I do about 10 times a day without
any problem. Unless you can provide steps to reproduce this bug on somebody's
else machine, it is WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
Reopening for further investigation.

Reporter: if you close mozilla, delete compreg.dat (it will be regenerated next
time you start mozilla) in the components/ directory and start mozilla again,
does downloading work? If it doesn't, could you do the same, but now delete
downloads.rdf from your profile? I have the feeling this is a dupe, but of a bug
that needs to be reopened.

Pascal: with cases like this, there is often an additional factor at work that
you as one triager don't experience. Don't be too quick with marking bugs WFM
unless you are absolutely certain you're testing under the exact same
conditions, particularly when there are more unconfirmed reports of the same
problem.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

15 years ago
Deleting compreg.dat gave some progress. Now the pages are saved, as far as HTML
is concerned. However the images are not saved and src path is used to retrieve
them when displaying the locally saved page. Some images are not displayed at
all (broken image display).

Comment 6

15 years ago
LaiMon: that is as expected I'd say - at least, I assume Mozilla _does_ save the
images if you choose "Web Page, complete" in the Save As dialog?

Marking as a dupe for now.

*** This bug has been marked as a duplicate of 203689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.