Request: ALT text for IMG should be visible

VERIFIED DUPLICATE of bug 25537

Status

enhancement
VERIFIED DUPLICATE of bug 25537
16 years ago
15 years ago

People

(Reporter: david, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

When an IMG element has an ALT attribute with text, the text should be visible
when the cursor is over the image.  This could be only for a few seconds (as
with Netscape 4.7), or it could be sustained as long as the curson remains over
the image.  This could be mandatory, or it could be an option either via the
Images portion of the Preferences window or via user.js.  

Yes, I know I can see the ALT text if I view the image's properties.  However, I
want to know the image has ALT text before I try that.  And I really don't want
to keep opening Element Properties windows for every image.  

Reproducible: Always

Steps to Reproduce:
1.  Load Web page indicated above in "URL" section.  
2.  Position cursor over mailbox or keys images.  
Actual Results:  
Nothing

Expected Results:  
Some indication that the image has ATL text.  

In some cases, copyright information relative to the image is contained in the
ALT text.  In other cases, I have seen ALT text suggesting that the user select
the image as a link.
This is number 4 on the "top ten" list of most reported bugs:
http://bugzilla.mozilla.org/duplicates.cgi

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Current behavior is by design according to standards.

v dupe
Status: RESOLVED → VERIFIED
This bug report -- requesting an enhancement -- should be considered separately
from #25537 (which reported a problem).  While no actual error may exist, the
request for enhancement may also be valid and should stand on its own.  

The HTML 4.01 Specification report by W3C refers in Section 4 ("Conformance") to
RFC 2119 ("Key words for use in RFCs to Indicate Requirement Levels"). 
According to RFC 2119, the lack of "must not" or "should not" relative to
presenting a tool-tip for ALT text is significant.  

Even more significant, Section 6 of RFC 2119 says:
"Imperatives of the type defined in this memo must be used with care and
sparingly.  In particular, they MUST only be used where it is actually required
for interoperation or to limit behavior which has potential for causing harm."
This requested enhancement (especially if implemented with a user-selected
option) would not affect interoperability or cause harm.  

Therefore, this enhancement would not be contrary to the HTML standard.  
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
There's already an active of discussion of this proposed feature in bug #25337,
which requests the same enhancement as this bug. Setting severity of #25337 to
"enhancement" and again marking this as a dupe.

*** This bug has been marked as a duplicate of 25337 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Oops, I meant #25537.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Sorry about that.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.