Closed Bug 209550 Opened 17 years ago Closed 15 years ago

bad position when use <statusbar/> inside <wizard/>

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: afatecha, Assigned: afatecha)

References

Details

(Keywords: testcase, Whiteboard: [testcase,patch])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

wizard doesn't inserts anything under buttons-box (ok, cancel, etc), but
statusbar must be in window's bottom place.

Reproducible: Always

Steps to Reproduce:
1.open test-case
2.see where <statusbar> is placed


Actual Results:  
<statusbar> is placed over buttons-box

Expected Results:  
<statusbar> must be placed under buttons-box

I'll post patch for this bug.
Attached file test-case
must be runned from chrome.
Attached patch patch for thisSplinter Review
posted patch. ;)
*** Bug 209552 has been marked as a duplicate of this bug. ***
Attachment #125748 - Flags: review?(varga)
cc-spam ;)
Summary: bad position when use <statusbar/> inside <wizard/> → bad position when use <statusbar/> inside <wizard/>
Keywords: testcase
Whiteboard: [testcase,patch]
Status: UNCONFIRMED → NEW
Ever confirmed: true
I wonder if it is actually a good idea to use <statusbar> in <wizard>
I found that good for feedback about small things.
Assignee: hyatt → afatecha
Attachment #125748 - Flags: review?(varga)
You need to talk to other people then, because I'm not sure if this is right
thing to do.
I think <statusbar> must be in bottom of window (or have the change to do it at
least). 
No matter if is good looking or not.
Jan, please let know if this bug is to right place to talk about or I would have
to write in news.
Attachment #125748 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 125748 [details] [diff] [review]
patch for this

Waiting for a definitive ruling.
Attachment #125748 - Flags: superreview?(jaggernaut)
Attachment #125747 - Attachment mime type: text/plain → application/vnd.mozilla.xul+xml
This change seems okay to me, I don't think many people are going to use
<statusbar> in <wizard>, and those who are will most likely want it below the
buttons, not above. Hmmm, what if someone puts a <statusbar> in a <wizardpage>,
does that get pulled down to the bottom by this change too?
no, because <children> only look for inside one level, it doesn't pulled down
too, I had tested.
If that's the case, this seems fine to me, too (not that it really matters, but
I like to hear myself talk).
Comment on attachment 125748 [details] [diff] [review]
patch for this

Whoever checks this in should remove the trailing w/s.
Attachment #125748 - Flags: review?(neil.parkwaycc.co.uk) → review+
Comment on attachment 125748 [details] [diff] [review]
patch for this

sr=jag
Attachment #125748 - Flags: superreview?(jag) → superreview+
Neil, can you commit in cvs this? because I can't do it.
Fix checked in.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
It appears that this patch never made it into Firefox.
(In reply to comment #17)
> It appears that this patch never made it into Firefox.

true. Neil, can you commit this for Firefox?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #18)
>Neil, can you commit this for Firefox?
I think it would need separate Firefox review.
I agree. I will add a new patch for review.
Status: REOPENED → ASSIGNED
Attachment #213892 - Flags: review?(neil)
Attachment #213892 - Flags: review?(neil) → review?(beltzner)
Comment on attachment 213892 [details] [diff] [review]
Patch for firefox

When merging the toolkit bindings was brought up, we said no to this.  If you want to add something oddball like a statusbar to a wizard, you can just extend the wizard bindings to include it in your own code.
Attachment #213892 - Flags: review?(beltzner) → review-
ok, no for Firefox.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago15 years ago
Resolution: --- → WONTFIX
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.