If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla startup script should have flag to force rewriting env. variables

RESOLVED DUPLICATE of bug 226071

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 226071
15 years ago
13 years ago

People

(Reporter: André Dahlqvist, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I am working on a function to be used by Thunderbird to launch a browser on
Linux when a person clicks on a URL in an e-mail. This pointed out a problem
with Mozilla's startut script that bbaetz recommended me to report: since I have
thunderbird running, MOZILLA_FIVE_HOME (and maybe other env. variables) point to
thunderbird's directory. Now, when I try to execute Mozilla from within
Thunderbird the mozilla startup script does not update MOZILLA_FIVE_HOME since
it is already set, and then tries to run mozilla-bin in thunderbird's directory
instead of in mozilla's directory.

There should be a flag or something to the startup script to allow me to force
and update of these environment variables. Alternatively, maybe Thunderbird
shouldn't set MOZILLA_FIVE_HOME at all?
(Reporter)

Comment 1

15 years ago
CC:ing Scott.

Comment 2

15 years ago
see also bug 172706 and bug 202985
the startup script really has nothing to do with Build Config. -> xp apps
Assignee: mozbugs-build → jaggernaut
Component: Build Config → XP Apps
QA Contact: granrose → paw
(Reporter)

Comment 4

14 years ago
I think Darin fixed this in bug 226071. Duping against that one.

*** This bug has been marked as a duplicate of 226071 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.