Bad behaviour tabing past disabled input element

VERIFIED INVALID

Status

()

Core
Keyboard: Navigation
--
minor
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: tc, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429

If a form contains <input> elementes containing an disabled property, and you
try to tab past it you stay in the input field you where in. Tabbed focus is
advanced, because you actually move on the next time you tab (unless theres mere
than one disabled field).

Simply to to tab through the form on this page: http://tc.dk/testformdisable.php

Reproducible: Always

Steps to Reproduce:
1.Go to http://tc.dk/testformdisable.php
2. click on the first form element
3. click on tab

Actual Results:  
Focus stays in the first form element

Expected Results:  
Should have moved to the third element
(Assignee)

Updated

15 years ago
Blocks: 83552

Comment 1

15 years ago
This has already been fixed, try a newer build please.
(Reporter)

Comment 2

15 years ago
True. This is fixed. I actually I was on a new build ... ah, the juy of to many
computers. 

Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.