Japanese input into Java applets does not work - the text goes to the status bar instead

RESOLVED DUPLICATE of bug 92814

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 92814
15 years ago
14 years ago

People

(Reporter: Doug Lerner, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030612

While English text that is typed into a Java applet works ok, Japanese text is,
for some reason, captured by the browser's status bar (at the bottom of the
browser) and doesn't get entered into the Applet.

On the same machine, this works with IE and works "more or less" with Safari
too, so I do believe that the Java VM on the Mac is fine and that this is an
issue with Mozilla. The same problem with the same symptom also occurs with
Firebird.


Reproducible: Always

Steps to Reproduce:
1.Go to a Java applet that allows text input
2.Make sure you are focused in the text input field
3.Enter Japanese characters

Actual Results:  
1. As you type, the characters get entered in the browser status bar.
2. Attempting to finalize the input by pressing enter/return gives a short alert
beep, and nothing happens. The text does not get entered.

Expected Results:  
1. As you type, the text should appear either inline in the text input area or
in a separate text-capturing area for the Japanese input system.
2. Finalizing the input by pressing enter/return should send the characters into
the text input area.
(Reporter)

Comment 1

15 years ago
This bug continues to persist in the latest 1.5a version. I would try to help
solve the problem if I knew where to look!

doug

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 92814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.