Mails are not removed from server after move to local folder by filtering module

RESOLVED DUPLICATE of bug 89034

Status

MailNews Core
Filters
--
major
RESOLVED DUPLICATE of bug 89034
15 years ago
9 years ago

People

(Reporter: emmet, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030618
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030618

Junk mail where the junk control settings are such that mail classified as junk
is deleted (sent to trash) is not removed from the POP server. Further, clearing
the trash mailbox does not update the server.

This bug may be linked to  Bug 195052 (Option to remove junk mail from POP3
account - even though other messages are left on server)

I also note that in early 1.4 builds that classified and moved junk mail (let
alone deleted) WAS deleted from the server. Hence marking as 'Major' since this
seems to be a regression.


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Confirming on Linux build 2003072105
URL: n/a
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

14 years ago
This also holds true for manual filtering.   If I set up a rule that moves a
particular message from the inbox or deletes it, it will remain on the server. 
 This is even if I have enabled the option to delete messages from server when
moved from inbox or deleted.

Comment 3

14 years ago
*** Bug 220298 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
*** Bug 222103 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Summary: junk automatically deleted remains on POP server → Mails are not removed from server after move to local folder by filtering module

Comment 5

14 years ago
FWIW, I'm using MailWasher as a temporary workaround, since it *CAN* delete mail
from a POP3 server without downloding it.

But I really hate having to use a second tool when Mozilla should be a complete
solution.

Comment 6

14 years ago
Same problem appears in Thunderbird 0.3.

Comment 7

14 years ago
Is this a dupe of bug 89034 ?

Comment 8

14 years ago
Yes, it is.

*** This bug has been marked as a duplicate of 89034 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.