If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[DOGFOOD][bugday] mail news buttons disappear on click and mouse-over

VERIFIED DUPLICATE of bug 18242

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 18242
18 years ago
13 years ago

People

(Reporter: asa, Assigned: hangas)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
tested on windows 98 build 120608

issue: the 'next', 'delete', 'print', and 'stop' button images disappear after
you click on them.  also the 'get msg', 'new msg', 'reply', 'reply all', and
'forward' buttons disappear / are lost on mouse-over. Functionality seems to
remain.

steps to reproduce: open mail. click on next, delete, print, or stop buttons.
watch them disappear.  move mouse over the get msg, new msg, reply, reply all,
or forward buttons. watch them disappear.

expected behavior: buttons should not disappear on click or mouse-over.

Comment 1

18 years ago
I'm not seeing this in my debug build from today. Lisa?
(Reporter)

Comment 2

18 years ago
addiional information:  the buttons with circle images (get msg, new msg, reply,
reply all, and forward) all function fine on mouse-over as long as you have not
pressed one of the buttons which disappear on clicking (next, delete, print, and
stop.  After pressing one of the buttons that disappear on clicking, then the
other buttons become succeptable to the disappearing on mouse-over problem.

final probably irrelevant note: the buttons that disappear on mouse-over
disappear completely (except for the get msg button which leaves behind some
small non-geometric visual artifact) while the buttons that disappear on
clicking leave behind a square outline with a dot in the center.

Comment 3

18 years ago
Is this happening only to the mail toolbars, or it it also happening to browser
toolbars?

Comment 4

18 years ago
Let me try this shortly.
I'll try first with 12/6 build and then the 12/7 build.

Asa tells me it's only in mail.

Comment 5

18 years ago
Phil, I reproduced this in 12/6 win32 build.  I'll try 12/7 next, but asa says
the bug is there.

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 6

18 years ago
Phil, also seen in 12/7 build.  Stop by and I'll show you.

Updated

18 years ago
Assignee: phil → hangas
Summary: [bugday] mail news buttons disappear on click and mouse-over → [DOGFOOD][bugday] mail news buttons disappear on click and mouse-over

Comment 7

18 years ago
Ok, now I see it. Thanks, Lisa. Reassign to hangas, cc putterman. Nominate for
dogfood.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Updated

18 years ago
Assignee: hangas → evaughan
Status: ASSIGNED → NEW
Target Milestone: M12
(Assignee)

Comment 8

18 years ago
Sending to Eric.  I was not able to reproduce the bug as easily as explained in
the first entry of this bug.  I had to:
1) Bring up the Mail News window
2) Click the New Message button
3) Close the New Message window
4) click the stop button on the Mail News window
5) move the mouse across all the buttons in the toolbar

Results: all the buttons dissapear, all new icons drawn in this window are drawn
as a small square.

I was able to do these steps on Windows and Mac to see the problem.

Comment 9

18 years ago
Using steps described by hangas I reproduced the problem on Linux.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 10

18 years ago
This is a dogfood issue.

Updated

18 years ago
Assignee: evaughan → hangas

Comment 11

18 years ago
This happens because MsgStop is called when clicked on that somehow corrupts the
ui. If you remove the on click handler at line 536 in messenger.xul the bug will
not happen.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
*** This bug has been marked as a duplicate of 18242 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
Verified Duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.