If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[DOGFOOD] All graphic(icons)on the toolbar are gone after hitting Stop while downloading a message

VERIFIED FIXED in M12

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: marina, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] - fix checked in)

(Reporter)

Description

18 years ago
Say you have a message with an attachement and it is loading slowly and you hit
stop to stop downloading it. Now look at your toolbar bar :there is a redraw
problem with all icon images-they are gone and in the thread pane scroll bar and
message icons look like they didn't completely loaded.
Steps to reproduce:
-open Inbox ;
-click on the message that has a Web page (displayed on-line);
-stop downloading by clicking "Stop";
-//note: icons on the toolbar for "Get Mail", "New Mail", "Reply" etc have
disapeared and in the thread you'll see some redraw problems
(Reporter)

Comment 1

18 years ago
forgot to mention : it was observed with today's 1999-11-08-09 M11 win build (it
happens on IMAP and POP

Updated

18 years ago
Assignee: phil → rpotts

Comment 2

18 years ago
bienvenu sez this is rpotts' problem.

Comment 3

18 years ago
*** Bug 18376 has been marked as a duplicate of this bug. ***

Updated

18 years ago
OS: Windows NT → All
Hardware: PC → All
Summary: All grafic(icons)on the toolbar are gone after hitting Stop while downloading a message → All graphic(icons)on the toolbar are gone after hitting Stop while downloading a message

Updated

18 years ago
QA Contact: lchiang → laurel

Updated

18 years ago
Target Milestone: M12

Comment 4

18 years ago
Putting on M12 radar.

Comment 5

18 years ago
Moving milestones...

Updated

18 years ago
Summary: All graphic(icons)on the toolbar are gone after hitting Stop while downloading a message → [DOGFOOD] All graphic(icons)on the toolbar are gone after hitting Stop while downloading a message

Comment 6

18 years ago
Nominating for dogfood since bug 21075 is marked PDT+

Comment 7

18 years ago
*** Bug 21075 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
In the other bug, it was assigned to hangas with comments from evaughan.

Comment 9

18 years ago
adding nbaca to Cc: list.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 10

18 years ago
Putting on the PDT+ radar.

Comment 11

18 years ago
hey david,
Is this *really* my bug?  it sounds like the toolbar images are being loaded in
the same load group as the message (which would be bad).  This could cause the
toolbar images to get interrupted (if they were loading) when the stop button
was pressed...

I can't imagine what the loadgroup would be doing that could cause this :-(

-- rick

Comment 12

18 years ago
Could this be a side effect of IMAP and the UI executing events on the wrong
threads?  This is described in 17065 and 18005, for which DougT has a fix
available as a patch.
I can reproduce the problem.

I'll try dougt's posted patch for nsEventQueue.cpp now...
nope, dougt's patch doesn't fix this.
(Assignee)

Comment 15

18 years ago
rick, sorry if this isn't your bug - I was going on what you told me when I
described this bug to you :-) We are using the root web shell's load group, so
that we can stop any url running in our window. But the thing is that the images
are not getting loaded when I press stop - they disappear after I mouse over
them long after pressing stop.  Unless pressing stop causes them to get reloaded
while we're stopping. I'm not sure what load group the toolbar images are using.
We could create our own load group. Or we could just cancel the load group and
not stop the web shell. I'll try that last thing and see if that makes a
difference.
(Assignee)

Updated

18 years ago
Assignee: rpotts → bienvenu
Whiteboard: [PDT+] → [PDT+] - fix waiting for code review and checkin approval ETA 12/13
(Assignee)

Comment 16

18 years ago
OK, just cancelling the loadgroup doesn't show this problem. I'll take the bug.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] - fix waiting for code review and checkin approval ETA 12/13 → [PDT+] - fix checked in

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 17

18 years ago
OK using 12-13-09m12 commercial builds on linux 6.0, mac OS 8.5.1 and NT 4.0

Updated

18 years ago
Target Milestone: M13 → M12
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.