Closed Bug 210876 Opened 17 years ago Closed 14 years ago

fieldset

Categories

(Core :: Layout: Form Controls, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: marty, Unassigned)

References

()

Details

(Keywords: testcase, Whiteboard: [reflow-refactor])

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

I put an example online for you guys that will show the bug:
http://www.excudo.net/bug/fieldset_table.html

I've nested a table in a fieldset and what happens is that when i set the
fieldset's width to auto, the table sort of collapses. The width of all the
table cells will tend towards zero - not minding the width of the cells below or
above. When i give the fieldset a fixed width (400px for example), the problem
seems to be solved

Reproducible: Always

Steps to Reproduce:
see Details
Actual Results:  
see Details

Expected Results:  
It should not make such a big chaos of the table when you don't specify a fixed
width for the fieldset :)
How peculiar.
Assignee: other → form
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Form Controls
Ever confirmed: true
QA Contact: ian → desale
Summary: table-structure becomes a chaos (collapses) when it's nested in a fieldset without a fixed width → fieldset
Whiteboard: [reflow-refactor]
Keywords: testcase
Dupe of Bug 129346.
(which may need to expand its summary - since Bernd added another dupe at Bug
129346 comment 9).

This testcase is now 404, so recommend removing the "testcase" keyword
Depends on: 129346
Attached image screenshot 1 (obsolete) —
Comment on attachment 142636 [details]
screenshot 1

Oops, sorry guys, wrong bug :)
Attachment #142636 - Attachment is obsolete: true
OS: Windows 2000 → All
Blocks: 295476
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

seems fixed by reflow branch landing
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
Attached patch ReftestsSplinter Review
Attachment #257590 - Flags: review?(dbaron)
Comment on attachment 257590 [details] [diff] [review]
Reftests

Checked in after testing in pre- and post-reflow-branch builds.
Attachment #257590 - Flags: review?(dbaron) → review+
Status: RESOLVED → VERIFIED
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.