Closed Bug 129346 Opened 19 years ago Closed 14 years ago

Fieldset renders incorrectly with style="float: left;" or any other shrink-wrap situation

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: pali, Unassigned)

References

()

Details

(Keywords: helpwanted, testcase, Whiteboard: [reflow-refactor])

Attachments

(3 files)

Fieldset seems to have problems rendering legend and calculating width when it
has style="float: left;". See testcase.
Keywords: testcase
I just noticed that style="float: right;" has also problems in initial load of
the page. Reloading fixes problem with "float: right;", but has no effect on
left one.
*** Bug 129345 has been marked as a duplicate of this bug. ***
Priority: -- → P3
Target Milestone: --- → Future
QA Contact: madhur → tpreston
heh, i just went over floater bugs and noticed the strange floating point
rounding errors when resizing the testcase
http://pali.sk/mozilla/fieldset_testcase.html.
A floated fieldset also destroys layout of a table contained inside.
fieldsets 1 & 2:
 Notice how the table cells don't line up correctly.

fieldset 1:
 Notice the gap on the rhs of the table directly proportional to the width of
the col. When the width of the col is changed, the width of the gap is changed
also. The border of the col can be seen behind some of the misaligned cells.

fieldset 2: 
 Notice the legend has the full width of the fieldset. Setting css properties
of the legend "width", "display", and "position" has no effect in any
combination.
This is more of the "only first part of size-finding reflow is done" crap.

We really need a better way of automating this shrink-wrapping stuff a little
more...
I suspect that the "real fix" would involve munging the availSize a bit more
and maybe calling FinishReflowChild before doing the second Reflow()....
Resizing testcase in Gecko/20030516 Mozilla Firebird/0.6 window is strange...
the right-floated fieldsets are jumping between correct and incorrect rendering
depending on odd/even window width. Not that it helps to solve the left-floated
ones.. ;-)
*** Bug 220178 has been marked as a duplicate of this bug. ***
Assignee: rods → form
Keywords: helpwanted
OS: Windows 2000 → All
Priority: P3 → --
QA Contact: tpreston → ian
Hardware: PC → All
Target Milestone: Future → ---
This bug is present in Firebird too.
Blocks: 210876
*** Bug 235509 has been marked as a duplicate of this bug. ***
Summary: Fieldset renders incorrectly with style="float: left;" → Fieldset renders incorrectly with style="float: left;" or any other shrink-wrap situation
*** Bug 251120 has been marked as a duplicate of this bug. ***
Whiteboard: [reflow-refactor]
*** Bug 342298 has been marked as a duplicate of this bug. ***
I've made a simple test case that portraits the bug as it affects table cells inside a floating fieldset: http://theinnercircle.no/misc/floating-fieldset.html
Weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(Fields not lined up nicely)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(Fields lined up nicely)

-->RESOLVED FIXED (and mark blocking bug 300030) ??
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.

(I checked the dupes too)

-> FIXED (by the reflow branch landing)
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
We need a testcase in the regression suite for this.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.