back button loses scroll position on page with non-ASCII (iso-8859-1) char without proper meta

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: marc, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

When a document contains non-ASCII (ISO-8859-1) characters like 'é' without a
proper meta tag (didn't try with HTTP header) then the back button loses the
scroll position (reset to top of page)

Reproducible: Always

Steps to Reproduce:
1. Go to http://home.infomaniak.ch/mongenet/Marc/Mozilla/scrollback.html
2. scroll down page
3. follow link (to Mozilla.org)
4. use back button

Actual Results:  
The top of the page is dsiplayed

Expected Results:  
Should have kept the scroll position and display the part I was viewing before
following the link.
(Reporter)

Comment 1

16 years ago
Created attachment 126684 [details]
HTML page with the bug
(Reporter)

Comment 2

16 years ago
Oups, given URL and test case does not seem to expose the bug today.

But this bug still exists for documents on the local disk (file:// URL),
so please save the attachement on your disk to reproduce the bug.

Comment 3

15 years ago
Dupe of bug 205391 ?
(salut Marc!)

Comment 4

15 years ago
I have the same problem on ALL pages! Using firbird 0.7 with winXP pro

While viewing this list of bugs for example; I click on a link then the scroll
returns to the top of the page when I click back again!

Very annoying!

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 217120 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
Here's another page that might demonstrate this issue:
http://w1.193.telia.com/~u19311232/olympiapage1.html

Is this still a duplicate of Bug 217120?  I'm not sure of the cause for Bug 217120.

Comment 7

15 years ago
Re. comment #1: WFM
Re. comment #2: WFM
Re. comment #6: The URL there WFM
Re. comment #4: scroll position lost in bugzilla pages is bug 47350

tested with a current CVS build, Linux

Updated

15 years ago
Blocks: 251784
Product: Browser → Seamonkey
WFM with FF1.0.4 and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2)
Gecko/20050515 Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.