Closed Bug 211041 Opened 17 years ago Closed 17 years ago

Can't work with upper case character for filter of about:config

Categories

(Core :: Preferences: Backend, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 234724

People

(Reporter: hidenosuke, Assigned: ccarlen)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030628
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030628

If you enter uppler case character in the filter of about:config
nothing will be matched.

Reproducible: Always

Steps to Reproduce:
1.Open the about:config screen
2.Enter uppder case character like I
3.
Actual Results:  
Nothing will be matched.


Expected Results:  
The item that has you entered the character will be matched.
*** Bug 211040 has been marked as a duplicate of this bug. ***
Well... pref names are case-sensitive.  Why should the filtering not be?
Confirmed in build 2003062808 on Mac OS X 10.2.6

The preference-names are indeed case-sensitive, but the filter shouldn't be.
Neither is the filter in mail/news or the typeahead.
Status: UNCONFIRMED → NEW
Ever confirmed: true
That fails to follow...  The mailnews filters are case-insensitive because mail
headers are case-insensitive by definition.  Typeahead has nothing to do with
this bug....
I think that case-insensitive filter (search?) is more convenient.
looks ok. But I would call substring.toLowerCase() first, and assign it to a
temporary variable, rather than calling it once per loop.
Note: attachment 128769 [details] [diff] [review] or attachment 128771 [details] [diff] [review] from bug 213832 also fix this bug
and add some more features.
The problem with the case-sensitivity of this filter (in case that hasn't been 
made clear) is that any upper-case character renders the searchstring useless.
For instance, filtering on "username" brings up the "server....userName" 
preferences, but filtering with "userName" brings up nothing.  This is quite the 
opposite of "case-sensitive" filtering; it is case-broken filtering.

The preferred behavior, it seems to me, is if the filter string is all 
lower-case, filter insensitively; if it is mixed-case, filter sensitively.

But a completely insensitive filter would be preferred to the current behavior.

*** This bug has been marked as a duplicate of 234724 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.