Last Comment Bug 211106 - Can't programatically delete nodes under a -moz-user-select: all; element
: Can't programatically delete nodes under a -moz-user-select: all; element
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 Windows 95
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
data:text/html,<label>Run this search...
Depends on: 769967
Blocks: 210676
  Show dependency treegraph
 
Reported: 2003-06-30 07:39 PDT by neil@parkwaycc.co.uk
Modified: 2012-07-24 10:17 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description neil@parkwaycc.co.uk 2003-06-30 07:39:32 PDT
-moz-user-select: all; is only supposed to affect user actions.
It is not supposed to affect program actions.
Comment 1 neil@parkwaycc.co.uk 2004-01-20 02:36:19 PST
Steps to reproduce problem:
1. Edit the Bugzilla Query Page, or the URL provided
2. Click on Run this search
3. Click on <label> in the struct toolbar
4. Click Format/Label Properties
5. Enter some new text
6. Click OK

Expected results: text of label changes

Actual results: entire label deleted
Comment 2 :Aryeh Gregor (away until August 15) 2012-07-24 01:08:21 PDT
I can't reproduce this -- I don't understand the test-case in comment 1.  What's the "struct toolbar"?  I suspect this was fixed by bug 769967 part 5.
Comment 3 neil@parkwaycc.co.uk 2012-07-24 03:09:17 PDT
(In reply to Aryeh Gregor from comment #2)
> I can't reproduce this -- I don't understand the test-case in comment 1. 
> What's the "struct toolbar"?  
Part of SeaMonkey Composer. But that's not important, I was able to verify the fix without recourse to it.

> I suspect this was fixed by bug 769967 part 5.
Indeed! Yay :-)

(This really helps with several of Composer's form properties dialogs)
Comment 4 :Aryeh Gregor (away until August 15) 2012-07-24 03:34:20 PDT
CCing ehsan to let him know that this was really causing problems, since he expressed reservations about bug 769967 part 5.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-24 10:17:10 PDT
(In reply to :Aryeh Gregor from comment #4)
> CCing ehsan to let him know that this was really causing problems, since he
> expressed reservations about bug 769967 part 5.

Oh nice!  This is sort of a relief.  :-)

Note You need to log in before you can comment on or make changes to this bug.