Last Comment Bug 211201 - Java applet doesn't show anything.
: Java applet doesn't show anything.
Status: RESOLVED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Java APIs for DOM (show other bugs)
: Trunk
: x86 Windows 2000
: -- major (vote)
: ---
Assigned To: Ashu Kulkarni
: Alexei V. Mokeev
Mentors:
http://tw.ezchat.yahoo.com/list/list/...
: 239655 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 23:38 PDT by tmpy2
Modified: 2012-04-09 22:27 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description tmpy2 2003-06-30 23:38:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Hi,
  I'm using mozilla 1.4 final and Sun's Java 1.4.2 final.
  When you get into one of the chat rooms, the java applet supposed to load and
start. The java chat window shows it has loaded and started but it does NOT show
anything in the chat window. It seems it has stuck.  To test it wasn't a sun's
java fault, I used IE 6.0 with sun java 1.4.2.  That combination worked just
fine. I guess something is wrong on mozilla side...

Thanks for looking into this bug.

Reproducible: Always

Steps to Reproduce:
1. go to http://tw.ezchat.yahoo.com/list/list/list_1.html
2. A list of chat rooms would show up. go into any room preferably a room with
many people.
3. A java chat window should popout.
4. The problem: it's stuck and nothing is showing in the chat window.

Actual Results:  
nothing is showing in the chat window.

Expected Results:  
Chat window should start showing who's in the room on the left side of the
window and what people are typing on the right side.
Comment 1 Bob Clary [:bc:] 2004-04-06 10:46:51 PDT
Java(TM) Plug-in: Version 1.4.2_02
Using JRE version 1.4.2_02 Java HotSpot(TM) Client VM
----------------------------------------------------
load: class chat.class not found.

java.lang.ClassNotFoundException: chat.class
	at sun.applet.AppletClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadCode(Unknown Source)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Caused by: java.io.IOException: open HTTP connection failed.
	at sun.applet.AppletClassLoader.getBytes(Unknown Source)
	at sun.applet.AppletClassLoader.access$100(Unknown Source)
	at sun.applet.AppletClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	... 10 more
Comment 2 Bob Clary [:bc:] 2004-04-06 13:52:15 PDT
*** Bug 239655 has been marked as a duplicate of this bug. ***
Comment 3 RNicoletto 2011-07-20 02:45:27 PDT
The Yahoo! Chat Room is Out of Service since November 5, 2004.

Note You need to log in before you can comment on or make changes to this bug.