Closed Bug 21148 Opened 20 years ago Closed 20 years ago

Enable OJI in linux

Categories

(Core Graveyard :: Java: OJI, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 15071

People

(Reporter: moshev, Assigned: drapeau)

References

()

Details

Attachments

(1 file)

Since a plugin is now available for linux from Blackdown team and
is downloadable at
ftp://ftp.tux.org/pub/java/JDK-1.1.8/i386/v1/JavaPlugIn_1.1.2_k-glibc-2.1.2.sh
I checked whether it works for mozilla by copying
javaplugin.so.* from .netscape to package/plugins.
for now, mozilla in linux ignores Java plugin and applets are not
working
Expected results: After installing plugin applets should
start working
Actual result: Mozilla ignores applets.
Thank you for the update.  I doubt whether that plugin will work, though, if
this plug-in source is based on Sun's Java Plug-In source: the Sun Java Plug-In
1.1.2 worked with Mozilla builds from a while ago, but many Mozilla API changes
have been made since then.  The Sun JDK group has been trying to follow Mozilla
changes, and the JDK 1.3 JVM for Windows works (Solaris still catching up).

We'll check this out, see if it works.

Meanwhile, have you built your own copy of Mozilla with "--enable-oji" turned on
when you run the "configure" script?  That may be why your copy of Mozilla
doesn't see Java, if you're using your own build.
Thank you for the update.  I doubt whether that plugin will work, though, if
this plug-in source is based on Sun's Java Plug-In source: the Sun Java Plug-In
1.1.2 worked with Mozilla builds from a while ago, but many Mozilla API changes
have been made since then.  The Sun JDK group has been trying to follow Mozilla
changes, and the JDK 1.3 JVM for Windows works (Solaris still catching up).

We'll check this out, see if it works.

Meanwhile, have you built your own copy of Mozilla with "--enable-oji" turned on
when you run the "configure" script?  That may be why your copy of Mozilla
doesn't see Java, if you're using your own build.
Thank you for the update.  I doubt whether that plugin will work, though, if
this plug-in source is based on Sun's Java Plug-In source: the Sun Java Plug-In
1.1.2 worked with Mozilla builds from a while ago, but many Mozilla API changes
have been made since then.  The Sun JDK group has been trying to follow Mozilla
changes, and the JDK 1.3 JVM for Windows works (Solaris still catching up).

We'll check this out, see if it works.

Meanwhile, have you built your own copy of Mozilla with "--enable-oji" turned on
when you run the "configure" script?  That may be why your copy of Mozilla
doesn't see Java, if you're using your own build.
Nope i have not built mozilla, i usually download nightly binaries,
maybe i should move to source..
Hey guys,  what is the status of this currently?
I would not have time to check it this week.
If someone else could check it out, please do so..
Target Milestone: M13 → M14
move to m14. let me know if fixes are available. thx.
Java Plugin 1.2.2 is now available from blackdown at
http://www.blackdown.org/java-linux/jdk1.2-status/plugin-status.html

What are the exact steps to try whether it works with Linux mozilla? 
Should copying the plugins directory content be enough?
after copying the javaplugin.so to package/plugins directory
and ~home/.netscape/java to package/
I start getting the following:

.//run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/home/dwnl/mozilla/package
  LD_LIBRARY_PATH=/home/dwnl/mozilla/package
       SHLIB_PATH=/home/dwnl/mozilla/package
          LIBPATH=/home/dwnl/mozilla/package
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nNCL: registering deferred (0)
WEBSHELL+ = 1
WEBSHELL+ = 2
.//run-mozilla.sh: line 29: 17388 Segmentation fault      $prog ${1+"$@"}  


This is with Java plugin 1.2.2 from blackdown. 
I think someone needs to contact blackdown developers, 
since they seem completely anaware of the need to OJI enable their plugin.

                                             
I have just runned it with strace, and attached the result.
hope it helps someone to understand what is going on.

Sorry to burst everybody's bubbles, but there is no way this version of the
plugin will work with Mozilla. This plugin is based on the old plugin API, and
the only Java Plugins which work with Mozilla are the versions based on the "not
yet released" JDK1.3, not JDK1.2.

I vote that we just close this bug, unless anyone has any objections.
Is any JVM 1.3 plugin will automagically work with mozilla ?
If so then i have no objection closing it untill then, 
but if the plugin will have to be checked for compatibility
why not leave this bug open untill then?
Also why is it not possible to make mozilla work with older plugin api's?
After all older plugins work with netscape if you use the EMBEDD tag
so it would only be necessary to translate APPLET tag to EMBED tag internally
in mozilla and voila, or am i completely of the base?
this plugin does have the entry points for a mozilla plugin.  I'm looking at
this seeing if there is anything I can do.
oh.  i see mark.. hmm.. well, we need a bug on java not working on linux... but
uhm.. i'm not sure what to do.
Okay, pavlov, I've got an answer.  I agree that "OJI not working on Linux"
should be marked as a bug; we just can't do anything about it until the JDK
folks finish their port of the 1.3 Java Plug-In to Linux JDK 1.2.2.whatever.
(I talk to them several times a week, so am as on top of it as I can be)
Meanwhile, I'm gonna mark this as a duplicate bug #15071, since that's the first
time I remember seeing "Linux/Java no worky" coming up.

Let me know if this doesn't seem right to you, and I'll consider reversing the
decision.  For now, it's gonna be marked as a dup.


*** This bug has been marked as a duplicate of 15071 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
sounds good to me.
Verified dupe of 15071 "Java applet not loading on Linux/Mac OS"
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.