Closed Bug 15071 Opened 20 years ago Closed 19 years ago

Java applet not loading on Linux/Mac OS

Categories

(Core Graveyard :: Java: OJI, defect, P4)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: ludo, Assigned: drapeau)

References

()

Details

Using mozilla Build ID 1999092708 on a Debian "Potato".
If you go on the above URL with Netscape 461, on the right side of the main page
You'll see some "buttons", they are not displyed under Mozilla.
QA Contact: leger → elig
QA Assigning to self.
I'm assuming that the reporter refers to the buttons "Infos" "Photos" etc.
Those are APPLETs and work fine in apprunner 1999-09-25-09-M11 on Windows NT.
Maybe APPLETs doesn't work on Linux yet ?
QA Contact: elig → desale
I believe that the problem is as mats says --- there's no Java on Mac or Linux,
therefore, these Java-based buttons don't work on those platforms. (When I
disable Java within 4.5, the page behaves similarly to within Apprunner.)

QA Assigning to desale, who is the Java QA expert. Prashant, what should happen
to this bug? [I can't find a general "Java doesn't work on Linux & Mac OS" to
mark it a duplicate of.]

Thanks!
Assignee: don → drapeau
Component: Browser-General → OJI
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: M14
I believe I can offer some assistance.  There currently is a working VM for the
Macintosh; Patrick Beard implemented a working MRJ Plugin and Mark Lin has done
some work to assure that it works with current Mozilla builds.

On the other hand, there is no current Linux JDK Plugin, so there is no way to
test the Linux OJI support.  We believe that the Linux support works, since the
Solaris OJI support is now working, but we won't be able to confirm until
somebody implements a Linux JDK Plugin.  We don't expect that to happen for a
few months (nobody currently owns that problem, as JDK plugins are not a
Mozilla/Netscape/OJI problem, but rather seen as a third-party problem).

I will mark this bug as due in M14 (i.e., after Beta) and will lower the
priority on it.  When Linux support for OJI is ready and tested, this bug will
be re-visited.
Summary: some Pictures used to link to other pages don't appear → Java applet not loading on Linux/Mac OS
Thanks, drapeau@eng.sun.com!
Depends on: 13848
*** Bug 21148 has been marked as a duplicate of this bug. ***
I'm moving the milestone on this out because we still don't have access to a
Linux OJI-compliant JVM.  I've spoken with the JDK team at Sun about their
ETA; still haven't heard a response.
Target Milestone: M14 → M16
Updating QA Contact.
QA Contact: desale → paw
There is an OJI plugin in the new JDK 1.3 from IBM
http://www.alphaworks.ibm.com/tech/linuxjdk

I have tried using it, but it seems that OJI is not enabled in 
latest Linux nightly builds.

see my posts from today to netscape.public.mozilla.oji

Can anyone confirm whether OJI is enabled in nightly builds for Linux?

As far as I know, there is no oji plugin for Linux.  Hopefully soon.
Paw, you are wrong, there IS NOW an OJI plugin from IBM.
read my posts at n.p.m.oji
adding myself to cc while I download the new sdk.  I could really go for Java
support on Linux/Mozilla!
If this bug has become for linux, then it's a duplicate of #28461
Also, see comments on #28461 about latest 1.3 release, it will
save you 30mb of download
*** Bug 28461 has been marked as a duplicate of this bug. ***
No no no, Bug #28461 is the bug with all the info in it, 
It should be the other way around IMHO.

M16 has been out for a while now, these bugs target milestones need to be 
updated.
hi, if anyone has voted for this bug for linux java support, please jump to
bug #49451 ( http://bugzilla.mozilla.org/show_bug.cgi?id=49451 ) and make your
vote there.
This page has no applets.  Marking invalid.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Verified in build 2000102612 on Linux.  There are no applets
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.