Closed Bug 211669 Opened 19 years ago Closed 19 years ago

The back function of laptops' touchpad won't work

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: dague, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030702 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030702 Mozilla Firebird/0.6

Laptops' touch pad seem to have similar behavior like the scrolling, where if
you move the finger on top of the touch pad to the left, it sends the back
signal, which of course is identified by IE, but Firebird doesn't seem to
understand that (I think is part of Windows, it is not a trick done by the
touchpad's drivers), I would say the event should come similarly to how the
scrolling with the mouse wheel comes.

Reproducible: Always

Steps to Reproduce:
1. Using any laptop touch pad, and moving the finger on top of the touchpad
slightly to the left.
Actual Results:  
It doesn't go back.

Expected Results:  
It should have gone back to the previous page.
dupe of bug 146962?
Simon, looks like it to me too.

Reporter, please check out bug 146962 and follow the instructions in the various
comments to test this.  If you are not using a Synaptics touchpad,  please feel
free to reopen this bug.

*** This bug has been marked as a duplicate of 146962 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
I did check that Synaptics bug first before posting this, and no, it is not
related, it is not a Synaptics touchpad.

This touchpad seems to use some standard events for the scrolling and back
function, and the scrolling does work with it. Is the "back" event the one that
does not work.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Daaniel, I may be wrong here, but as far as I know, there is no standard event
for the back function (as there is for scrolling). So this built-in back
function for IE in your touchpad might be just that: A driver hook especially
for IE.

Could you tra any other browser (Netscape 4, Netscape 7.1, Mozilla 1.4, Opera 7)
and see if it works there? If it ain't I think we can be quite sure, that this
is a IE-only function and therefore no Firebird-issue.
Daniel, if it was a built in Windows/IE thing, Synaptics wouldn't need it in
their drivers.  What type of touchpad do you have/model of notebook?  I imagine
if the driver is any good it has the ability to do similar things in other
applications, but the manufacturer should have some idea.
Mike, It is an Alps touchpad on a Toshiba Satellite laptop, the driver dates in
2001, and I haven't found any newer driver (it is the one provided by the
manufacturer and came preinstalled, not those ones that say Microsoft).
Daniel, what about testing with other browser?
I really don't think that this is firebird-issue.
Latest Alps driver from Toshiba for WinXP, dated 03-18-2003

http://cdgenp01.csd.toshiba.com/content/support/downloads/s113tpadx.exe

If you can wait a few more days I can bug some friends doing support for Toshiba
notebooks.

Either way, its not a bug with Mozilla, since Mozilla doesn't have any built-in
support for touchpad special functions.  My guess is that a driver dated 2001
won't have support for Mozilla, which hit 1.0 in mid 2002.  I also found
reference to older drivers having problems in certain applications doing the
special functions.  Marking INVALID due to this certainly being a driver issue,
but please update the bug with the results of the driver update.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
Mike: Thanks for the driver, I tried to look for it like 7 months ago, but since
they had a very old version I though it was kind of discontinued, and never
looked again. Although this did not fix the problem.

Although I would like if this can be fixed, don't worry alot about it, I can
live with it, and is a kind of specific problem, although I appreciate a lot the
effort that you guys put into making this browser so great. This browser is
getting pretty good, and in fact although it is under developement, it is
already the best. I understand that this might be a specific function that the
driver implemented and calls IE's back function, so there might not be much that
can be done other than asking them to make their drivers compatible with
Mozilla. Keep the great work on Firebird!
You need to log in before you can comment on or make changes to this bug.