Release Notes (1.0 ~ 1.4) - how to enable synaptics touchpad mouse scrolling

VERIFIED FIXED

Status

www.mozilla.org
General
--
minor
VERIFIED FIXED
15 years ago
5 years ago

People

(Reporter: Michael Burns, Assigned: Daniel Wang)

Tracking

({relnote})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020512 Netscape/7.0b1
BuildID:    2002052306

On all Dell and other Manus. laptops which use Synaptics touchpads, ie a lot of
them, mouse scrolling does not work by default. There is a fix, but it need to
be documented in the release notes under "Mouse wheel scrolling". Currently all
Dell, Compaq etc laptop users will lose the ability to scroll web pages if they
switch to Mozilla. 

Reproducible: Always
Steps to Reproduce:
1. Try to scroll a web page on a laptop with a Synaptics touchpad.
2.
3.

The fix is to edit the file c:\program files\synaptics\syntp\syntpenh.ini

Copy the line that says:
[Netscape Navigator/Communicator]
WT = "*Netscape 6*"
SF = 0x10000000
ST |= 0x00004000

and put this below it

[Mozilla]
WT = "*Mozilla*"
SF = 0x10000000
ST |= 0x00004000

It does not fix scrolling for all Moz apps ,ie scrolling in mail may not always
work, but at least scrolling will now work for web browsing.

Comment 1

15 years ago
-->jatin
Assignee: rudman → jatin

Comment 2

15 years ago
On my Dell Inspiron 4100 with Windows XP Home Edition, the only *Netscape 6*
entry in my Synaptics INI file is

[Netscape Navigator/Communicator]
WT = "*Netscape 6*"
SF = 0x10000000
SF |= 0x00004000

This doesn't quite match the settings given in the example. I copied those lines
and as a result added the following section:

[Mozilla]
WT = "*Mozilla*"
SF = 0x10000000
SF |= 0x00004000

This makes my touch pad work just fine. I don't know the significance of SF
versus ST, etc., but I wanted to mention this anyway.

- Bill
(Reporter)

Comment 3

15 years ago
Sorry your right it shold be SF and NOT ST. I was a bit bleary eyed when I wrote
that. FYI I am using the latest Synaptics driver as of the day I posted.

Updated

15 years ago
Keywords: mozilla1.1, relnote

Comment 4

15 years ago
Michael, this does not affect _all_ Dell laptop users with synaptics touchpads.
I've never made the change you suggest on my Latitude CPxJ and touchpad
scrolling has worked for me for quite a while.
(Reporter)

Comment 5

15 years ago
Have a look at this thread which I missed, perhaps this should be reopened since
it is apparently not completely fixed. Ie in email and in other situtations
where the word Mozilla is pushed too far right in the browser title, scrolling
ceases to work.
http://bugzilla.mozilla.org/show_bug.cgi?id=56892

Also note as per my original intent, I still believe this workaround should be
linked to in the release notes.
(Reporter)

Comment 6

15 years ago
Found a fix linux scrolling as well! This page
http://mobilix.org/touchpad_driver.html has a synaptics driver for X that among
other things activates the "right side scrolling" for touchpads. I just
installed it on a stock Redhat 7.3 laptop install and it works great. Mozilla
along with Konq and all of my X apps now scroll.

Comment 7

15 years ago
Created attachment 98402 [details]
FIX for Synaptics Touchpad Scrolling Bug In Mozilla 1.x & Netscape 7.x

This bug was reported early in 2002 when the later 0.9x or the beginning of the
1.x builds were starting to be propogated. There was a report in bugzilla on a
fix for the Mozilla Browser that required a modification to the .ini file.
However, I will have to go through the archives of my e-mail to find the actual
fix. Please note, this is the same bug that Netscape 7.x suffers from however,
this fix will only work with Mozilla Only browsers.

Anyone who needs this fix, please e-mail me with your request to:
mozilla@hitradio.biz.

Good Luck.
Scot Michaels

Comment 8

15 years ago
This is fixed in some versions of the Synaptics driver. The new driver includes
the following in SynTPEnh.ini:

[Mozilla]
FC = "MozillaWindowClass"
SF = 0x10000000
SF |= 0x00004000

Note that this does not rely on the word "Mozilla" to be in the title bar so is
more reliable than the previous suggestion.

I do not know if this is incorporated into all Synaptics drivers. Mine is an OEM
version called "IBM ThinkPad UltraNav Driver Version 6.7.3.4".
(Reporter)

Comment 9

15 years ago
Hi Nathan, that must be a vendor specific fix. The latest drivers from Synaptic's website  US6018XP_2.zip which is for XP does not have that, it only contains a entry for Netscape and Netscape 6. As posted above, to get Mozilla to work on my Dell Inspiron 4000 I've had to manually edit Syntpenh.ini.

But the great news is that that entry works perfectly :-) Like you said it no longer requires Mozilla to appear in the titlebar. I have tested with Mail and Composer and scrolling works as it should. I'm glad there is a resolution to this which doesn't rely on the titlebar. Thanks for posting it.

Comment 10

15 years ago
What should the release note say?
Keywords: mozilla1.1 → mozilla1.3
(Assignee)

Comment 11

15 years ago
*Known Problems*
 :
Keyboard and Mouse
  blah
Mouse wheel scrolling
  blah
Synaptics touchpad
  Window: Synaptics touchpad scrolling is not enabled for Mozilla by
  default. To activate the feature, open the file
  c:\program files\synaptics\syntp\syntpenh.ini with Notepad.
  Add the following text and save the file:

     [Mozilla]
     FC = "MozillaWindowClass"
     SF = 0x10000000
     SF |= 0x00004000
Assignee: jatin → mitchell
Blocks: 133795
Component: User → Miscellaneous
Product: Documentation → mozilla.org
QA Contact: rudman → mitchell
Summary: Need note on how to enable mouse scrolling for synaptics touchpads → Release Notes (1.0 ~ 1.3a) - how to enable synaptics touchpad mouse scrolling
Version: unspecified → other
(Assignee)

Updated

15 years ago
Blocks: 187393

Comment 12

15 years ago
Reassigning to Dawn, who works on the Release Notes more than I.

ml
Assignee: mitchell → endico

Comment 13

15 years ago
Two minor nits: 1. "Window:" should be "Windows:" 2. A reboot is required for
the changes to take effect.

Comment 14

15 years ago
I have a samsung p10 laptop with a synaptics touchpad. 
All I had to do to get "mousewheel" - ie dragging finger along the right edge of
the pad - functionality under Mozilla 1.3a (winxp home edition) was to install
the latest drivers I found on the synaptics website
(http://www.synaptics.com/support/downloads.cfm#drivers)
Owen is taking QA for "repeating relnote" bugs. Sorry for the spam; search for
the previous string to find and delete these messages.
QA Contact: mitchell → malachi

Comment 16

14 years ago
two more minor nits:

1)
  c:\program files\synaptics\syntp\syntpenh.ini
is only one possible location for the SynTPEnh.ini file. The path depends on 
your Windows' language (i.e. german Windows calls it C:\Programme\... ), and on 
the chosen install options for Synaptics drivers and Windows itself.

Maybe just tell people to search for SynTPEnh.ini on their system.

2)
  regarding Comment #13 From Nathan Silva:

A reboot is not necessarily required. It is sufficient to terminate & restart 
the running "SynTPEnh.exe", i.e. from Task Manager.
However, for unexperienced users, a reboot will be the easiest way to activate 
the .ini changes  

Comment 17

14 years ago
*** Bug 207903 has been marked as a duplicate of this bug. ***
*** Bug 211669 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

14 years ago
-> me
Assignee: endico → stolenclover
Keywords: mozilla1.3
Summary: Release Notes (1.0 ~ 1.3a) - how to enable synaptics touchpad mouse scrolling → Release Notes (1.0 ~ 1.4) - how to enable synaptics touchpad mouse scrolling
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 20

14 years ago
fixed
No longer blocks: 187393
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Component: Miscellaneous → webmaster@mozilla.org
Resolution: --- → FIXED
*** Bug 213191 has been marked as a duplicate of this bug. ***
*** Bug 209697 has been marked as a duplicate of this bug. ***
*** Bug 215066 has been marked as a duplicate of this bug. ***
I have an IBM ThinkPad 390E and it runs on Windows 98.  Mozilla (and the
Netscape 7.1 browser) does not allow me to use my third button that, when held
down, allows mouse scrolling in a browser (and elsewhere).  I looked in
C:\Program Files, but there is no folder/directory for Synaptics and I can't
find the file syntpenh.ini elsewhere on my C drive either.  Is there a different
fix for Think Pads?  I read what Nathan posted, but I couldn't find anything on
my Think Pad like he describes.  Please Help!
(Assignee)

Comment 25

14 years ago
mid button scrolling is bug 22775
Status: RESOLVED → VERIFIED
*** Bug 221919 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
*** Bug 222048 has been marked as a duplicate of this bug. ***
*bugspam*

Comment 29

14 years ago
*** Bug 223018 has been marked as a duplicate of this bug. ***

Comment 30

14 years ago
*** Bug 219943 has been marked as a duplicate of this bug. ***
*** Bug 246975 has been marked as a duplicate of this bug. ***
*** Bug 229481 has been marked as a duplicate of this bug. ***
*** Bug 228764 has been marked as a duplicate of this bug. ***

Comment 34

13 years ago
It still does not work with Thunderbird or Firefox - are there any workarounds?
I tried to replace "Mozilla" with "Firefox" or "Thunderbird" - it did not work.
BTW - can some1 explain why this is a driver issue - how can a driver not suport
a  GUI compliant program?

Comment 35

12 years ago
same problem, synaptics touchpad scrolling mouse rendered inoperative in Firefox
1.02 on Compaq presario x1000. i clicked on the link for the 'fix" attachment,
but it is incomprehensible to me. THis is a VERY COMMON ISSUE, with many bug
reports. KINDLY provide a fix asap!

Comment 36

12 years ago
Unfortunately, now I can see, that the problem was caused by touchpad driver
update (with Windows optional update). It was update to v7.12.7 from v7.5.3.8.
Only after a full removal (simple removal did not help, I had to clean reg by
hands) of the new version and the old version installation, problem was solved.
I should underline, that mentioned above .ini file for both driver versions contain

[Mozilla]
FC = "MozillaWindowClass"
SF = 0x10000000
SF |= 0x00004000

but it does not help... - I tried to change [Netscape...] record as it was
described above, but it did not help either.
Product: mozilla.org → Websites

Comment 37

8 years ago
maybe this is a little too late, and maybe the newest version of synaptics' driver has solved it, but for those people who still using 10.2.xxx hacked driver in order to get multitouch/chiral/momentum features, you can always type this command: taskkill /im SynTPEnh.exe   into a notepad and save it as .bat, then put this file into startup folder.

this command doesn't actually SynTPEnh.exe process, as you soon will find out. But somehow it enables you to use Chiral feature in Firefox, that's the most important thing. Isn't it?
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.