If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Widget:GTK2 - 'select' form elements on layers leave their dropdown list when their parent layer is moved if they have been clicked.

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: tim stebbing, Assigned: blizzard)

Tracking

({testcase})

Trunk
x86
Linux
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

When I put a form on a layer, and that form has select elelements, if the select
is clicked and it drops-down its list, then the layer is moved with javascript, 
even if the select has retracted the select's dropdown content stays where it was.
These small boxes of select options are even visible over another mozilla window
if placed over the first one.

Reproducible: Always

Steps to Reproduce:
1. create a layer <div> with absolute position and a z-index > 0
2. add a select form element to the layer, click the select to expand its options
3. move the layer using javascript to another location

Actual Results:  
selects option list stays in place, superimposed over even other browser windows.

Expected Results:  
The select options box should have been destroyed
Maybe form controls, maybe Views.
Assignee: other → form
Component: Layout → Layout: Form Controls
QA Contact: ian → desale

Comment 2

14 years ago
Tim, please provide a testcase or URL.
(Reporter)

Comment 3

14 years ago
Created attachment 127199 [details]
Testcase/screenshots

Comment 4

14 years ago
steps to reproduce with the testcase?
1. click the select to get the dropdown menu
2. close dropdown menu by clicking elsewhere
3. click "MoveMe"
4. click the select again, menu appears where it used to be

if those are the steps to reproduce, this bug worksforme (menu appears at the
top where it should)
(Reporter)

Comment 5

14 years ago
Once you click 'MoveMe' the layer and form will move, but for me the 
menu representing the options of the select (the bit that drops down)
appears where the layer used to be. See the screenshots I included with
the testcase.

The select will still operate fine in its new location, thats not the 
issue, its that the 'ghost' of the old menu still appears in the old
location.

Perhaps its an issue specific to the linux build? or perhaps X? Im
running the GTK2 enabled mozilla 1.4 on RH9 gnome desktop. 
Most likely a GTK2 issue
(Reporter)

Comment 7

14 years ago
I just tested it under windows mozilla 1.4a and could no replicate the bug,
pointing to a gtk2 issue.

Comment 8

14 years ago
.
Assignee: form → blizzard
Component: Layout: Form Controls → GFX: Gtk
QA Contact: desale → ian
Summary: 'select' form elements on layers leave their dropdown list when their parent layer is moved if they have been clicked. → Widget:GTK2 - 'select' form elements on layers leave their dropdown list when their parent layer is moved if they have been clicked.

Comment 9

14 years ago
confirmed with linux trunk/CVS/gtk2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 10

14 years ago
Created attachment 128484 [details]
just the testcase
(Assignee)

Comment 11

14 years ago
Well, that's just weird.
Blocks: 92033

Comment 12

14 years ago
Just a "Me, too".  I'm running Mozilla 1.7b (UA = Mozilla/5.0 (X11; U; Linux
i686; en-US; rv:1.7b) Gecko/20040326) on Gentoo Linux under Gnome 2.4.  It's the
GTK build, and I get the same problem.

Ian
Created attachment 148405 [details]
This attachement contains another testcase (html with a dropown box that use some javascript to change the css).

This is the testcase that made me discover this bug.
When the javascript switches the css, the layout is modified then the bug
appears.
It even stays on the top of the display when switching to another virtual
desktop (gnome(2.4|2.6)/gtk+(2.2|2.4)) or moving mozilla windows out of the
dropdown area.
Reproduced on 4 machines either using binaries or self-compiled
moz/firefox/epiphany on x86 and ppc (running linux). Konqueror (linux env) & IE
not affected.

Comment 14

14 years ago
bug 241187 might be a dup of this bug. But I have a patch there and can fix the
problem.
The problem is that the visibility status for the popup is not right. So when
SyncFrameViewProperties is called, the popup will be shown again.
I do appreciate if someone can review the patch for me.

Comment 15

14 years ago
load http://bugzilla.mozilla.org/query.cgi
Click once on the first dropdown box arror ("contains all of the words/strings)
Click View
Click View again (because it doesn't work the first time :)
Click Text Zoom -> 120%
Minimize Mozilla

I don't know if its the same bug but it's funny all the same:
The dropdown and its mysterious cousin live a life almost completely detached
from the rest of Mozilla.

Resizing the mozilla window by dragging the right edge towards the left will
also leave the boxes "standalone" if Mozilla window is made narrow enough

Resizing to the right for some reason makes them at move into main window area
now and then.

Comment 16

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051221 Firefox/1.6a1

Works for me. Reopen if you can reproduce in current builds.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.