Last Comment Bug 21193 - [FLOAT] Half-size Box Acid Test Layout broken due to rounding
: [FLOAT] Half-size Box Acid Test Layout broken due to rounding
Status: RESOLVED FIXED
: css1, testcase
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: All All
: P2 minor with 4 votes (vote)
: mozilla1.9
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://style.cleverchimp.com/boxacidt...
: 195505 (view as bug list)
Depends on:
Blocks: float acid1
  Show dependency treegraph
 
Reported: 1999-12-08 13:34 PST by Jikes Incorporated
Modified: 2014-04-26 03:07 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
XHTML Testcase Floating Tables Width sums to 100% (7.87 KB, text/html)
2003-03-10 18:49 PST, Ronald Tilby
no flags Details
screenshot of URL link (16.85 KB, image/png)
2008-06-05 22:25 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description Jikes Incorporated 1999-12-08 13:34:19 PST
Oh dear.  Here comes another **** bug report.

Problem: http://style.verso.com/boxacidtest/half/  does not lay out correctly.
Standard 100% Box Acid Test does fine, 200% Box Acid Test does fine, 50% Acid
Test barfs, throwing boxes all over the place.

Platform: Win 95
Build: Daily, 12-8-99
Bug Reporter: Clueless, lazy, and at work without source.

Whether this is due to icky Win32 widget barfing, or actual layout problems, I
do not know, but it won't automagically fix itself no matter what I toggle or
manipulate, and it IS supposed to lay out correctly.

When I get home I will whack on it with a CVS build for Linux.  Please please
please fix CSS1!  There is a special place in Heaven for all you saints who are
working on Mozilla.  Thank you!
Comment 1 troy 1999-12-08 17:52:59 PST
Looks like a problem in the block code
Comment 2 David Baron :dbaron: ⌚️UTC-7 1999-12-13 16:58:59 PST
My memory is that this is actually not a bug, and the half-size boxacidtest is
invalid, because of rounding issues.

Marking as duplicate of bug 4098.  If you want this dealt with, reopen that bug
** and reassign it to the default owner of the component **.

*** This bug has been marked as a duplicate of 4098 ***
Comment 3 David Baron :dbaron: ⌚️UTC-7 1999-12-13 16:59:59 PST
Actually, I'm reopening this, because it works fine on Linux, and is therefore a
platform parity issue.  Marking as such.
Comment 4 leger 1999-12-14 12:52:59 PST
Clearing DUPLICATE resolution due to reopen.
Comment 5 leger 1999-12-14 13:53:59 PST
Updating to default Layout Assignee...kipp no longer with us :-(
Comment 6 troy 1999-12-14 14:14:59 PST
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
Comment 7 buster 1999-12-20 22:24:59 PST
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.
Comment 8 buster 2000-03-03 16:05:39 PST
mine! mine mine mine!  all mine!  whoo-hoo!
Comment 9 David Baron :dbaron: ⌚️UTC-7 2000-03-07 18:34:09 PST
This is currently a problem on Linux.  Removing pp keyword, adding css1 keyword,
marking All/All, adding dependency to boxacidtest tracking bug, and marking
[FLOAT].

I think the correct solution to this bug is in the float positioning code:  If a
float doesn't fit horizontally in its parent by less than half a pixel (or
perhaps it should be done by whether the edge would be rounded to outside the
parent / over another float when displayed, if that's possible), then I think it
should not be carried to the next "line" of floats.

I think this is a real problem, since people do use floater-based structures to
make columns using CSS.
Comment 10 rickg 2000-04-07 16:39:46 PDT
moving all buster m15 bugs to m16.
Comment 11 buster 2000-04-11 23:18:14 PDT
pushing off until after beta2
Comment 12 buster 2000-06-01 14:21:29 PDT
redistributing bugs across future milestones, sorry for the spam
Comment 13 ekrock's old account (dead) 2000-06-05 14:59:18 PDT
Nom nsbeta3, recc nsbeta3+. This test suite is highly influential and closely 
watched in standards compliance circles. css1 compliance issue.
Comment 14 Hixie (not reading bugmail) 2000-07-25 22:54:19 PDT
As per meeting with ChrisD today, taking QA.
Comment 15 Jason Eager 2000-07-31 17:33:25 PDT
Blah! Anyone actively working on this?

Comment 16 Marc Attinasi 2000-08-02 12:26:50 PDT
Taking a stab at prioritizing buster's nsbeta3 bugs...

According to IanH, this is a rounding problem caused by half-pixel values - 
deemed edge-case.
Comment 17 buster 2000-09-13 11:27:01 PDT
marking future:  not enough time to get to this edge case before RTM.  if 
someone else wanted to look into adding pixel rounding, I would be happy to work 
with them on it.
Comment 18 karnaze (gone) 2001-03-16 15:40:58 PST
Moving to m1.0.
Comment 19 Hixie (not reading bugmail) 2001-05-22 23:47:39 PDT
anyone remember what Todd's current server is called?
Comment 20 David Baron :dbaron: ⌚️UTC-7 2001-07-16 09:47:11 PDT
We need to change nsBlockReflowState::CanPlaceFloater (near the beginning) to
allow a half pixel of overflow.
Comment 21 Kevin McCluskey (gone) 2001-10-04 16:29:19 PDT
Build reassigning Buster's bugs to Marc.
Comment 22 karnaze (gone) 2002-02-04 17:42:08 PST
Changing url and moving to m1.1.
Comment 23 David Baron :dbaron: ⌚️UTC-7 2002-02-04 17:46:37 PST
Changing URL back to the one that works.
Comment 24 unapersson 2002-07-10 05:37:29 PDT
The URL given appears fine in both 1.0 and the latest nightly (on Win NT4).
Should this bug be marked fixed?
Comment 25 David Baron :dbaron: ⌚️UTC-7 2002-07-10 09:54:33 PDT
I think it would be easy to construct testcases that are still broken.
Comment 26 Arthur 2003-01-12 07:03:41 PST
The rounding issue is still there on linux 1.2.1 with text zoom 100%. Try
playing with the text zoom and it'll display sometimes just fine and sometimes
messed up.
Comment 27 Andrew Schultz 2003-01-12 08:32:07 PST
==> floats
Comment 28 louis bennett 2003-01-19 23:16:06 PST
perhaps of interest to some - the layout switches between proper and improper
rendering when you increase or decrease font size. (1.3a / os x)
Comment 29 David Baron :dbaron: ⌚️UTC-7 2003-03-01 06:52:38 PST
*** Bug 195505 has been marked as a duplicate of this bug. ***
Comment 30 Ronald Tilby 2003-03-10 18:49:17 PST
Created attachment 116822 [details]
XHTML Testcase Floating Tables Width sums to 100%

I think this testcase is a good demonstration of the problem.
Comment 31 Vedran Miletic 2003-10-05 08:01:05 PDT
retargeting
Comment 32 Travis Chase 2004-02-24 02:29:51 PST
Is this bug still a problem? the URL for the test case is long gone,
Comment 33 Ronald Tilby 2004-02-25 08:30:17 PST
Although the url in comment 0 is dead, the URL in the url field of the bug
(http://style.cleverchimp.com/boxacidtest/half/) is still alive, and still fails
to render properly using Mozilla 1.7Alpha.  The XHTML Testcase in the
attachments also still exhibits the problem.
Comment 34 Julien "_FrnchFrgg_" RIVAUD 2005-03-18 02:47:41 PST
I agree there is a problem with rounding here. But I am not sure the testcase
description is good: It expects the each whole div to fit on a line.

But, IMHO, the sum of table's widths is 100%; so calculating I get:

Total width of n tables stacked one after the other on one line =

sum for each table(width + borders + padding)

=

100% div's width + n * 1px > parent div's width

(for what I reckon, either you decide that the half border of collapsed borders
table bleeds and as such can overwrite the other border; then sum = 100% OK, or
you decide to enlarge/inflate table's margin to prevent overlapping, and then
the previous calculus is good)

So the bug would be solved by (I think -- yes I do... sometimes)
a) Solving the "borders of collapsed table" bug
(https://bugzilla.mozilla.org/show_bug.cgi?id=155955)
b) Solving the "rounding errors" bug (do not recall the number)

_FrnchFrgg_
Comment 35 Ronald Tilby 2006-12-08 11:18:54 PST
The testcase is now WFM, but the URL still fails using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120804 [cairo]
Comment 36 Gary Kwong [:gkw] [:nth10sd] 2008-06-05 22:25:34 PDT
Created attachment 323997 [details]
screenshot of URL link

The testcase now WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0 and the URL shows a correct half-size image.

Should this be resolved WFM? (This is the last bug blocking tracking bug 8914)
Comment 37 David Baron :dbaron: ⌚️UTC-7 2008-06-09 13:42:13 PDT
Might this have been fixed by bug 287624 or (more likely) bug 417178?
Comment 38 David Baron :dbaron: ⌚️UTC-7 2008-06-11 12:15:35 PDT
Fixed between Linux nightlies 2008-03-24-04-trunk and 2008-03-25-04-trunk, thus by bug 417178.

Note You need to log in before you can comment on or make changes to this bug.