1.4 install fails to complete with an XPCOM procedure entry error

RESOLVED DUPLICATE of bug 195600

Status

--
critical
RESOLVED DUPLICATE of bug 195600
16 years ago
14 years ago

People

(Reporter: sw-moz-bugs, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4/mozilla-win32-1.4-installer.exe

Near the end of the 1.4 install the following error box opens and the install
ends. Restarting the mozilla application generates the same error.

Mozilla.exe - Entry point Not Found

The procedure entry point ?flush@nsOutputFileStream@@UAEXZ could not be located
in the dynamic link library xpcom.dll


Reproducible: Always

Steps to Reproduce:
1.Download the 1.4 install
2.Run the installer with an admin account, using default options at each stage
3.Error occours at end of install
Re-installing a 1.3 release or the 1.3.1 after works but initialy comaplains
about missing xpcom_compat.dll. This does not seem to cause any problems though.

Actual Results:  
Mozilla fails to start.

Expected Results:  
Open the browser at the default start page.

No talkback crash was generated. I will need advice on how to provide more
useful information. The only info I have is:

Mozilla.exe - Entry point Not Found

The procedure entry point ?flush@nsOutputFileStream@@UAEXZ could not be located
in the dynamic link library xpcom.dll
(Reporter)

Comment 1

16 years ago
BTW this bug was also produced with 1.4-rc3 on the same host. The host runs
Windows XP home edition and is based on an OEM install from HP which has had all
recent security updates.

Comment 2

16 years ago
Smells like a duplicate of bug 195600...
"browser crashes on startup after install and after xpi install. Installation of
1.4 fails"

Duplicate of bug 195600 (again) ?
(Reporter)

Comment 3

16 years ago
It might well be a duplicate. I have had enigmail and calander installed before
and although the 1.3.1 install does not show either present the old xpi files
may well still be lying arround. I presume if I remove these files I should then
be able to install 1.4 sucessfuly.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 195600 ***
Severity: blocker → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.