browser crashes on startup after install and after xpi install. Installation of 1.4 fails

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: pavel1r, Assigned: ssu0262)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030301
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030301

After installation of the current nightly build (2003030108 - upgrade from 3
days old nightly) browser crashed every time on startup. After I uninstalled,
removed mozilla dir and installed it again, browser starts OK, but whenever I
install an xpi, browser crashes on first restart.

Reproducible: Always

Steps to Reproduce:
1. Install over previous nightly build
2. Install any add-on.
3.

Actual Results:  
Browser crashes on startup.

Expected Results:  
Start normally.

I tried to install calendar or enigmail, but their installation left unfinished.
When I start calendar it suggests to quit mozilla and run regxpcom. regxpcom
crashes.
(Reporter)

Comment 1

16 years ago
Sorry for misinformation, only enigmail and calendar installation causes crash
on next startup. All other xpis installed without problems.

Comment 2

16 years ago
Reporter : please write ONE report per issue. 

Your second issue is INVALID per your own comment 1.
Your first issue is INVALID because you always need to uninstall the old build
before installing a new one. Mozilla installer is just that. It's not Mozilla
UPGRADER. It's not made to be backwards compatible or handle upgrades. Please
read the installation notes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
*** Bug 195618 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 195712 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 195756 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Re: comment 2: should an RFE be added suggesting that the Moz installer detect
whether a previous installation is present and (preferably) offer to run the
uninstaller first (or at least warn), then?

Comment 7

16 years ago
*** Bug 195756 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Ray, I think Your comment #6 is a good idea. Every procedure, that ensures
mozilla to be stable, will rise the acceptance of the product! 

Comment 9

16 years ago
*** Bug 195820 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 196620 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 196669 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Bug 196620 is supposed to be a duplicate of this bug -- I did not try to install
any plugins or add ons, and did uninstall the previous nightly build before
trying to install.

Uninstalling first gets me the TalkBack agent.  This appears to have started
about 10-12 days ago.

I cannot get the nightly build installed.  Should the status of this bug stay
'resolved'?

Comment 13

16 years ago
*** Bug 196821 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 200623 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
just opened an rfe about adding a warning if destination directory is not empty.
Please see bug 200651

Comment 16

16 years ago
*** Bug 204034 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 205469 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 207133 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 208089 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 208089 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 209546 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
I'm expecting more bug reports from people experiencing this problem after
upgrading from 1.3 to 1.4, once 1.4 is released. Updating summary to avoid dupes.

Old summary: "browser crashes on startup after install and after xpi install."
Summary: browser crashes on startup after install and after xpi install → browser crashes on startup after install and after xpi install. Installation of 1.4 fails

Comment 23

16 years ago
*** Bug 210092 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
*** Bug 210091 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
*** Bug 210081 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
*** Bug 210281 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
*** Bug 210091 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
*** Bug 210312 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
*** Bug 210362 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
*** Bug 210472 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
*** Bug 210472 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
*** Bug 208322 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
*** Bug 196902 has been marked as a duplicate of this bug. ***

Comment 34

16 years ago
*** Bug 211228 has been marked as a duplicate of this bug. ***

Comment 35

16 years ago
*** Bug 211383 has been marked as a duplicate of this bug. ***

Comment 36

16 years ago
*** Bug 211214 has been marked as a duplicate of this bug. ***

Comment 37

16 years ago
*** Bug 211394 has been marked as a duplicate of this bug. ***

Comment 38

16 years ago
*** Bug 211417 has been marked as a duplicate of this bug. ***

Comment 39

16 years ago
*** Bug 211408 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
*** Bug 211458 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
*** Bug 211467 has been marked as a duplicate of this bug. ***

Comment 42

16 years ago
*** Bug 211568 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
*** Bug 211557 has been marked as a duplicate of this bug. ***

Comment 44

16 years ago
*** Bug 205277 has been marked as a duplicate of this bug. ***

Comment 45

16 years ago
Reopening to catch more dupes.
Status: RESOLVED → UNCONFIRMED
Depends on: 200651, 210731
Resolution: INVALID → ---

Comment 46

16 years ago
*** Bug 211549 has been marked as a duplicate of this bug. ***
*** Bug 211543 has been marked as a duplicate of this bug. ***

Comment 48

16 years ago
*** Bug 211723 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
I uninstalled my 1.3.x version and attempted to install 1.4.  The installation
fails with the same type of error.

Luckily I can reinstall 1.3.

Comment 50

16 years ago
The workaround for comment 49 is to remove your old installation directory after
uninstalling.  Some component that was installed in 1.3 is
not removed by uninstall and is bombing 1.4.

There seems to be a misconception in some of the comments that uninstalling
Mozilla fixes the problem.  It does not.  That's why there will be tons of
unhappy customers.  You might expect the masses to figure out that they should
uninstall, but fooling with the installation directory - I don't think so.

I'm a bit of a Mozilla evangelist and this will *not* play well among the
techno-phobic.  I am just waiting for the "1.4 is junk" reviews.
cormack.uwaterloo.ca 288>cat xxx
The workaround for comment 49 is to remove your old installation directory after
uninstalling.  Some component that was installed in 1.3 is
not removed by uninstall and is bombing 1.4.

There seems to be a misconception in some of the comments that uninstalling
Mozilla fixes the problem.  It does not.  That's why there will be tons of
unhappy customers.  You might expect the masses to figure out that they should
uninstall, but fooling with the installation directory - I don't think so.

I'm a bit of a Mozilla evangelist and this will *not* play well among the
techno-phobic.  I am just waiting for the "1.4 is junk" reviews.

Comment 51

16 years ago
*** Bug 211739 has been marked as a duplicate of this bug. ***
Confirming as the two blocking bugs are real, but does this bug really add
anything or should it simply be closed? We've also got bug 154243 hanging around
which is basically the same issue, just different entry points in different
versions.
Assignee: asa → ssu
Status: UNCONFIRMED → NEW
Component: Browser-General → Installer
Ever confirmed: true

Comment 53

16 years ago
*** Bug 211333 has been marked as a duplicate of this bug. ***
*** Bug 211935 has been marked as a duplicate of this bug. ***

Comment 55

16 years ago
*** Bug 211946 has been marked as a duplicate of this bug. ***

Comment 56

16 years ago
*** Bug 211937 has been marked as a duplicate of this bug. ***

Comment 57

16 years ago
I've reproduced this problem with 1.4, and resolved it by simply installing 1.4
into a new directory. In this case, leaving the v1.3 installed (in a separate
directory) does NOT cause v1.4 to crash.

Comment 58

16 years ago
*** Bug 212043 has been marked as a duplicate of this bug. ***

Comment 59

16 years ago
Moz 1.4 worked on this pc (o/s Win98) sice the initial release of 1.4, but as of
yesterday I get crashes on trying to startup. I used program manager to
uninstall, restarted the pc, installed a new 1.4 install (not a nightly build!)
freshly downloaded from Moz.org and still it crashes.
a) Why has it stopped working, and
b) Why hasn't a re-install cured the problem?
The error message is reproduced below. Can someone assist please? Thanks.
Colin

Error Report:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0187:610f0769.
Registers:
EAX=4d7a6f6d CS=0187 EIP=610f0769 EFLGS=00010202
EBX=00000000 SS=018f ESP=0065f630 EBP=0065f654
ECX=00786184 DS=018f ESI=610f3b40 FS=48af
EDX=317b0fff ES=018f EDI=0078c860 GS=0000
Bytes at CS:EIP:
8b 00 3b c3 74 21 33 f6 80 38 00 74 1a 8b 4d 08 
Stack dump:
00000000 80000000 00787c00 610f3b40 00786160 00000000 00000001 00786168 00000000
0065faa8 610d7a7e 00787c04 00786160 0078cbc0 0078fec0 610f6084 

Comment 60

16 years ago
The problem with uninstalling first is that I un-installed Mozilla 1.3.1
(Stable), rebooted the machine and installed Mozilla 1.4 (Stable) and it didn't
work. I had to manually delete the old directory (the un-installer didn't do it)
and then install Mozilla 1.4. The installer and/or uninstaller should delete the
dir before installing 1.4.

Comment 61

16 years ago
I make my living as a software dev mgr.  This is the first time I have had to
wade through bug reports on any Moz blessed release.  I followed the included
suggestion and was able to install the 1.4 by either clearing the old 1.3 folder
or simply installing to a new folder.  I have carefully read through the install
instructions and it does mention anything about having to uninstall the previous
version of Moz.  I certainly have never had to do so in the past and I have
upgraded a half dozen times over the past 2 years on 20+ W2K desktops.  

This critical bug does need to be addressed.  

spf@obx.com

Comment 62

16 years ago
*** Bug 212288 has been marked as a duplicate of this bug. ***

Comment 63

16 years ago
*** Bug 212449 has been marked as a duplicate of this bug. ***

Comment 64

16 years ago
*** Bug 212463 has been marked as a duplicate of this bug. ***

Comment 65

16 years ago
*** Bug 212495 has been marked as a duplicate of this bug. ***

Comment 66

16 years ago
Also true for NT 4.0, SP-6.  Identical problem occurs if Mozilla 1.4 is
installed in any drive other than the <system> drive.  In my case, the <system>
drive is C:\, but in all previous Mozilla releases, I had successfully installed
Mozilla on my E:\ drive.  With Mozilla 1.4 [Mozilla 1.4 Mozilla/5.0 (Windows; U;
WinNT4.0; en-US; rv:1.4) Gecko/20030624], installing to the E:\ drive produced
an immediate crash when the browser attempted to start at the end of the
installation.  Attached is the "Dr. Watson" dialogue screen issued with the
failure, and the portion of the system dump related to the crash that was
produced at the same time.

Attempting to execute Mozilla (any module) after restarting the computer
produced identical results.  Installation on the <system> (i.e. C:\) drive
enabled the application to install and execute successfully.

Comment 67

16 years ago
Created attachment 127671 [details]
Dr. Watson Diualogue Screen Following Moz 1.4 Installation on other than <system> drive

Attachment 1 [details] [diff] of two.  Related System Dump to follow.

Comment 68

16 years ago
Created attachment 127672 [details]
Dr Watson log from Moz 1.4 Crash after E:\ drive Installation

Drwtsn32.log portion from Mozilla crash after installation on OTHER than
<system> drive (i.e. E:\).  Attachment 2 [details] [diff] of 2

Comment 69

16 years ago
*** Bug 211694 has been marked as a duplicate of this bug. ***

Comment 70

16 years ago
Uninstalling the previous version (at least for me uninstalling 1.3.1) from the
Add/Remove Programs Control Panel does not resolve this despite some comments
here that the issue can be resolved by "uninstalling" before installing 1.4.  I
was able to resolve the issue by manually deleting the "components" subdirectory
that remained after an uninstall.  I'm not sure if doing that breaks anything
else, but my user and e-mail configuration remained intact as well as my plugins.

Comment 71

16 years ago
Please read all comments before posting. Comment 70 is basically the same as
comment 50. 

So once more, the explanation [and solution]:

Typically you can install Mozilla on top of older version. Sometimes however,
new features are implemented that break backwards compatibility with some 3rd
party tools. In that case you have to first uninstall Mozilla.

But when you installed [3r party] add-ons like spell check, enigmail, Calendar
etc. they will (a) not be uninstalled and (b) not be compatible with your new
Mozilla. [Please note that this behavior is by design because no program should
unistall items that it didn't install].

These add-ons do not have an uninstaller and, in case the new Moz is not
backwards compatible. In short: their presence brings down Moz. To uninstall
these add-ons you have to manually delete them [clear out the Moz folder].

So the steps to get 1.4 working are:
1) download 1.4
2) read the README!!!! 
http://www.mozilla.org/releases/mozilla1.4/README.html says "If you are
experiencing crashes on startup in xpcom.dll it is very likely that there is an
incompatibility with some third-party extension. To work around this problem,
uninstall your previous version of Mozilla, and completely delete the Mozilla
install directory before performing the new install. You will not lose your
profile data (such as bookmarks, preferences and cookies) but any third party
extensions and plugins may be lost."
3) install 1.4
4) reinstall your favorite 3rd party tools after confirming that they are
compatible with 1.4

The problem and solution for this bug are extensively described and the trunk
already contains a patch [see bug 210731] to avoid this in the problem in future
builds.

Therefore please refrain from posting further screenshots & solutions.

I hope this helps.

Comment 72

16 years ago
I think this might be an apropos time to bring up my bug 195818, where I ask
that the Moz community stop dancing around this issue by making the installer
uninstall previous versions if upgrades aren't supported. 
Depends on: 195818

Updated

16 years ago
No longer depends on: 195818

Comment 73

16 years ago
*** Bug 212780 has been marked as a duplicate of this bug. ***

Comment 74

16 years ago
Just wanted to add another voice to the comment list. I'm a fairly seasoned
software developer and this bug has killed a few hours of my time. I installed
1.4 over 1.3 (just like I've done with other versions countless times) and it
crashed, on both Win2k and WinXP systems.  I supposed I should have read the
README, but the thought never occurred to me that this type of behavior would
have been dismissed as "user-error" or RTFM stuff.  As Mozdev stuff starts to
become more popular, this problem ought to be fixed or be more explicit. 
Warnings should be displayed when you download such a component that users will
need to manually uninstall them when upgrade time comes.

Then again, perhaps countless stable and flawless Mozilla releases have spoiled
me into thinking that things will "just work" without reading the docs.

Finally, I love Mozilla.  Thanks for the world's best browser, installer
problems aside.

Comment 75

16 years ago
Created attachment 128498 [details]
screenshot of the debugger information

using this it is possible to find a place where the bug occures

Comment 76

15 years ago
Win2000 same bug many others here are reporting. Don't understand the 
statement made in Additional Comment #70  "To work around this problem,
uninstall your previous version of Mozilla, and completely delete the Mozilla
install directory before performing the new install." What exactly is the "install 
directory"?

Comment 77

15 years ago
*** Bug 215241 has been marked as a duplicate of this bug. ***

Comment 78

15 years ago
Re: comment 72
Did you both reading the comment right above yours?  The one that has cites the
bug that already does what you're bitching about the "Moz community" for not doing?

Comment 79

15 years ago
*** Bug 215309 has been marked as a duplicate of this bug. ***

Comment 80

15 years ago
This just started happening to me with version 1.4.2. I Moz also crashes at
launch with 1.5 alpha (don't know the exact version, but I downloaded it on
2003-08-07).
Win2k SP3 with RPC patch.

I deleted the mozilla directory and preferences, still happens. I do have
Firebird 0.6.1 and Thunderbird 0.1, but I don't think that matters.

Comment 81

15 years ago
*** Bug 215561 has been marked as a duplicate of this bug. ***

Comment 82

15 years ago
I have to run multiple versions of Mozilla, for compatibility checking with
multiple sites. I have always installed Mozilla to a separate directory (as
specified in the instructions) and have never attempted to "upgrade" or
overwrite a previous install. I only ever run full versions (no betas, no
alphas, etc).

I have installed 1.4 and appear to be having this problem, but there does not
seem to be a workaround listed in this bug report. Aside from the fact that I do
actually need different versions installed at once, if I uninstall 1.3 and 1.4
continues not to work, then I'll be left with nothing. How then am I going to
report a bug? Or even get an updated Mozilla?

Additional information (which may constitute a different bug?) is that on a
hunch, I tried running 1.4 with "-profilemanager". If I do this, it starts OK,
and lets me create a new profile. Unfortunately, after I close 1.4 down, that
new profile does not show up in profile manager the next time I run it (although
the directory has been created).

IMHO it would appear that 1.4 should be taken offline, since it is not
stable/safe enough for general usage. If you have a critical bug like this that
is preventing ordinary users from using mozilla - and we are talking about
complete loss of email, web, etc here - then it's inexcusable to encourage
people to replace a working version with a broken version (even if for many of
those users it is their own "fault" for not-quite following the instructions).

Comment 83

15 years ago
P.S. I have also tried to delete the contents of my plugins directory, but that
has had no effect. It only contained the flash-player.

Comment 84

15 years ago
I find it hard to believe that this is still being blamed on the user. Obviously
changing the installer is only a workaround and the cause of the crash is still
present in the code. Regardless of the steps you can take to avoid the problem
there is an underlying CRITICAL bug which causes the program to crash hard.
Changing the installer only fixes the symptoms.

If there is a problem with xpcom.dll and 3rd party applications that causes
total meltdown then the problem lies in xpcom. Wouldn't it make sense to get to
the bottom of it and make it more robust ?
*** Bug 207708 has been marked as a duplicate of this bug. ***

Comment 86

15 years ago
OK, now I got this too.

OS: Win98 SE
Build used: Nightly (2003091309) + SVG + GDI + MathML

No way to start up Mozilla *SIGH* because it *INSTANTLY* crashes.

Can nobody try to fix this eventually?

Comment 87

15 years ago
Some add-on to my previous post:

This has *NOTHING* to do with the installer!!

Definitely not. I'm now aware that I actually used the zipped (!) nightly build 
for testing and just launched the mozilla.exe file manually. Same thing as 
reported above.

Ah ... mozilla.exe -profilemanager fired up the printer (!) dialog on my box. 
ROTFL.
Getting better and better, huh. :-P

-ae-

Comment 88

15 years ago
*** Bug 210382 has been marked as a duplicate of this bug. ***

Updated

15 years ago
QA Contact: asa

Comment 89

15 years ago
*** Bug 207619 has been marked as a duplicate of this bug. ***

Comment 90

15 years ago
*** Bug 204052 has been marked as a duplicate of this bug. ***

Comment 91

15 years ago
*** Bug 210476 has been marked as a duplicate of this bug. ***

Comment 92

15 years ago
*** Bug 211042 has been marked as a duplicate of this bug. ***
*** Bug 210937 has been marked as a duplicate of this bug. ***
*** Bug 210849 has been marked as a duplicate of this bug. ***

Comment 95

15 years ago
Great work guys!!

Just installed 1.6a on my system (latest nightly due to the https bug) and it 
works fine! No instant crashes anymore!

So a smashing "all-clear" from my side.

-AE-
*** Bug 212254 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: browser crashes on startup after install and after xpi install. Installation of 1.4 fails → browser crashes on startup after install

Comment 97

15 years ago
Simon 'sipaq' Paquet: why did you change the summary of this bug?

The XPI part in the summary is a fundamental part in causing the crashes in case
a non-forwards compatible XPI is used. These words were included to catch more
dupes. Also, when changing the summary, please add a comment that you did so AND
list the previous summary.

By removing search terms you only reduce the chance of trapping bugs [for
instance "installation" in combination with "fail" won't find this bug anymore
after your summary change.

Changing the summary back:
OLD summary: "browser crashes on startup after install"

[PS: Sorry for spam]
Summary: browser crashes on startup after install → browser crashes on startup after install and after xpi install. Installation of 1.4 fails

Comment 98

15 years ago
*** Bug 226935 has been marked as a duplicate of this bug. ***

Updated

15 years ago
No longer depends on: 200651, 210731

Comment 99

15 years ago
mozilla-win32-1.5-installer.exe also does this because the installer deletes the
unauthorised extensions, but does not bother to clean
"C:\Documents and Settings\*user_name*\Application
Data\Mozilla\Profiles\default\xftvfsrg.slt\chrome\chrome.rdf"
(yes I saw missing components referenced in there), 
"C:\Program Files\mozilla.org\mozilla\chrome\chrome.rdf"
may be affected too, the result is a permanent banner when mozilla 'starts'!

Suggestion
----------
The XPI installer retains copies of all installed .xpi's for reference.
The Installer (optionally) checks if resident extensions support the browser
being installed and allows compatible ones to be picked and re-installed, after
all extensions have been _fully_ uninstalled!  Version checks could be done from
the xpi contents or online.


Updated

15 years ago
Blocks: 163993

Comment 100

15 years ago
*** Bug 230638 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: crash

Comment 101

15 years ago
Can anyone give specific steps to reproduce this problem with 1.7 beta or newer?
I am unable to reproduce with the windows 1.7 beta installer or any of about 15
of the most popular Mozilla extensions at mozdev.org. Please reopen if you can
give specific reproducible steps that crash a current Mozilla build. Thanks.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 102

15 years ago
*** Bug 209896 has been marked as a duplicate of this bug. ***

Comment 103

15 years ago
*** Bug 210832 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

14 years ago
No longer blocks: 163993

Comment 104

13 years ago
Mozilla 1.7.12 would not start after reinstalling Win 98. Would not start after program reinstall either. Uninstalling, deleting the GRE folder in c:\program files\commonfiles\mozilla.org and reinstalling fixed this problem

Comment 105

13 years ago
After overinstall to version 1.5 error in xpi ocurre. Help delete of 1.5 and re-install 1.6.1beta again

Comment 106

11 years ago
I don't see any recent bugs on this, so....
Firefox did some kind of upgrade this morning. Now it crashes on startup. tried to unstall (v 2.0.0.5) and install the older 1.0 with the same result. I've been installing Firefox on all my customers computers as an alternate browser and they all love it. PLease fix this bug. I can't live without my Firefox. Thanks.

Comment 107

11 years ago
Huh?

Comment 108

10 years ago
if i clkik on it it wont go on i have widos 2000 plsel tell me  on my hotmail

Comment 109

9 years ago
Bug comments are a mess, versions are mixed up -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.