All users were logged out of Bugzilla on October 13th, 2018

Mozilla version 1.4 does not accept proxy configuration!

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Mozilla version 1.4 does not accept manuall proxy configuration! I installed
(now) ver. 1.4 over the ver. 1.3, (uninstall and then install J) and this new
ver. 1.4 does direct connection to the internet, even though I have not direct
connection, but I do connection via proxy server (Settings are good, I have
manual proxy configuration, but it does not work).

Reproducible: Always

Steps to Reproduce:
1. Uninstalling Mozilla 1.3
2. Installing Mozilla 1.4
3. Mozilla does not accept manuall proxy configuration.

Actual Results:  
Mozilla does connection via direct connection to the Internet, and I have not
direct connection to the Internet

Expected Results:  
Mozilla should accept configuratio option.

-
(Reporter)

Comment 1

16 years ago
After reinstalling the older version (1.3) over the new version (1.4) – it
(Mozilla ver. 1.3) works correctly. 
Summary: Mozilla version 1.4 does not accept proxy configuration! → Mozilla version 1.4 does not accept proxy configuration!
(Reporter)

Comment 2

15 years ago
Is there somebody, Or Mozilla Projekt is finished!(?)

Comment 3

15 years ago
Created attachment 129247 [details]
HTTP Debugging log file

This is a HTTP debug log, as proposed in
http://www.mozilla.org/projects/netlib/http/http-debugging.html
I´ve used Mozilla Firebird 0.6 instead of Mozilla 1.4, the error seems to be
the same. Proxy server is squid/2.5.STABLE2 (acording to the log file)
The log file contains 5 http request, the first one with no autentication, the
following 2 - i suppose - with wrong autorization user/pass (when mozilla
promptly showed proxy password dialog again), and the final 2 with the correct
user/pass. After putting the right user/pass Mozilla stopped showing the dialog
but i cound not access the initial page (http://www.mozilla.org/start/)

Comment 4

15 years ago
*** Bug 224516 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Reporter, we can't do anything without more information, like the log provided
by Telmo. What's so special about your proxy-server ? Does it use authentication ? 

PS : manual proxy-authentication works fine for me.
(Reporter)

Comment 6

15 years ago
... and what do you need from me? I am not server specialist.

Remark:
... manual proxy configuration does not work still.
but (I do not why) Automatic proxy configuration via URL work correct.

Please, send me "manual" or "guide" - What should I do to help You (us)?

Comment 7

15 years ago
You can generate a log file with the instructions at
http://www.mozilla.org/projects/netlib/http/http-debugging.html , and attach it
to this bug.

Since you mention that a PAC file works (auto proxy configuration), please
provide this logging too (and the PAC file), then we can compare. I think you
made a simple configuration error (different hostname or port for example).
There's no real difference between auto and manual configuration, aside from
possible syntax errors in the PAC file.
(Reporter)

Comment 8

15 years ago
Dear Mr. Jo Hermans, I sent you e-mail with three files.
2xLogfiles and 1xPAC file.

I hope it is sufficient information.

Comment 9

15 years ago
Please don't mail any files, I'm not using a real email-address here (if I
didn't came here by accident, I would have never seen it). Attach the files to
this bug instead.

Comment 10

15 years ago
one more thing: this problem doesn´t happen on Linux
and i´ve tested firebird 0.7 on windows and it has the same problem
-> wfm

Delete c:\program Files\Mozilla.org and c:\Program Files\common files\Mozilla
and reinstall Mozilla if you still see the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.