Closed Bug 212714 Opened 17 years ago Closed 16 years ago

aol.com - HTTP Header includes two entries following CHARSET

Categories

(Tech Evangelism Graveyard :: English US, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rontilby, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030711
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030711

The web server at http://members.aol.com is serving:
Content-Type: text/html; charset=Shift_JIS,ISO-8859-1
in the HTTP header.  As near as I can tell, 'charset' should only ONE charset token.
This is confusing mozilla when rendering otherwise W3C compliant pages.
For example: http://members.aol.com/rontilby/

Reproducible: Always

Steps to Reproduce:
1.enter: http://members.aol.com/rontilby  in the mozilla address bar
2.The page won't display in the browser.
3.

Actual Results:  
The page won't display, or (in my specific case) it is downloaded and then
displayed in the AOL browser.

Expected Results:  
page should display normally.

This problem also causes the W3C HTML Validator to reject pages fed from
members.aol.com
I'm not sure whether should (yet) be confirmed as an Tech Evang bug when it's an
open browser bug at present.  See bug 210229.
Depends on: 210229
Apparently Mozilla was formerly fault-tolerant of this spec. violation, and has
regressed.  If the HTTP Spec. allows for only one character set to be specified
in the Content-Type header, then AOL should be evangelized whether or not
Mozilla is fault-tolerant regarding this particular issue.  This problem with
AOL's servers is causing the w3c's html validator to fail otherwise standards
compliant pages.
Those are both AOL sites. Lets dupe and evange them if they decide it is a
bigger issue although I don't know how much luck we will have with AOL.

*** This bug has been marked as a duplicate of 210229 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
No longer depends on: 210229
Resolution: --- → DUPLICATE
The problem in Mozilla has been fixed, but AOL still needs to be evangelized 
because they're serving invalid HTTP Headers, and it makes Mozilla think that 
all pages from members.aol.com are using the 'Shift JIS' character set.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Ron, please complain to AOL as a member since you will have more effect than I will.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: HTTP Header includes two entries following CHARSET → aol.com - HTTP Header includes two entries following CHARSET
*** Bug 224483 has been marked as a duplicate of this bug. ***
--17:01:00--  http://members.aol.com/itsthelaw7/itsthelaw.htm
           => `itsthelaw.htm.2'
Resolving members.aol.com... done.
Connecting to members.aol.com[205.188.226.184]:80... connected.
HTTP request sent, awaiting response...
 1 HTTP/1.1 200 OK
 2 Date: Tue, 11 Nov 2003 16:00:48 GMT
 3 Server: Apache/1.3.26 (Unix) Resin/2.0.5
 4 Connection: close
 5 Content-Type: text/html

They removed the charset in the server header -> fixed
Status: NEW → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → FIXED
Depends on: 173931
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.