Last Comment Bug 212798 - Make existing linux flashplayer.xpt (for scriptability) work with gcc 3.2 builds
: Make existing linux flashplayer.xpt (for scriptability) work with gcc 3.2 builds
Status: RESOLVED FIXED
qawanted
: regression, relnote
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Peter Lubczynski
: bmartin
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://devedge.netscape.com/viewsourc...
: 221294 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-15 14:33 PDT by Olivier Cahagne
Modified: 2004-06-12 15:07 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Olivier Cahagne 2003-07-15 14:33:42 PDT
build ID: 2003071508 on Linux + Flash 6.0r79 and flashplayer.xpt.

Scriptability doesn't work anymore since Mozilla.org switched to GCC 3.2.3, as
mentioned in the release notes:
http://www.mozilla.org/releases/mozilla1.4/README.html#new-issues

about:buildconfig reports:
--disable-tests --enable-extensions=default,irc --without-system-nspr
--without-system-jpeg --without-system-zlib --without-system-png
--without-system-mng --disable-debug --enable-optimize --disable-elf-dynstr-gc
--enable-optimize=-O2 --enable-crypto

I launched a debug build to see any error output but there's no debug info on
why scriptability doesn't work anymore:
 - hack not working well, regression from bug 154206 ?
 - flashplayer.xpt needs to be updated ?

I deleted xpti.dat and a debug build didn't say whether or not flashplayer.xpt
was valid.

I couldn't find any bug report matching the release notes, so I'm opening one,
hoping this can be looked at.
This started generated some bug reports: bug , bug .
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2003-07-15 15:20:56 PDT
The basic issue, as I understand it, is that he flash xpt expects GCC 2.9x name
mangling, while GCC 3.x does different name mangling.  The only way to fix this
is to regenerate the xpt; the only people who can do that are Macromedia.
Comment 2 Olivier Cahagne 2003-07-15 15:56:36 PDT
is it ok to CC emillard (?) or kiwi at macromedia.com ? I sent an e-mail to
flashplayerunix@macromedia.com.
Comment 3 Olivier Cahagne 2003-07-16 12:41:54 PDT
CC'ing some Macromedia people after talking to dmose.
Apologies if you're not the most appropriate people to CC on this as it's
Linux-specific, I also saw two other people in bugzilla: msintov@macromedia.com
and dshultz@macromedia.com.
Comment 4 Dan Mosedale (:dmose) 2003-07-16 12:42:51 PDT
I suspect that this is going to require not just regeneration of the XPTs, but
also a recompile of the flash plugin with gcc 3.2 or later.
Comment 5 Peter Lubczynski 2003-07-22 11:57:04 PDT
Yeah, the plugin needs to be recompiled with the same compiler as the browser
and be sure to use an updated npapi.h. This is a similar issue as on OSX, see:
http://www.mozilla.org/projects/plugins/plugin_scripting_ABI_technote.html

Comment 6 Bob Clary [:bc:] 2003-10-06 17:38:03 PDT
*** Bug 221294 has been marked as a duplicate of this bug. ***
Comment 7 JHB 2003-11-04 02:32:08 PST
I met similar problems with flash player after upgrading gcc packages recently.
I can fix this problem after installation of compat-libstdc++ package again.

I suspect up2date removed installed compat-libstdc++ package while upgrading new
gcc packages because of I didn't install full of these packages(compat-*;
actually I don't need other packages except compat-libstdc++).

If you are using Redhat Linux and your Mozilla browsers(I tested with Mozilla
and Firebird also) fail to display flash movies even you installed proper
plug-in, I recommand you to check that your system has compat-stdc++ package(s)
properly.

Honestly I can not sure this bug is related exactly with my case but it much
help to fix my problem and i hope this message can help somebody who have
similar cases with me.

Thanks.
Comment 8 Olivier Cahagne 2004-03-20 03:37:03 PST
Fixed with recent Flash 6.0r81.

This is worth being mentioned in upcoming Mozilla 1.7 release notes:
http://www.mozilla.org/releases/mozilla1.7b/known-issues.html#plugins
[...]
If you're using the Linux GCC 3.2 binaries compiled by mozilla.org then
JavaScript access to Flash will not work.
[...]
Comment 9 Daniel Wang 2004-06-12 13:41:37 PDT
somebody please comment on Olivier's last comment
Comment 10 Olivier Cahagne 2004-06-12 15:07:21 PDT
Daniel, I opened bug 238325 about this.

Note You need to log in before you can comment on or make changes to this bug.