Text outside textfield when toggling display of kids of display:table-cell fieldset

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Joseph A Borg, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030716
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030716

I set up a form with fieldsets and inputs in divs. If I change the display style
property to none and back to block of the divs, the page renders correctly, but
trying to enter data, gets rendered half way up the field's baseline

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
A URL or a minimal testcase illustrating the problem would be helpful.

Also, the summary implies you're changing the fieldset to block/none/block while
the description reads (to me) like you're doing it to div's within the fieldset.
 Which?  (Another reason that a testcase helps.)
(Reporter)

Comment 2

15 years ago
Created attachment 127935 [details]
part of a form before collapsing

part of the form, some text has been entered in two fields for clarification in
further screen shots
(Reporter)

Comment 3

15 years ago
Created attachment 127936 [details]
part of a form collapsed/minimised

the fieldset address has been 'collapsed'. Address is the fieldset legend
(Reporter)

Comment 4

15 years ago
Created attachment 127937 [details]
the same fieldset expanded/maximised

the fieldset 'address' has been expanded and new text entered in fields.
Joseph, the screenshots don't help us get a handle on what's going on.  The url
of that site would be most helpful; alternately, save it as "Web Page, Complete"
and attach to this bug, please.
Created attachment 127958 [details]
Testcase based on what Joseph mailed me

_Please_ attach files to the bug like we asked instead of mailing them to
people directly!
Attachment #127935 - Attachment is obsolete: true
Attachment #127936 - Attachment is obsolete: true
Attachment #127937 - Attachment is obsolete: true
The display:table-cell on the fieldset itself is key here.

Replacing the fieldset and legend with a pair of <div>s makes the bug go away,
even if I keep the display:table-cell.

Replacing just the <legend> with a <div> also makes the bug go away.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Summary: changing tha display property from block to none and back to block of fieldset, the text entered is not aligned to the field rendered → Text outside textfield when toggling display of kids of display:table-cell fieldset

Comment 8

14 years ago
The testcase works fine except that the <fieldset> is not repainted after the
<legend> display has been set to 'none' (just covering the window results
in the desired rendering). (I will try to fix the repaint issue in bug 276104).

Boris, I'm not sure I understood the testcase though - did I miss something?
Depends on: 276104
Keywords: testcase
Created attachment 169992 [details]
The testcase I think I meant

In 1.8a5 this testcase works, but I'll recheck in an older build when I get
home....
Created attachment 170206 [details]
Real testcase

So the old testcase used to work until bug 238989 got fixed back in April. 
With that fix, the DOM changed to include textnodes as kids of the fieldset. 
This testcase works with both the old and new DOM.
Attachment #127958 - Attachment is obsolete: true
Attachment #169992 - Attachment is obsolete: true
Created attachment 170207 [details]
Real real testcase

This makes sure we get the old DOM and reproduces the bug even in old builds
with bug 238989 fixed.
Looks like behavior on that last testcase was fixed sometime between
2004-07-17-08 and 2004-07-18-07; probably in bug 251501.. Marking worksforme,
but please reopen if there is still an issue in a current trunk build.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.