All users were logged out of Bugzilla on October 13th, 2018

Microsoft Word attchments will not open on the recipient's end

VERIFIED DUPLICATE of bug 168098

Status

--
critical
VERIFIED DUPLICATE of bug 168098
16 years ago
10 years ago

People

(Reporter: shannon, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425

When sending a Word document from one specific computer the recipient cannot
open it on their end. A notice comes up that says
"The document name or path is not valid. Try these suggestions
* Check the file permissions for the document or drive
* Use the File OPen dialog box to locate the document."
Now when we check the document on other computers and send it it works fine. It
is just this one computer that isnt sending it correctly. Excel files come
through fine. I tried to uninstall Mozilla and then put it back on but that
didnt seem to work. I can open the document fine on this specific computer but
it just wont open once it is sent as an email attachment.

Thank you for your help
Shannon K McMillen

Reproducible: Always

Steps to Reproduce:
1.Attch the Word file to the email
2. Send email
3.Try to open it on recipient's end and it freezes and then you get the error
message



Expected Results:  
Sent the attachment correctly and hopefully once you saved it to your computer
from the email attachement it would open correctly
Can you attach the attachment header from the message source ?
You may also try a new profile on the system (run "mozilla -profilemanager" and
create an additional test profile)
*** Bug 215634 has been marked as a duplicate of this bug. ***
via mail :

Content-Type: *.msword;
 name="Wyoming Content Standard - Grade 4.doc"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline;
 filename="Wyoming Content Standard - Grade 4.doc"

----------------------------------------------------------------------------

A workaround would be to remove the wrong mime-types from the helper apps and if
no entry is there, override the wrong windows registry settings with a correct
entry in the helper apps.

Mozilla should not use qouted-printable for non text/* mime-types because this
leads to dataloss.

from bz on IRC :
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgAttachmentHandler.cpp#264
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgCompUtils.cpp#1431
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
(Assignee)

Comment 4

15 years ago
taking, will probably dup against 168098
Assignee: sspitzer → bienvenu
(Assignee)

Comment 5

15 years ago
duping against bug 168098 - my hope is that I fixed this last weekend so that a
build from this week should work. 

*** This bug has been marked as a duplicate of 168098 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.