Please remove 'Cookies are delicious delicacies' from Options->Privacy->Cookies

VERIFIED FIXED in Firefox1.0beta

Status

()

Firefox
Preferences
P2
trivial
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: Thomas Covello, Assigned: mconnor)

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0beta
fixed-aviary1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have patch])

Attachments

(3 attachments, 6 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030714 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030714 Mozilla Firebird/0.6

The inaccurate description 'Cookies are delicious delicacies' appears under
Tools-Options-Privacy-Cookies.

Reproducible: Always

Steps to Reproduce:
1. Tools->Options
2. Click Privacy. Expand 'Cookies'.

Actual Results:  
'Cookies are delicious delicacies'

Expected Results:  
'Cookies are files that some websites use to keep track of their users. They can
only be accessed by the originating server, and are usually not harmless. If you
so choose, you can delete them in this section.'
(Assignee)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
I don't know if "...are usually *not* harmless..." [emphasis mine] is really
accurate or necessary in a new description.
(Assignee)

Comment 2

14 years ago
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 3

14 years ago
Some additional thoughts... with all the scare on cookies going on in the media,
some people believe cookies are complete privacy-destroying tools that store
everything from your credit-card number to your pet's names.

Rather than the paragraph below, I'd put an even shorter line (though it should
still be more informative than the 'delicacies' thing) along with a clickable
hyperlink or thingymabob to a longer explanation). This can be an excellent
opportunity to set the record straight about what cookies are and aren't...

E.g.
- Subtly emphasise the fact that a cookie stores information on your computer
and cannot access your private life unless you type it in
- Suggest blocking 3rd party cookies ('for the originating website only')
- Use a softer wording instead of 'keep track of users'
- Discuss uses of cookies rather than technicalities: instead of 'a cookie can
keep data for your next visit' say 'a cookie can remember your password so you
don't have to enter it again'.

I also believe the "usually not harmless" wording in the previous comment was a
tautology and should've been "usually harmless" or "usually not harmful" ;).

Comment 4

14 years ago
"Web pages can store bits of text called cookies on your computer so they can
recognize you during future visits."

----
Other privacy options are only one sentence long, and they don't attempt to
explain the implications of the options; I think it makes sense to try to hold
to that standard.  It simplifies the interface for newbies.

As for steven's comments, I think this addresses them as best as possible:

1. It puts greater emphasis on the fact that web pages provide data rather than
retrieve it.
2. I don't believe it's possible to suggest blocking 3rd party cookies given the
writing style of the dialog.
3. The wording matches the other options in the dialog.  It's easy to understand
(at least conceptually) for newbies.
4. It provides the most fundamental use of cookies, while de-emphasizing the
technical details of how they work.

It's also objective as to whether cookies are "good" or not.  The whole point of
a preference is letting the user decide :)
(Reporter)

Comment 5

14 years ago
Sorry folks, 'usually not harmless' was a typo. I wanted to convey 'usually
harmless', but anyway I agree with Steven and jbarros that opinions are not of
the sort to put in the options dialog. I've been away for the last week, so I
couldn't get back to you all. As for jbarros's description, I think that 'bits
of text' sounds a bit unprofessional, but otherwise I'd say it's pretty good.

PS - I've found a good resource for the hyperlink: http://www.cookiecentral.com/faq/

Updated

14 years ago
URL: N/A

Comment 6

14 years ago
Created attachment 136539 [details] [diff] [review]
Patch to use a slightly modified version of Jesse Barros description

This is my first time dealing with diff files and such, so I hope I did
everythign correctly.

Updated

14 years ago
Attachment #136539 - Attachment is obsolete: true

Updated

14 years ago
Attachment #136539 - Attachment is obsolete: false
Attachment #136539 - Flags: review?(blake)
Ben M.:

+<!ENTITY cookieExplanation.label           "Web pages sometimes store bits of
text called cookies on your computer so they can
+recognize you during future visits.">

I don't really like that description. It doesn't even mention that it can also
store information, just says it can recognize you. Why don't we use an abridged
version of what's on the Cookies FAQ?

"A cookie is a text-only string that gets entered into the memory of your
browser. It can be used to identify you or store information useful for future
visits."


P.S. I thought that description of cookies being delicious was, but when I saw
it I agreed it was inappropriate and that's why I searched for this bug.
Oh, and btw, please provide a link to some webpage that talks about cookies
within the description.
Comment on attachment 136539 [details] [diff] [review]
Patch to use a slightly modified version of Jesse Barros description

Sorry, I overwrote your changes accidentally with the collision (I didn't think
that it would because I hadn't altered them). I'll apply them for you.
Attachment #136539 - Attachment is obsolete: true
Attachment #136539 - Flags: review?(blake)
(Assignee)

Comment 10

14 years ago
if we're going to link somewhere from a description, it should be Help

Comment 11

14 years ago
per comment 7:

I think "text-only string" is way too technical a language to use here
[especially for novices and international users that use the English version]

Idem for "memory of your browser". Plus, is that statement factually correct in
the first place? Can't cookies be stored on the computer's hard drive as well?
(Assignee)

Comment 12

14 years ago
Do we really need to assume that people don't know what cookies are anymore? 
Seamonkey's blurb is gone now...

Comment 13

14 years ago
How about something using the phrase "session-tracking information" or something
like that. still a bit technical, but if they are changing the cookie prefs
anyway they should (probably, hopefully) have some clue about what that means.
in any event, I agree the current "delicacies" phrase is not only inaccurate, it
looks unprofessional. even if a new phrase isn't decided on it should be removed
ASAP.

Updated

14 years ago
Flags: blocking1.0?
Flags: blocking1.0? → blocking1.0+

Comment 14

13 years ago
Taking bug.
Assignee: firefox → aebrahim

Updated

13 years ago
Status: NEW → ASSIGNED
Hardware: PC → All
Target Milestone: --- → Firefox0.9

Comment 15

13 years ago
Created attachment 149557 [details] [diff] [review]
Replace delicious delicacies description with something better

Replace old description with:

"Cookies are stored on your computer by websites in order to personalize your
browsing experience."

I wrote this description with the intent of being descriptive, while not
implying that cookies are either good or bad.

Updated

13 years ago
Attachment #149557 - Flags: review?(mconnor)

Comment 16

13 years ago
Created attachment 149559 [details] [diff] [review]
Better replacement description

"Cookies are pieces of information stored on your computer by web sites in
order to personalize your browsing experience."
Attachment #149557 - Attachment is obsolete: true

Updated

13 years ago
Attachment #149557 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #149559 - Flags: review?(mconnor)

Comment 17

13 years ago
I like the Yahoo! explanation on
http://privacy.yahoo.com/privacy/us/cookies/details.html
"A cookie is a small amount of data, which often includes an anonymous unique
identifier, that is sent to your browser from a web site's computers and stored
on your computer's hard drive."

Comment 18

13 years ago
Requesting blocking0.9 since there is a patch ready for this and this is
somewhat high visibility.
Flags: blocking0.9?

Comment 19

13 years ago
I just saw this one and am voting since it is very unprofessional looking.
Flags: blocking0.9? → blocking0.9-

Updated

13 years ago
Target Milestone: Firefox0.9 → Firefox1.0beta
Priority: -- → P2

Updated

13 years ago
Attachment #149559 - Flags: review?(mconnor) → review?(bugs)
(Reporter)

Updated

13 years ago
Blocks: 214267
Flags: blocking-aviary1.0RC1+

Updated

13 years ago
Whiteboard: Patch ready, needs review/checkin.

Updated

13 years ago
Attachment #149559 - Flags: review?(bugs)

Comment 20

13 years ago
Created attachment 152371 [details] [diff] [review]
Update for bitrot
Attachment #149559 - Attachment is obsolete: true

Updated

13 years ago
Attachment #152371 - Flags: review?(mconnor)

Updated

13 years ago
No longer blocks: 214267

Updated

13 years ago
Blocks: 214267

Comment 21

13 years ago
This thing is a year old. Can't somebody just fix it for Pete's sake? I don't
see the huge challenge in this one.

Comment 22

13 years ago
(In reply to comment #21)
> This thing is a year old. Can't somebody just fix it for Pete's sake? I don't
> see the huge challenge in this one.

maybe if we suggested it would make the new theme look better it would get fixed
right away. I have talked to at least one person I have installed firefox who
asked if the "delicacies" phrase was the result of a virus attacking their
browser :0
this *must* go in 1.0 final IMHO. it is not a feature, it is a bug.

Comment 23

13 years ago
(In reply to comment #22)
> this *must* go in 1.0 final IMHO. it is not a feature, it is a bug.

And it will. You can see the blocking flags are plussed. Please refrain from
saying "get this in faster, it sucks". We know it sucks. It will get fixed. You
can see there is already a patch. Once it gets reviewed, it can get checked in.
(Assignee)

Comment 24

13 years ago
Comment on attachment 152371 [details] [diff] [review]
Update for bitrot

I really don't like the look of this.  It looks really unpolished with this. 
Really, I should just fix this section to not suck, period.  Hmm, that's an
idea!
Attachment #152371 - Flags: review?(mconnor) → review-

Updated

13 years ago
Assignee: bmo → firefox
Status: ASSIGNED → NEW
Whiteboard: Patch ready, needs review/checkin.

Comment 25

13 years ago
(In reply to comment #24)
> (From update of attachment 152371 [details] [diff] [review])
> I really don't like the look of this.  It looks really unpolished with this. 
> Really, I should just fix this section to not suck, period.  Hmm, that's an
> idea!
> 

I'm taking this to mean that you're going to fix it? I've un-assigned myself
from the bug.
(Assignee)

Comment 26

13 years ago
yeah, there's a bunch of other bugs in here to smack.

I like the wording, inasmuch as I like any wording ;)
Assignee: firefox → mconnor

Comment 27

13 years ago
should the patch get landed and then improved more as time permits?

need to move quickly on this for the upcoming firefox 1.0 UI freeze. we need to
start locking down to critical fixes in the next week or so.
Whiteboard: [have patch]
(Assignee)

Comment 28

13 years ago
Created attachment 154131 [details] [diff] [review]
better patch, based on wording/layout from options dialog UI redesign
Attachment #152371 - Attachment is obsolete: true
(Assignee)

Comment 29

13 years ago
Created attachment 154132 [details] [diff] [review]
diff -w version of this patch
(Assignee)

Updated

13 years ago
Attachment #154131 - Flags: review?(bugs)
(Assignee)

Comment 30

13 years ago
Created attachment 154159 [details]
screenshot of this (Fedora)
Comment on attachment 154131 [details] [diff] [review]
better patch, based on wording/layout from options dialog UI redesign

>+            <hbox>
>+              <description>&cookieRetention.label;</description>
>+              <menulist id="networkCookieLifetime" 
>+                        prefstring="network.cookie.lifetimePolicy">
>+                <menupopup>
>+                  <menuitem value="0" label="&acceptNormally.label;"/>
>+                  <menuitem value="2" label="&acceptForSession.label;"/>
>+                  <menuitem value="1" label="&askAboutCookies.label;"/>
>+                </menupopup>
>+              </menulist>
>+            </hbox>

use align="center" on this box to make the label line up nicely with the
menulist. Your screenshot shows the alignment as being off. 

OK. r=ben@mozilla.org
Attachment #154131 - Flags: review?(bugs) → review+
(Assignee)

Comment 32

13 years ago
Created attachment 154168 [details] [diff] [review]
patch checked in
Attachment #154131 - Attachment is obsolete: true
Attachment #154132 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Keywords: fixed-aviary1.0

Comment 33

13 years ago
"Cookies are pieces of information stored by web pages on your computer."
I don't have any 'web pages on [my] computer.'

"They are used to remember login information and other data."
The "Stored Passwords" section specifically states its purpose as recording
login information, so there is potential confusion in this wording.

A suggested rewording:
Cookies are pieces of information stored on your computer by Web pages you
visit. They are generally used to offer you a more personalized experience.

And since you used "stored" in the definition, you might consider using that
word instead of "set" for the first checkbox label.
Ok, I'm glad we got something in for now.

Randall: I like your version but and the W in Web doesn't need to be
capitalized, and "personalized experience" might mean nothing to a novice user

How about this:
"Cookies are information stored on your computer by web sites you
visit. They generally keep track of how you want a site to look and who you are
when logged in."

I think someone should write up a help document on possible privacy/security
issues with cookies, and provide links from this page of the preferences to the
respective sections in that document.

Comment 35

13 years ago
(In reply to comment #34)
> Ok, I'm glad we got something in for now.
> 
> Randall: I like your version but and the W in Web doesn't need to be
> capitalized, and "personalized experience" might mean nothing to a novice user
> 
> How about this:
> "Cookies are information stored on your computer by web sites you
> visit. They generally keep track of how you want a site to look and who you are
> when logged in."
> 
> I think someone should write up a help document on possible privacy/security
> issues with cookies, and provide links from this page of the preferences to the
> respective sections in that document.



My version: 

How about this:
"Cookies are information stored on your computer by web sites you
visit. They generally keep track of how you want a site to look and your
identity when logged in."
Created attachment 154431 [details] [diff] [review]
diff -u against AVIARY_1_0_20040515_BRANCH

diff -u against AVIARY_1_0_20040515_BRANCH of Sasquatch's version with
Randall's set -> store change

Updated

13 years ago
Attachment #154431 - Flags: review?(mconners)

Comment 37

13 years ago
Comment on attachment 154431 [details] [diff] [review]
diff -u against AVIARY_1_0_20040515_BRANCH

Changing review? to the right person. But personally, I like the current
description that's been checked into CVS. It's more concise.
Attachment #154431 - Flags: review?(mconners) → review?(mconnor)
(Assignee)

Comment 38

13 years ago
Comment on attachment 154431 [details] [diff] [review]
diff -u against AVIARY_1_0_20040515_BRANCH

store isn't more accurate, and that description is wrong on a few different
levels, but I don't feel like going into details right now.  The description we
have is pretty good, and I don't think we should be focusing on stuff that's
fixed already.	There's a lot more fish to fry before PR1.
Attachment #154431 - Flags: review?(mconnor) → review-

Comment 39

13 years ago
I think "identity" sounds more professional than "who you are".

For the 50 seconds it would take to change, I think it would be worth it to put
in and put this one to bed.
My patch says "identity".

From my patch:

-<!ENTITY cookieExplanation.label           "Cookies are pieces of information
stored by web pages on your computer.  They are used to remember login
information and other data.">
+<!ENTITY cookieExplanation.label           "Cookies are information stored on
your computer by web sites you visit. They generally keep track of how you want
a site to look and your identity when logged in.">



I agree. It'll take a few seconds to check in the new patch, and this bug will
be done.
(Assignee)

Comment 41

13 years ago
Brian, what part of "no" do you consistently fail to understand?  Its a wordy
and imprecise description that I'm not in favour of, so I'm not going to check
it in so you leave it alone.

All I need to do is land on trunk and it'll be just as done, whether you agree
or not.
Status: NEW → ASSIGNED

Comment 42

13 years ago
(In reply to comment #40)

-<!ENTITY cookieExplanation.label           "Cookies are information stored on
your computer by web sites you visit. They generally keep track of how you want
a site to look and your identity when logged in.">

+<!ENTITY cookieExplanation.label           "Cookies are files stored on
your computer by web sites. They keep track of how you want
a site to look and your identity when logged in to those sites.">
I thought about using the word "files" but I thought that might scare people by
making them think that sites are gaining direct access to their hard drive. Its
concievable that cookies could be stored in other things besides files, such as
entries in a .db file or something, right?
(Assignee)

Comment 44

13 years ago
Please stop spamming the bug by discussing something that's already been
rejected.  If you want to debate the merits of the alternate wording please take
it to private email.

And just as a note to the logically impaired, a .db file is still a file, last I
checked.
As far as I know, decisions are generally something agreed upon at least by a
small group, historically, as opposed to decisions made by one person. Especally
when discussing UI, which is often a source of great turmoil when one person
hap-hazardly starts changing the UI on his or her own.

May I remind you that you said:

> Really, I should just fix this section to not suck, period.  Hmm, that's an
> idea!

We are not spamming this bug trying to come up with a wording to replace what
you said was a temporary wording. Remember that this fix has not been put on the
trunk yet. You are dealing with short-term, while we are dealing with long-term.
Would you like us to take this discussion to the message boards? If it were
taken to email, it would not include people who might be interested in having
some input on the new wording.

Aside: My logic was quite accurate. A .db file is not "files", therefore the
wording is inaccurate if you say files. 
That being said, I doubt people would agree on a wording anyway, so I'm
satisfied that the "delicious delicacies" was removed.
(Assignee)

Comment 47

13 years ago
(In reply to comment #45)
> As far as I know, decisions are generally something agreed upon at least by a
> small group, historically, as opposed to decisions made by one person. Especally
> when discussing UI, which is often a source of great turmoil when one person
> hap-hazardly starts changing the UI on his or her own.

First off, decisions on Firefox ARE generally made by a single person, in this
case Ben was the reviewer.  Considering that he is the single person leading the
project, and I used his UI spec as my blueprint, I think you're pretty much dead
wrong and out of touch with regard to how we work on this project.  You're also
not even keeping in mind the Firefox Development Charter (or even the original
version from the Phoenix days).  I also find it alternately amusing/insulting
that you are implying I'm making changes haphazardly.
 
> May I remind you that you said:
> 
> > Really, I should just fix this section to not suck, period.  Hmm, that's an
> > idea!
> 
> We are not spamming this bug trying to come up with a wording to replace what
> you said was a temporary wording. 

The quote was about fixing a number of outstanding issues with the prefpanel,
since the existing UI was a stopgap that had existed for a few months due to
backend changes in cookies.

Please to be showing me where I said this was a temporary wording.  I didn't
even imply it.  I did say there was bigger fish to fry, which meant that trying
to "tweak" it was a fool's errand.  Which isn't to say that I r-'ed the patch
out of a priority-based motive.  Really, the wording is bad, IMO, and that's
where it should end, instead of talking about "just check in my patch and put
this to bed" which completely ignores the previous decision on the patch.

Remember that this fix has not been put on the
> trunk yet. You are dealing with short-term, while we are dealing with long-term.

The reason it hasn't landed on trunk yet is twofold: 1) I had to work on other
fixes instead of dealing with a closed tree at that time, and 2) the locale info
is in a completely different location and I'd need to modify the patch
accordingly, which wasn't a priority.  It has nothing to do with the short or
long term usage of the wording.  Again, a baseless assumption.

> Would you like us to take this discussion to the message boards? If it were
> taken to email, it would not include people who might be interested in having
> some input on the new wording.

The wording as it stands is final, unless you can convince myself or Ben of the
reason it needs to change.  I doubt that's going to happen, considering its
Ben's wording, and you've failed utterly to convince me.

> Aside: My logic was quite accurate. A .db file is not "files", therefore the
> wording is inaccurate if you say files. 

Sorry, I thought you were aware that we store cookies in a single file, I guess
I shouldn't assume you know that much.

Comment 48

13 years ago
(In reply to comment #47)
> (In reply to comment #45)
> > As far as I know, decisions are generally something agreed upon at least by a
> > small group, historically, as opposed to decisions made by one person. Especally
> > when discussing UI, which is often a source of great turmoil when one person
> > hap-hazardly starts changing the UI on his or her own.
> 
> First off, decisions on Firefox ARE generally made by a single person, 


That is too sad. Whatever happened to "teamwork", and "building consensus"?




> > > Really, I should just fix this section to not suck, period.  Hmm, that's 
> > We are not spamming this bug trying to come up with a wording to replace 

> Please to be showing me where I said this was a temporary wording. 


I was also under the impression that it was a work in progress and open to
suggestions. 




> Sorry, I thought you were aware that we store cookies in a single file, I guess
> I shouldn't assume you know that much.

That was a pretty low blow, let it go, Joe. :-)

Comment 49

13 years ago
Mike, can you go ahead and fix this on the trunk, too? It's showing up on my
dependency list in bug 214267.

Comment 50

13 years ago
*** Bug 258295 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 51

13 years ago
Yes, people will hate me for a long time for this, and I'm even blamed by name
in Wikipedia's article.  Bah.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified.
Status: RESOLVED → VERIFIED
http://en.wikipedia.org/wiki/Mozilla_Firefox#Delicious_delicacies

The original text was inserted by Blake Ross, one of the lead developers of
Firefox. It was replaced by Mike Connor.

After this happened, the following remarks were made by Blake Ross over IRC:

    <blake2> congratulations mconnor
    <blake2> you just destroyed a legend!

On August 22, 2004, version 0.1 of the Delicious Delicacies extension
(http://www.squarefree.com/extensions/delicious-delicacies/) was released by
Jesse Ruderman. This extension restores the old description of cookies. As of
November 22, 2004, this extension is in version 0.4.1.
(Assignee)

Comment 54

11 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.