Closed Bug 213316 Opened 18 years ago Closed 18 years ago

choosing mozilla to display an wml file after clicking a link causes windows to open and open...

Categories

(Core Graveyard :: File Handling, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 167320

People

(Reporter: ingrid.merktnichts, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624

opening a page with the address <http://www.stahlrohr.com/wap.wml> causes
mozilla to ask for an application to display the file at
<http://www.stahlrohr.com/wap.wml>, choosing mozilla itself to display this type
of information causes mozilla to download the file from
<http://www.stahlrohr.com/wap.wml> to your download folder (eg
<file:///Users/username/download folder/wap.wml>) and opening a new window with
the file from your download folder <file:///Users/username/download
folder/wap.wml> saving the file again (with the addition -1 in the filename (eg
...wap-1.wml, wap-1-1.wml, and so on) and opening another window, saving the
file and so on.

Reproducible: Always

Steps to Reproduce:
1. goto http://www.stahlrohr.com/wap.wml
2. choose mozilla as application to display the information

Actual Results:  
the downloaded file is being opened in a new window, saved again, the newly
saved file is being opened in a new window and so on

Expected Results:  
nothing? ...the ability to choose mozilla itself to display something should be
disabled (in this case?).
Mozilla can't display this type of file : [text/vnd.wap.wml]

The file open loop should not happen but this is a dupe (AFAIK)
THe issue that Mozilla can't open text/* is bug 57342

*** This bug has been marked as a duplicate of 57342 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Component: Browser-General → File Handling
Resolution: --- → DUPLICATE
matti:
> The file open loop should not happen

I disagree... it's exactly what the user asked for. that said, we have a bug to
disallow setting mozilla itself as a helper application. reading comment 0, the
request here seems to just be to not allow setting mozilla as helper app, so
duping to the other bug...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 167320 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.