[DOGFOOD][Regression] Can't create new Address Book

VERIFIED FIXED in M13

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: hangas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] fix noted in comment)

(Reporter)

Description

19 years ago
Build Date & Platform Bug Found:
 macos commercial seamonkey build 1999-12-09-10-m12 installed on G3/400 OS 8.6
 win32 commercial seamonkey build 1999-12-09-20-m12 installed on P166 Win98
 linux commercial seamonkey build 1999-12-09-15-m15 installed on P200 RedHat 6.1

Overview Description:
 You can not create a new Address Book.  I bring up the "New Address Book"
dialog and enter in a new address book name then press OK.  The ok button
appears broken.  Nothing happens.  The application is still running.  I can
cancel or close the dialog.  No address book is created.

Steps to Reproduce:
1) Open the Address Book
2) Select the File menu and choose New->Address Book
   The new address book dialog appears
3) Enter in a name
4) Press OK
   Nothing happens.  No address book is created.

Actual Results:
 When I press the OK button in the "New Address Book" dialog, nothing happens.
The dialog is not dismiss and no address book is created.

Expected Results:
 When I press the OK button in the "New Address Book" dialog, it should dismiss
the dialog and create a new address book with the name I requested.

Additional Builds and Platforms Tested On:

Additional Information:
 I don't know when this feature broke.  It use to work in M11.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → pmock
(Reporter)

Comment 1

19 years ago
changing qa assigned to pmock@netscape.com

Comment 2

19 years ago
In addressbook.js
top.addressbook.NewAddressBook() should be top.addressbook.newAddressBook().

Updated

19 years ago
Summary: [Regression] Can't create new Address Book → [DOGFOOD][Regression] Can't create new Address Book

Comment 3

19 years ago
marking dogfood.

Comment 4

19 years ago
I used Linux Red Hat6.0: 12-10-08-M12 commercial build - No crash,
but the OK button not activate -- so cannot create new address book.
I have logged a bug#20599 regarding "Cancel & OK button" of the new folder
dialog before, maybe this is a general "button" problems.

Updated

19 years ago
Whiteboard: [PDT-]

Comment 5

19 years ago
PDT says default count of address books is good enough for dogfood
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT-] → [PDT-] fix noted in comment
Target Milestone: M13

Comment 6

19 years ago
Linux Redhat (1999-12-14-11 M12)
The problem is still there.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Fix checked in.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

19 years ago
Verified as fixed on win, mac, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-03-09-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-02-09-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-03-08-M13/NSMacIn
staller-M13.sea.bin
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.