Please add the "Switch Profile..." option to the Tools Menu

VERIFIED WONTFIX

Status

()

Firefox
Menus
--
enhancement
VERIFIED WONTFIX
15 years ago
13 years ago

People

(Reporter: Michael Ernst, Assigned: whimboo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030728 Mozilla Firebird/0.6.1

I use profiles extensively and like the idea of being able to switch profiles
"on-the-fly". Mozilla 1.4 does offer something that will work. They have
included a menu option on the Tools Menu called "Switch Profiles..." (see
screenshot #1). This is great and is exactly what I need. However, Firebird does
not have this option (see screenshot #2) and I have to shut down Firebird and
restart it again with the -p flag. I do not want to use Mozilla because Firebird
is too damn cool in all other aspects, so please don't tell me to switch and use
Mozilla. I am looking to the Firebird developers to just add this piece of code
and this option back into Firebird. Thanks.

Here is a link to the screenshots =
http://forums.mozillazine.org/viewtopic.php?t=13423

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
The "Switch Profiles..." option should have been left in Firebird like it is in
the Mozilla Suite.

Comment 1

15 years ago
Confirming as a new RFE.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla
(Assignee)

Comment 3

14 years ago
Actually the DOM Inspector offers this possibility. So it shouldn't be hard work
to move this entry into the main menu.
(Assignee)

Comment 4

14 years ago
taking.
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Assignee: firefox → bugzilla
Status: ASSIGNED → NEW
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

14 years ago
After a discussion on IRC it's not clear for me if i should start to implement
this. Has this feature a change to be checked in into the tree? If not i have to
handle this as an extension. Ben, could you give me a statement? Thanks.
(Assignee)

Comment 6

14 years ago
Sorry for spam. Ben, could you give a statement on comment 5 how to handle this
feature?

Comment 7

14 years ago
Firefox is not going to expose profile manager or profile switching to the user
in the UI. That it exists in the DOM Inspector is a bug, an artifact of dropping
Seamonkey's DOM Inspector into Firefox.  If you'd like to see UI for this, it's
going to be as an extension.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 8

14 years ago
*** Bug 263197 has been marked as a duplicate of this bug. ***
*** Bug 266254 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
*** Bug 301121 has been marked as a duplicate of this bug. ***
Does anyone know if an extension for this was ever developed?

Updated

13 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.