removing parent of focused elem breaks mouse wheel and textboxes (shacknews.com dthread mode)

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Jason "Draugluin" Ritchie, Assigned: saari (gone))

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MyIE2; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: http://ftp.mozilla.org/pub/firebird/releases/0.6.1/MozillaFirebird-0.6.1-win32.zip

In DThread mode on http://www.shacknews.com/latestchatty.x, when I click a 
threaded reply and the section refreshes using DHTML, my scrollwheel no longer 
works and I cannot enter text into the form at the bottom.

Reproducible: Always

Steps to Reproduce:
1. http://www.shacknews.com/latestchatty.x
2. change the dropdown box from thread to dthread
3. find a thread with a reply
4. click the reply
5. only that section should reload
6a. try to use scrollwheel
6b. try to focus the textbox at the bottom

Actual Results:  
Mousewheel has no effect.
Textbox will not take focus.

Expected Results:  
Mousewheel should scroll the page.
Textbox should allow typing.

This page worked correctly in MozillaFirebird 0.6 for win32.

Comment 1

14 years ago
Confirming..

This is also seen randomly:
http://forums.mozillazine.org/viewtopic.php?p=132355#132355

Blake's seen it too:
http://forums.mozillazine.org/viewtopic.php?p=121079&highlight=#121079

Comment 2

14 years ago
Dupe of bug 212556 ?
(I dont have sufficient permissions to mark it so)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 212556 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
verified with 20030807 build.
Status: RESOLVED → VERIFIED

Comment 5

14 years ago
Not a dup of bug 212556.  This bug is 100% repro and wasn't fixed by 212556's fix.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
I can verify this bug is still present in this build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030817 Mozilla
Firebird/0.6.1+

I can reproduce this problem on the shacknew.com comments 100% of the time. 
Though it does NOT happen on Firebird 0.6

Comment 7

14 years ago
Unlike Peter and Jason, I do see this bug in Firebird 0.6.  I also see this in
nightlies of both Firebird and Seamonkey.

In 0.6, clicking in an empty spot restores scrolling (but seems to make  bug
212556 more likely to happen on an app switch).  In my 08/16 nightly, clicking
in an empty spot does not restore scorlling.

Comment 8

14 years ago
Created attachment 129970 [details]
bottom-up testcase

Comment 9

14 years ago
-> event handling
Assignee: blake → saari
Status: REOPENED → NEW
Component: General → Event Handling
Keywords: testcase
Product: Firebird → Browser
QA Contact: asa → ian
Summary: after innerHTML is updated, scrollwheel and textboxes no longer work in shacknews.com comments → removing parent of focused elem breaks mouse wheel and textboxes (shacknews.com dthread mode)
Version: unspecified → Trunk

Comment 10

14 years ago
my mistake it does happen in Firebird 0.6, was thinking of Mozilla 1.4.

Comment 11

14 years ago
In DThread mode on http://www.shacknews.com/latestchatty.x, when I click a 
threaded reply and the section refreshes using DHTML, my scrollwheel no longer 
works and I cannot enter text into the form at the bottom.

Reproducible: Always

Steps to Reproduce:
1. http://www.shacknews.com/latestchatty.x
2. change the dropdown box from thread to dthread
3. find a thread with a reply
4. click the reply
5. only that section should reload
6a. try to use scrollwheel
6b. try to focus the textbox at the bottom

Actual Results:  
Mousewheel has no effect.
Textbox will not take focus.

Expected Results:  
Mousewheel should scroll the page.
Textbox should allow typing.

This page worked correctly in MozillaFirebird 0.6 for win32.
Works for me, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050402
Firefox/1.0+

Comment 13

12 years ago
(In reply to comment #12)
> Works for me, using:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050402
> Firefox/1.0+

Works as in you still see the bug?  The bug still exists.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223
Firefox/1.0.1

Again, the idea is to click a reply and then try to scroll.  You can not.  You
have to click back on the page in a blank area for action to restore.
Yes, the bug exists in 1.7 builds, but not anymore in trunk, 1.8b builds, as far
as I can tell.
Forgot to tell, you can get and try a 1.8b trunk build here:
http://ftp.uni-erlangen.de/pub/mozilla.org/firefox/nightly/latest-trunk/

Comment 16

11 years ago
This does indeed seem to be fixed in Gecko 1.8.  Tested with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124
Firefox/1.5.0.1

Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.