"Add to Address Book" should make an attempt to parse the name into the Last Name/First Name fields

VERIFIED DUPLICATE of bug 40046

Status

Thunderbird
Address Book
--
enhancement
VERIFIED DUPLICATE of bug 40046
14 years ago
13 years ago

People

(Reporter: Dave Evans, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4; MultiZilla v1.4.0.4A) Gecko/20030624
Build Identifier: Mozilla Thunderbird 0.1 (20030723)

"Add to Address Book" should make an attempt to parse the name into the Last
Name/First Name fields

Reproducible: Always

Steps to Reproduce:
1.View a message
2.Right click on an email address
3.click on "Add to Address Book"


Actual Results:  
The email address is placed into the appropriate field
The associated name is put in the "Display" field
No other information is parsed from the email address

Expected Results:  
"Bob Jones" <bjones@mozilla.org> should parse into:
- First Name: Bob
- Last Name: Jones
- Display: Bob Jones
- Email Address: bjones@mozilla.org

"Jones, Bob" <bjones@mozilla.org> should parse into:
- First Name: Bob
- Last Name: Jones
- Display: Bob Jones
- Email Address: bjones@mozilla.org

Comment 1

14 years ago
This would be a nice enhancement.  The old NC 4.7x had this ability, though it
was not bullet proof.  It had a buggy way of putting first and last name
combined into either or both the first and last name fields on occasion.

Updated

14 years ago
QA Contact: asa

Comment 2

14 years ago
Isn't this a duplicate of bug 40046?

I'd like to see this done too, but it seems that no work has been done on that
bug for quite some time.
(In reply to comment #2)
> Isn't this a duplicate of bug 40046?
>
Yes

*** This bug has been marked as a duplicate of 40046 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.