error messages When page is loaded, when I fill in the form and when I want to send informations

VERIFIED DUPLICATE of bug 127539

Status

Tech Evangelism Graveyard
German
VERIFIED DUPLICATE of bug 127539
15 years ago
3 years ago

People

(Reporter: ch.schuetz, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla 1.4b Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4b) Gecko/20030507

The login to my online banking account on this page does not work. If I press 
"Anmelden" (login) nothing happens. On the JavaScript Konsole I get several error 
messages: 
 
1. While loading the page: 
Fehler: document.all has no properties 
Quelldatei: 
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main 
Zeile: 129 
	and  
Fehler: document.all has no properties 
Quelldatei: 
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main 
Zeile: 204 
 
2. While entering numbers in the form: 
Fehler: event is not defined 
Quelldatei: 
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main 
Zeile: 56 
 
3. After clicking on "Anmelden" (login): 
Fehler: formular is not defined 
Quelldatei: 
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main 
Zeile: 64 
 
I tried with firebird 0.6 as well but I got the same errors. 
 
Perhaps this is a duplicate of bug 54031 which is about problems with https on 
IBM-machines. If this is the case, I'd like to ask, if there is a possibility to work around. 
This is the last reason to have also the Internet-Explorer installed on my PC. 
 
Thanks  
Christoph Sch├╝tz 

Reproducible: Always

Steps to Reproduce:
1. Enter the page: https://banking.diba.de/ 
2. There will popup a formular window. Enter some numbers. You won't need a real 
account. The login procedure does not start. This is the bug I report 
3. Click on "Anmelden" (login). Nothing will happen. 
Actual Results:  
The login procedure does not start. Nothing visibale happens. 

Expected Results:  
The login procedure should start and test if the account and the PIN are right. When 
all is there should be a frame to manage the account. If the PIN or the account 
number is not right this sholud be mentioned in the login window
Those errors just show the page relying on IE "extensions" to the DOM for its
functionality.  Changing those to use standard functions would make the page
work in not only IE but also other browsers.
Assignee: saari → german
Status: UNCONFIRMED → NEW
Component: Event Handling → German
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: desale → german
Version: Trunk → unspecified

*** This bug has been marked as a duplicate of 127539 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
-v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.